6 Replies Latest reply: Oct 22, 2009 5:27 PM by RMG_Music
RMG_Music Level 1 Level 1
Whenever I launch Safari, it opens all my bookmarks in tabs...all 100+ it takes forever to load. How do I stop this??? I can find no settings to alter this behavior. Anyone have a script or something I can do??? I did run a script once to return Safari's tab behavior back to the original functionality after Apple modified the Tab display, but I don't know how this behavior keeps happening.

I need help from the Apple pro's here. Thanks for the help!

iMac 20'', 2GHz, 500 GB HD, 4GB Ram, Mac OS X (10.5.8), Safari Version 4.0.3 (5531.9)
  • Golden Shoes Level 5 Level 5
    What other Input Managers do you have installed, such as Glims? What did you install just prior to this problem happening?
  • RMG_Music Level 1 Level 1
    Hi, just the normal software updates including safari. I must also say that this behavior is occurring on my 1.25ghz Powerbook G4 and not my intel based iMac. I tried deleting safari altogether and download as a clean install but the behavior still persists.
  • Golden Shoes Level 5 Level 5
    Safari isn't the problem, so deleting it and reinstalling it was a waste of your time. Applications are rarely the problem, so unless we know that it definitely is, you should never delete it when you are having trouble with one.

    Try going to Home/Library/Preferences and delete (but don't empty the Trash) the com.apple.Safari.plist file; then restart Safari and see if the problem goes away. You will have to reset all your preferences again.
  • RMG_Music Level 1 Level 1
    That seems to have done the trick, O wise one! One other question, One thing that always irritated me about Safari is whenever I click on a link (website, email, etc..) instead of opening that link in a new tab on my existing safari browser session it open a completely new window even though I have set up the preferences to open in a new tab, what gives..I don't have this issue when using Firefox. I also don't want to have to use a shift key command to do this either.

    Thanks
  • Golden Shoes Level 5 Level 5
    An email link should never open a browser window; your email program should open. If you have the top two boxes checked in Preferences > Tabs, you must Command-click a link to open a new tab; it's always been that way and it's not likely to change. You could also set a hidden preference in Safari via this Terminal command:

    defaults write com.apple.Safari TargetedClicksCreateTabs -bool True

    Then press Enter or Return and quit Terminal. This will cause links targeted links (those that say they will open in a new window in Safari's status bar at the bottom) to open in new Tabs without having to Command-click on them. Untargeted links still require a Command-click to open in a new Tab. However, you could install Glims and it has an option to let you open new tabs without needing to Command-click on a link.

    But, if a link is controlled by JavaScript, it will open in a new window, or in the same Tab you are viewing, regardless of anything else you might do.

  • RMG_Music Level 1 Level 1
    Thank You for the excellent information, Case solved!