10 Replies Latest reply: May 3, 2010 7:00 AM by Tommisauce
Tommisauce Level 1 Level 1 (0 points)
I have a Canon PIXMA MP600R which was set up to use over a wireless network and was working completely 100%.

However I installed Snow Leopard two weeks ago and now the printer wont work wirelessly. I have reinstalled the printer three times now, downloaded the printer updates from Apple and still no joy. I have trawled through the help file and the Canon PIXMA MP600R manual and have still not managed to connect wirelessly even though all the criteria's are met - access point, network configuration etc. The printer does not display in the Utility Printer Network List only in the USB list. When trying to connect to the printer to the router the message 'Printer cannot be found' pop up comes up even though all MAC, IP address, network access are met... any ideas?

MacBook Pro, Mac OS X (10.6.1)
  • Tommisauce Level 1 Level 1 (0 points)
    Hi Pahu,

    Unfortunately the wireless printing still doesn't work.

    I followed all your steps and written in bold what actually happened in the final step – where the procedure failed:

    4. With the driver installation complete, select to add the printer and choose the Default browser view. You will probably see the MP600R as a Bonjour Scanner appear quickly, but we don't wont to select this yet.

    The Canon printer showed up in 'Kind' but only under USB (The Printer was plugged into the computer at the time). I waited – however the printer did not show up as ‘canonijnetwork’. So I am still having the exact same issue. Any ideas?

    We need to wait until the MP600R appears with its Kind column showing 'canonijnetwork'. When this does appear, select it and the Print Using menu will automatically find the correct driver. Click Add to finish adding the network printer queue.


    This is really starting to grate as previously when I was running Leopard the wireless printer was working 100% now with Snow Leopard it’s proving impossible to set up.

    Any help to finally get this issue resolved is greatly appreciated.
  • PAHU Level 6 Level 6 (15,325 points)
    Tommisauce wrote:
    The Canon printer showed up in 'Kind' but only under USB (The Printer was plugged into the computer at the time). I waited – however the printer did not show up as ‘canonijnetwork’. So I am still having the exact same issue. Any ideas?

    You cannot have the printer connected via USB when you are trying to add it as a network printer. Try turning off the printer, unplugging the USB cable, and then turning the printer back on. Give it a minute to connect to your network and then try adding it again.

    Pahu
  • Tommisauce Level 1 Level 1 (0 points)
    Hi again,

    I have tried to connect the printer using your latest advice i.e unplugging the USB cable - and that still hasn't solved the problem. I even ran though the steps - 1 - 3 in your initial email and still no joy. I have also switched the printer / router off and on to see if that had an effect but it didn't.

    When I'm in the default screen to add print - absolutely nothing comes up in Printer Name / Kind -the menu remains blank. Any further ideas? I thought upgrading to Snow Leopard from Leopard was the right thing to do but its plain to see that it has some basic problems still.

    A reply would be most grateful as I still need to solve this issue of printing wirelessly.

    Many thanks again
  • PAHU Level 6 Level 6 (15,325 points)
    Hi there,

    It reads like you have not got the printer configured for wireless. With the default browser view, you should be at least seeing the MP600R as a scanner. Do you know what IP address the MP600R has? If so, you could open the Network Utility application, select the Ping tab, enter the IP address of the MP600R and press Ping. If you get a response then at least you know that the Mac should be seeing the printer on your network.

    If you are not sure of the IP address, I think you can view this via the MP600R display. If you select Device Settings, then LAN settings, then View Wireless LAN List, this will confirm what IP address the MP600R currently has.

    Pahu
  • Tommisauce Level 1 Level 1 (0 points)
    Hi again Pahu,

    I tried what you advised 'opening Network Utility and attempting to 'ping' the IP address.

    I tried both the settings, sending an unlimited amount as well as only sending 10 pings - both failed to work. My router does show 'attached devices' and is showing the printers IP address as well. In attempting to get this wireless thing going is seems to be going backwards rather than forwards.

    I need some help on this big time as it's driving me nuts.. Snow Leopard really leaves a lot to be desired in my opinion.

    However - thanks again.
  • PAHU Level 6 Level 6 (15,325 points)
    Okay, well that explains why the printer is not appearing in the Default browser view. I would try the following...

    1. Confirm that the IP address the printer should have is correctly set in the MP600R. To do this on the printer, scroll to Settings and press OK. Then, scroll to Device Settings and press OK. Now scroll down to LAN settings and press OK. Then scroll down to Wireless LAN Settings list and press OK. This will show you if the connection is active and what IP address is currently set in the MP600R. If this is different to what you believe it should be, then you will have to connect the printer back to the Mac via USB and use the Canon IJ Printer Utility to reconfigure the network settings.

    2. If the IP address is correct and active, then ensure your Mac is set to the same subnet as the printer. Typically the subnet is the first three sets of numbers in the IP address for a home network. For example, if your Mac has an IP address of 192.168.0.5, then you subnet is 192.168.0. In order for the Mac to communicate with the printer, the MP600R would need the same subnet of 192.168.0.x, where x would be a different number to the Mac and router.

    3. If all the IP addresses are correctly set, but the MP600R still does not respond to the Ping, then try turning off the printer for 30secs and then turning back on. Give it a minute to reconnect to the wireless network and then check what IP address it has using Step 1 above. Then try the Ping again.

    HTH

    Pahu
  • Tommisauce Level 1 Level 1 (0 points)
    Hi again,

    after the latest rounds of advice the printer doesn't even show up on the network now - not only that but it's not even showing up on attached devices.

    Whilst in the MP600R default screen > Printer Set up > Utility > Printer List > Product / Type USB shows up but not 'Network' - which we all know. The only buttons below that panel that can be clicked are 'Cancel / Maintenance' the 'Network Settings' button is greyed out. What the **** is going on?? This procedure is going backwards rather than forwards.

    Any ideas that will get this Canon Pixma MP600R working wirelessly would be most welcome and would greatly be appreciated - as I'm losing hair as I've been pulling it out in trying to get this printer functioning.

    Many thanks in advance
  • PAHU Level 6 Level 6 (15,325 points)
    Not sure why this is giving you so much trouble but I believe the MP600R will work fine on Snow Leopard once we get the machine correctly configured. I think I made an assumption that you were printing fine via wireless with another version of Mac OS X. But given that the printer does not appear to have/had an IP address set, then it would suggest that you were not printing previously via wireless. Is this correct?

    To configure the IP address in the MP600R you have to connect the printer to the Mac via USB. Then you select the USB attached MP600R in the Printers list and open the Options & Supplies > Printer Utility. This will open the Canon IJ Printer Utility. Here you select the MP600R and now the Network Settings button should appear. If the button is still not present then you may have to download and install the Canon IJ Network Utility v2.70. In testing 10.6, my printers have already been configured for the network so I have never needed to do this setup step and therefore I am not certain if the facility exists to configure the network settings without this tool being installed. Apologies if this has been the stumbling block.

    Once you have the Network Settings button present, select it and go through the procedures to configure the network settings. Once this process has completed, the setup will prompt you to turn off the MP600R and then disconnect the USB cable. Then when you power the MP600R back on, the machine should be connected to your wireless access point. At this stage you can check that the MP600R has an IP address via the Device Settings menu on the printer (refer back to my third reply to check how this is done).

    Once the printer has an IP address and shows that it is active, you can now add another printer queue, this time for the wireless connected MP600R. Open Print & Fax, select to Add and choose the Default view. As I said in the first reply, you will probably see the MP600R immediately as a Bonjour Scanner, but we need to wait until the MP600R appears with its Kind column showing 'canonijnetwork'. When this does appear, select it and the Print Using menu will automatically find the correct driver. Click Add to finish adding the network printer queue.

    Hope this stops the hair reduction....

    Pahu
  • Tommisauce Level 1 Level 1 (0 points)
    After having another bash at getting the Canon printer to work wirelessly I have managed to do so.

    I followed step 1 - and it worked first time! Not sure how especially after having so many problems with it, but that's computers I guess.

    Many thanks again for the support
    Thomas