3 Replies Latest reply: Oct 25, 2009 1:48 PM by V.K.
JumpingHunger Level 1 (0 points)
I have recently moved my MacBook into the shed so that I can work in peace and quiet. My setup is that I have a Time Capsule connected to my broadband modem, and is acting as the wireless router. The MacBook is set to backup to the time capsule.

Due to my computer being out of doors I wanted to get FileVault up and running in order to make my entire drive more secure.

The problem I get is that it all seems to be working fine, until I log out, shut down or restart which takes approx 8-9 hours EVERY TIME. There doesn't seem to be any incremental backups taking place it just starts again and takes a further 8-9 hours.

Is this a limitation, or can I change the settings? My Time Capsule is secure in the house so I'm not bothered about data security from that end, it's just the MacBook is my concern.

Macbook, Mac OS X (10.5.2)
  • V.K. Level 9 (56,110 points)
    Filevaulted home directories are only backed up when you log out. TM warns you about it when you set up TM. filevault also warns you about it when you turn filevault on the first time.
    this happens for technical reason which i don't really want to go into. let me just say that there is no way around this. this does mean that every backup when you log out can be big and take a long time if done wirelessly but what you describe is very extreme. what kind of work do you do on the computer?how big is your home folder? do you work with any large database files? do you use entourage, or any windows virtualization programs? they all use large database files. also, how long ago did you turn on filevault? was it in Snow leoaprd, leopard, or even a prior OS?

    Message was edited by: V.K.
  • JumpingHunger Level 1 (0 points)
    many thanks for the info. I haven't used filevault before snow leopard so this is a first. With regards to my home folder it's 180gb (upgraded my hard drive) which is mostly documents.

    Due to the nature of the work I do on my MacBook I need the backups done every hour which seems like another limitation sadly. I think the best course of action is to disable file vault and just take the laptop indoors at night!
  • V.K. Level 9 (56,110 points)
    I think the best course of action is to disable file vault and just take the laptop indoors at night!

    probably. given that it's a laptop this should not be a big deal, right? it's still strange why you were getting such huge TM backups. see how it works with filevault off.