Previous 1 2 Next 21 Replies Latest reply: May 20, 2010 7:08 AM by LordKnuth
tseitz89 Level 1 Level 1 (0 points)
For some reason my Unibody Macbook Pro won't connect on a 5Ghz channel on the brand new Airport Extreme (late 2009) instead it connects to a 2.4Ghz band, anyway i can force it to connect to the 5Ghz?

MacBook Pro Unibody, Mac OS X (10.6.1)
  • Bob Timmons Level 10 Level 10 (87,705 points)
    Welcome to the discussions!

    Can your MBP "see" the 5 GHz channel and not connect, or can it not "see" it all?

    Make sure that your MBP is very close to the AirPort Extreme to check if it will connect that way. 5 GHz signals are absorbed by walls and minor obstructions much more quickly than 2.4 GHx signals. In many cases, you almost have to have "line-of-sight" between the computer and router to get a good signal at the 5 GHz setting.

    There are more steps you can take to "force" the 5 GHz connection, but it's pointless to list those now until you can get a 5 GHz connection.
  • Thomas Halenbeck Level 2 Level 2 (395 points)
    Any news here? I have the same problem. My MacBook can see the 5GHz Wireless (side by side located) but when trying to connect to it it ran into "connection timeout". Everything works fine with 2.4GHz.
  • Bob Timmons Level 10 Level 10 (87,705 points)
    There seem to be a lot of "missing bands" posts recently, enough to suspect a possible issue.

    One of the "fixes" mentioned is to turn off the "guest" network and see if you can now connect to the "main" network. If so, then activate the "guest" network again to see if that helps.

    If not, you are experiencing the same issues as a number of other users. We'll have to stay tuned for developments.
  • Loredo Level 1 Level 1 (0 points)
    Same problem here. Also no other computers can connect to the 5GHz network. Disabling the guest network did not solve the issue, not even disabling the encryption.

    Apple, we want a fix pls!!
  • Rafa_sp Level 1 Level 1 (0 points)
    Hi!
    I have the same problem, I just bought a MacBook Pro (mid 2009) and it won't connect (but it can see) to the network in 5GHz mode (Time Capsule) but my older MacBook (2007 or so) can connect without any problems. Now the radio mode in the TC is down to 2,4Ghz so the MB Pro can connect but it's very slow, around 80 mbps to 130 mbps but only if I'm in the same room.

    Other thing: I tried using manual channels but it made no difference, turning off the "wide channels" in 5Ghz seems to work, at least I can connect from the MB Pro but the speed is similar to the ones I get when in 2,4 Ghz mode.
  • Thomas Halenbeck Level 2 Level 2 (395 points)
    I did some tests on the weekend. And basicly it now works. I do NOT have a certain solution, but after messing around for a while my MacBook now connects to 5GHz.

    I started over with totally resetting the dual band AirPort Extreme (Holding the button while power on). Afterwards I did some minimum required configuration with my iMac and AP extreme side by side. As it worked and I could connect now, I moved the AirPort to its final location and the MacBook could connect as well.
    Guest networking was disabled all time.

    Eventhough the MB can connect to it and 5GHs WiFi is the first one in the list of WiFi, it always connects to 2,4Ghz. After Restart or Awake from sleep it takes to long till 5Ghz is recognized. 2,4Ghz works right away and hence the MB connects to it, which is the second one in the list.
    Beside that, 5Ghz is way to delicate. The MB needs to be that close to the router that you rather choose a ethernet cable than WiFi. Sometimes it just does not work at all (Humidity? Moon? Someone is crossing? Tide? Bad breakfast?). I doubt any reliability if there is a brick wall just close to the router. Not thinking about WiFi needs to cross furniture or walls.

    I strictly disadvice to have an AirPort Express configured against a 5Ghz network. As it wont be able to connect to the 5Ghz most of the time, it will remain unreachable and you have to start over with a reset or a wired connection.

    In my environment 5Ghz technologie is not worth a penny. I disabled it and try to forget. May in a couple of years ...
  • Bosakie Level 1 Level 1 (0 points)
    I have had the very same problem. The Issue: you cannot run both the 5Ghz and 2.4Ghz networks at the same time.

    I called Apple on this and they said I needed to disable one of the networks. I disabled the guest network and was able to access the wirless network with my printer and hard drive. I enabled the guest network again and was only able to access the guest network and lost connectivity to the wireless network. To keep people from accessing my Hard Drive I enable access by login to the drive. This allows the to access my printer and internet, but not the hard drive unless they have the password.

    Apple indicated that they will have a fix for this sometime in November.
  • Level 6 Level 6 (11,035 points)
    I got the same issue with my brand new Airport Extreme (AE): "connection timeout". Switched to several settings, always the same dam*n thing: "connection timeout" (took me half a day :-| )

    *I finally went through:*
    *1. By doing a manual restart:* http://skitch.com/two123/nf6t8/airportextrem-manualrestart (restart took several minutes after AE shows up again)
    *2. Important: Guest network need to be switched off !!*
    *3. Turn your Mac's AirPort off/on*

    Proof: http://skitch.com/two123/nf6xp/airportextreme-5ghz-working

    Now, copying a file from my iMac (AE Ethernet) to my MacBook (AE 5GHz) is twice as fast with 11-14 MB/s !!

    My Airport Extreme settings:
    http://skitch.com/two123/nf6xs/airportextreme-settings1
    http://skitch.com/two123/nf6x5/airportextreme-settings2
  • LarsW Level 1 Level 1 (0 points)
    Great! Thanks so much, 77swords - I had the same issue and can now finally connect to the 5 GHz network after following your steps.

    However, copying files from the MacBook to my Mac Mini (both connected to 5 GHz) doesn't appear to be any faster now, although network utility shows me a link speed of 300 Mbit/s. I didn't measure exactly, but shouldn't it be significantly faster? Is there anything else to set up in order to ensure good speed?
  • Jdusoccer12 Level 1 Level 1 (20 points)
    I have this problem too I can get the 5Ghz mode but it won't switch automatically I had to make a separate network name for the 5Ghz and it works now but why won't it switch automatically? And network utility shows speed of 144mbit/s for 2.4ghz and 300mbit/s for 5ghz should it be faster?
  • Bob Timmons Level 10 Level 10 (87,705 points)
    +I have this problem too I can get the 5Ghz mode but it won't switch automatically I had to make a separate network name for the 5Ghz and it works now but why won't it switch automatically? And network utility shows speed of 144mbit/s for 2.4ghz and 300mbit/s for 5ghz should it be faster?+

    Not sure what you mean when you ask "+...why won't it switch automatically?+"

    Are you asking how to get your Mac to automatically log on to the 5 GHz network? Your Mac will automatically select the best connection in terms of signal strength and noise.

    Do you want your Mac to log onto the 5 GHz network first, even though it may not be the best available signal? I'm not sure why you would not want the best signal, but if that is the case, post back for instructions.
  • metalic Level 1 Level 1 (0 points)
    This is all connected to http://discussions.apple.com/thread.jspa?messageID=10717472#10717472

    Its something wrong either with the new chips (Marvel) or the firmware. The autoconnect to 5 GHz is one of many issues...
  • mh1919 Level 1 Level 1 (0 points)
    let's hope it's the firmware, just got a replacement cause the service thought it might be the hardware, was not though...
  • Apophis Level 1 Level 1 (10 points)
    To make your mac choose the 5 GHz link in preference to the 2.4 GHz link:

    Go to Network preferences
    Click the "Advanced…" button
    Drag the networks into the preferred order
Previous 1 2 Next