Previous 1 2 3 4 Next 46 Replies Latest reply: Feb 1, 2010 7:11 AM by Saxlix Go to original post
  • Saxlix Level 1 Level 1
    I contacted Apple customer care here in Poland yesterday - they told me that it was impossible for them to locate an Apple Hardware Test disc for a machine as old as mine.

    Does anyone know where I might find a copy of this disc? One would think Apple could make this more readily available, perhaps as a download...
  • Saxlix Level 1 Level 1
    I found an original set of discs for a PowerMac G5 for sale here in Poland - however, it is for a G5 built later than mine (the copyright says 2005).

    These discs contain Tiger (10.4.2) as well as AHT (2.5.2) - will they work on my G5 from 2004? More importantly, will the hardware test work with my G5 1.6? Thanks!
  • IIe Level 1 Level 1
    On my original discs that came with my G5 1,6 Ghz the version number for AHT is 2.1, but I did use more recent versions of AHT (not 2.5) and it worked. The original system version on the machine was 10.2.7, now we are on 10.5.8, so a more recent AHT makes sense, doesn't it ?
    I guess if you installed a more recent graphic card or other hardware it would also make sense that you would need (would be able) to use a more up-to-date version of AHT.
    Maybe you can find AHT 2.1 online.
  • IIe Level 1 Level 1
    Is your RAM 2x1Gb and 2x512Mb or 3x1Gb ?
  • Saxlix Level 1 Level 1
    My RAM configuration is 2x1Gb and 2x512Mb - I have also experimented with just 2x1Gb with no luck.

    Can you tell me how to find AHT online? They are available for many machines on Apple's website, but the G5 version is not offered as a download.
  • IIe Level 1 Level 1
    Unfortunately, I couldn't find it either.

    I see on your profile that you got MacOs 10.4.11 installed. Did you try installing 10.5(.8) ?

    And did you try running the AHT copy you got. I do not think it can harm your computer. It will probably refuse to boot the CD or tell you that you're using the wrong version. But as I said before, I used a more recent copy with my machine and it worked.

    I could send a copy of the original CD (if it is legal) to your local Apple shop for you, but don't know if you're allowed to post an address (of a shop) on this forum. Wouldn't suggest it myself.

    You should try to call another Apple certified dealer (do they still exist?) and insist.

  • Saxlix Level 1 Level 1
    I haven't received the discs yet - I am bidding on them through a Polish website and wanted to make sure they would work on my machine.

    I did call Apple CS in Poland - they have no more discs for my machine. I might try Apple CS in the States - maybe my brother could forward them to me.

    Thanks for your offer of sending your discs to me, but let me try these other avenues before going down that road...
  • BDAqua Level 10 Level 10
    but the G5 version is not offered as a download.

    Because it was included on the riginl Install Disc(s).

    If you have it Have you booted off the Install Disk by holding the *d key* down at boot-up, (not the c key), and run the extended Apple HW Test? Some Install disks require holding the Option key at bootup to select the AHT.
  • Saxlix Level 1 Level 1
    I installed Tiger with a retail install disc, not the system discs that come with the computer. I don't believe the install disc features AHT - in fact I'm sure of it. And I bought this computer used w/o the accompanying discs...

    I understand that AHT for G5 PowerMacs is on the system discs, but this doesn't explain why it isn't available as a download - my PowerBook G4 came with AHT on the system discs, yet a download for this machine is available on Apple's website.
  • BDAqua Level 10 Level 10
    Oh yes, I wish they were available also, and do not know why.

    I think TechTool Pro has has a similar HWT on it, maybe the Deluxe version also... not sure.
  • Saxlix Level 1 Level 1
    I finally found a system disc for PM G5's - I purchased it and the AHT worked perfectly. However, after 20+ hours (16 loops) of testing, no problems were detected. So any suggestions on what my next step should be?
  • BDAqua Level 10 Level 10
    I see you gave a Crash report earlier, but it didn't contain any useful info really, see this to get an idea of what we need to see...

    How to read Crash Logs...
  • Saxlix Level 1 Level 1
    I am able to find only one crash log from November (although my computer has crashed several times, there are no crash logs other than this one). Here is the information:


    Host Name: power-mac-g5
    Date/Time: 2009-11-21 09:43:19.913 +0100
    OS Version: 10.4.11 (Build 8S165)
    Report Version: 4

    Command: coreservicesd
    Path: /System/Library/CoreServices/coreservicesd
    Parent: launchd [1]

    Version: ??? (???)

    PID: 102
    Thread: 0

    Exception: EXCBADACCESS (0x0001)
    Codes: KERNINVALIDADDRESS (0x0001) at 0x007a0f4c

    Thread 0 Crashed:
    0 <<00000000>> 0x91dcefec 0 + -1847791636
    1 <<00000000>> 0x91dc8f7c 0 + -1847816324
    2 <<00000000>> 0x91de32fc 0 + -1847708932
    3 <<00000000>> 0x91de4034 0 + -1847705548
    4 <<00000000>> 0x91dc667c 0 + -1847826820
    5 <<00000000>> 0x00219a50 0 + 2202192
    6 <<00000000>> 0x002190dc 0 + 2199772
    7 <<00000000>> 0x00218e50 0 + 2199120
    8 <<00000000>> 0x903b57a4 0 + -1875159132
    9 <<00000000>> 0x903ba97c 0 + -1875138180
    10 <<00000000>> 0x903b56c4 0 + -1875159356
    11 <<00000000>> 0x902be080 0 + -1876172672
    12 <<00000000>> 0x902bdf94 0 + -1876172908
    13 <<00000000>> 0x902b06ac 0 + -1876228436
    14 <<00000000>> 0x902afcdc 0 + -1876230948
    15 <<00000000>> 0x902bf13c 0 + -1876168388
    16 <<00000000>> 0x903b4ba0 0 + -1875162208
    17 <<00000000>> 0x0000259c 0 + 9628
    18 <<00000000>> 0x00002440 0 + 9280

    Thread 1:
    0 <<00000000>> 0x9002ba68 0 + -1878869400
    1 <<00000000>> 0x903df7bc 0 + -1874987076
    2 <<00000000>> 0x9002b3c0 0 + -1878871104

    Thread 2:
    0 <<00000000>> 0x9001440c 0 + -1878965236
    1 <<00000000>> 0x9002b3c0 0 + -1878871104

    Thread 0 crashed with PPC Thread State 64:
    srr0: 0x0000000091dcefec srr1: 0x100000000200d030 vrsave: 0x0000000000000000
    cr: 0x24022402 xer: 0x0000000020000000 lr: 0x0000000091dcefe8 ctr: 0x000000009012c520
    r0: 0x0000000091dcefe8 r1: 0x00000000bfffec00 r2: 0x0000000000000000 r3: 0x0000000000000000
    r4: 0x00000000bfffeb74 r5: 0x0000000000000004 r6: 0x0000000000000005 r7: 0x0000000000000004
    r8: 0x00000000bfffeb70 r9: 0x0000000000000024 r10: 0x0000000000000001 r11: 0x00000000a03b175c
    r12: 0x0000000001230898 r13: 0x00000000bfffee10 r14: 0x0000000000000000 r15: 0x0000000000000000
    r16: 0x0000000000289000 r17: 0x0000000000000000 r18: 0x0000000000001b03 r19: 0x0000000000000000
    r20: 0x00000000bffff03c r21: 0x000000007f7efdcd r22: 0x0000000000300f88 r23: 0x0000000000300f80
    r24: 0x00000000a03b571c r25: 0x0000000000001f30 r26: 0x0000000000000000 r27: 0x0000000000305b50
    r28: 0x000000000180d000 r29: 0x000000000180d018 r30: 0x00000000007a0f30 r31: 0x0000000091de3248

    Binary Images Description:
  • BDAqua Level 10 Level 10
    Hmmm, long thread so I'm not absolutely certain what all we've done, but never saw so many Zeros in a thread crash before.

    For this log to be of much use it'd need to show what was running around 0x91dcefec 0 + -1847791636 & 0x007a0f4c

    Seems that would likely be RAM, CPU, Logic Board related, even though AHT found no problem, you can only really trust it if iut finds a problem, not if it doesn't. OSX & a few APs seem to press the RAM harder than any RAM test.

    Any clues in crashreporter.log ?
  • Saxlix Level 1 Level 1
    The only file in the CrashReporter folder was the file I posted. The file is named as follows: coreservicesd.crash.log

    So if I can't trust AHT or Memtest, what exactly can I trust?