12 Replies Latest reply: Oct 30, 2009 7:58 AM by jdqb11
jdqb11 Level 1 Level 1 (0 points)
When i try to open itunes it gives me the error message "Windows cannot access specified device, path or file. You may not have the appropriate permissions to access the item" It was working fine yesterday afternoon and this morning i got this message.

Dell
  • polydorus Level 6 Level 6 (11,950 points)
    Do you have a default installation of iTunes?
    That is to say your iTunes folder is in Music on the c: drive and it contains the iTunes Music folder containing all your music files.

    In the meantime what happens if you do a shift key start?
    Hold down the shift key and start iTunes, keep holding the shift key until you are prompted to choose or create a library.
    Does it get that far?

    If it does you can try both options, first create a new empty library somewhre away from your normal music such as in documetns. This is just a test to see if iTunes can open when it doesn't look for your normal library.

    If iTunes opens like that, what happens if you repeat the shift key start, then select "choose" and navigate to your usual iTunes folder and choose iTunes Library.itl.

    Message was edited by: polydorus
  • jdqb11 Level 1 Level 1 (0 points)
    When i do the shift start i get the same message. My itunes library is under documents and settings under C: drive. This a folder that technically everyone on my server can access.
  • polydorus Level 6 Level 6 (11,950 points)
    If you get the same message when you do a shift key start before the Choose/create dialogue, then the problem is earlier in the open process and probably not related specifically to the library files.

    I was a bit worried by what you said about the server, I am not sure how that is relevant if your iTunes folder containing the library files and iTunes Music on your c: drive.

    Can you confirm that you have a default set up and do not have the music or library on the server.

    Is any specific file or folder mentioned in your error message?
    If not, can you find something more helpful in the Event viewer where Windows puts error messages? You can access it via the control panel>>Administrative tools.

    I forgot to mention, are you using Visa or XP

    Message was edited by: polydorus
  • polydorus Level 6 Level 6 (11,950 points)
    It occurred to me that there is something else you could try in case iTunes is trying to access a removable device.

    Tyy putting a CD or other disk in your drive.
    If you have an external drive that is not plugged in, try plugging it in.
    If you use a memory stick or camera on your PC try plugging it in.

    These are just tests to try and isolate the problem.
  • jdqb11 Level 1 Level 1 (0 points)
    This is the message i found in event viewer.

    The description for Event ID ( 0 ) in Source ( iPod Service ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Service started.

    and this is the message right before the one above:

    The assignment of application Windows Defender from policy NCSECC Policies by Worksmart succeeded.

    Worksmart is who houses our server....I have XP...i can plug up the devices and they work fine
  • polydorus Level 6 Level 6 (11,950 points)
    I didn't mean do the devices work, I meant does Itunes work if they are plugged in.

    Could you confirm that you have a default installation of iTunes and that you do not use the server for itunes?

    If not then it sounds like something got corrupted and may be it is worth trying a full removal of iTunes and related programs followed by reinstall.

    Here is a method for doing this including cleaning up if any of the uninsatlls fail. *if you are unable to delete any of the recommended files or folders report back with details*.


    == uninstall with cleanup ==
    Download a fresh copy of iTunes and the stand alone version of Quicktime (the one without iTunes)

    http://www.apple.com/quicktime/download/win.html
    http://www.apple.com/itunes/download/

    Save the files on your PC.

    Download and install Microsoft Installer cleanup utility, there are instructions on the page as well as the download. Note that what you download is the installer not the program – you have to run it to install the program. The installer doesn't give any message to confirm the installation.

    http://support.microsoft.com/kb/290301/

    (To run the program – All Programs>>Windows Install)

    Now use the following method to remove iTunes and its components:
    XP
    http://support.apple.com/kb/HT1925

    Vista
    http://support.apple.com/kb/HT1923


    *If you hit a problem with one of the uninstalls don't worry*, carry on with the deleting of files and folders as directed in the method.

    When you get to deleting Quicktime files in the system32 folder as advised in the method, you can delete any file or folder with Quicktime in the name.

    Restart your PC.

    Run the Microsoft Installer Cleanup Utility. (Start > All Programs > Windows Install Clean Up)

    Remove any references you find to the programs you removed - strictly speaking you only need to worry about those programs where the uninstall failed.

    If you don’t see an entry for one of the programs that did not uninstall, look out for blank entries or numeric entries that look like version numbers e.g. 7.x for Quicktime or 1.x for Bonjour.

    restart your PC

    Install the stand alone Quicktime and check that it works.

    If it does, install iTunes.

    ===
  • jdqb11 Level 1 Level 1 (0 points)
    I do have a default installation. I removed itunes and tried to download the itunes plus quicktime and it would not let me. It said there was a problem retrieving security settings or something of that nature. So should i uninstall quicktime as well and try to download them seperately like you give instructions to do?
  • jdqb11 Level 1 Level 1 (0 points)
    Ok...i did everything you said do...i uninstalled everything...downloaded the windows install cleanup...then i installed quick time...it worked fine...and then i started to install itunes and i got the same message...error getting file security c://program files/itunes/itunes.exe Get last error:5 ***?
  • jdqb11 Level 1 Level 1 (0 points)
    Any thoughts on what i do now?
  • jdqb11 Level 1 Level 1 (0 points)
    Any thoughts on what i do now?
  • polydorus Level 6 Level 6 (11,950 points)
    Can I just clarify what happened.

    Did you successful uninstall all the programs in the listed in the link and were you able to delete all the recommended files and folders. It is important to know if anything would not delete.

    You downloaded the stand alone Quicktime and installed it successfully and it worked.

    I am not clear exactly what happened when you tried to download iTunes, did you manage to save it on your PC. If you had trouble with the download describe what happened and how you go round it.

    I think you said that the installer would not run which is different from your original problem which was that iTunes would not run.

    Could you give the error message that your get when you try to run the installer *in full*.
  • jdqb11 Level 1 Level 1 (0 points)
    I uninstalled everything having to do with itunes and quicktime. I saved both the stand alone quicktime and itunes setup on my c: drive. I then ran the quitime first and it installed fine. I then tried to run the itunes set up and i received the message that you see above about cannot retrieve file security. So itunes never installed and i keep getting the same error message.