12 Replies Latest reply: May 12, 2010 3:20 PM by jay CRANDALL
Zuggy Level 1 Level 1 (0 points)
I just got my Ipod re-install the whole application and I got the latest version. However, when I try to connect to wifi or app store, it would say "Cannot connect, invalid argument" which is the same as safari and youtube. Does anyone know how to fix this thing?

Ipod Touch, Windows XP
  • MA IPOD NOT WORKIN Level 1 Level 1 (0 points)
    I get the exact same error and I have tried resetting and restoring my ipod I also tried resetting my router and still did not work. Anyone please help me fix this.
  • Followspot Level 1 Level 1 (0 points)
    I have the same problem too, tried to reset several times - please help
  • luvlabs Level 4 Level 4 (3,610 points)
    You are getting that message because you are either not connected to a wireless network, or your connection to the network is incomplete.

    If you think that you are connected (you get the Airport symbol in the top left), go to Settings > WiFi > and tap the blue > next to the network name you are connected to. If your IP address starts with 169.*, then the router you are connected to has not issued you an IP address. There are multiple reasons this can happen from old router firmware to using WEP encryption.

    Post your network details and we'll try and help you.
  • KimmieCee Level 1 Level 1 (0 points)
    I hope that it is ok to piggy back off of Zuggy because I am having the same problem and have done the same thing that Zuggy has done. I have an Itouch and it was working prior to me getting FIOS. Could that have anything to do with it? I was able to see the router that I have and sign in but still can not access the Internet, Apple Store or Itunes. I am a new user and I am not familar with some of the terms... Network detail can be found where? I do appreciate any and all help in this matter.
  • luvlabs Level 4 Level 4 (3,610 points)
    Howstuffworks.com is a wonderful place to learn about wireless networking and what all of the terms mean.

    The default encryption for the Fios router is WEP. Look on the manufacturer's plate on the router and write down the default WEP key. Use that as your password when you log onto your network with the touch. Once you learn more, you will figure out how to go into the router controls and get rid of WEP and replace it with WPA-psk or WPA2-psk encryption. Far more secure and easier to implement.
  • KimmieCee Level 1 Level 1 (0 points)
    Thank you so much. It worked and now I can sign in on the Itouch. I will have to review the website you have suggested to become more familar with the other information that you listed. I am truely greatful for your help.
  • whitem Level 1 Level 1 (0 points)
    LuvLabs.... I need help. My ipod keeps giving me the invalid argument. My IP address starts with 169*... help asap!!!
  • manyshadesofpurple Level 1 Level 1 (0 points)
    I just got the ipod touch 3 today. yay. Upgraded the software. I've spent the past few hours trying to connect to my home wireless network. It's a WEP with 2 Wire modem, DHCP. That's about all I know, and I don't really know what that means. I reset the modem to no avail. When I go into the "settings" on the ipod, I can see my network, which I have "forgotten" and entered several times now...using WEP and WPA. I do intend to visit the howstuffworks website to learn. However, with this being the holiday season, I don't have a lot more time to be fooling around with this. Sorry for the rant...and I appreciate your willingness to assist in any way you can.
    Once I'm at the network on the ipod, it does not seem to want to give me an IP address. One time it let me enter it on my own (under the "static setting"), but still told me I could not access you tube, itunes, etc. I entered the IP and subnet that was on my wireless on computer ("properties"). At least that time it did not tell me there was an "Invalid Argument", but still no access.

    I have looked on the Apple support site, manuals, etc. They do not address this stuff. I am getting thoroughly confused and overwhelmed. Do you have any quick suggestions? Your assistance would be appreciated ~ thank you.
  • manyshadesofpurple Level 1 Level 1 (0 points)
    Hi again! Re: new ipod touch.

    LuvLabs, I went on to howstuffworks and learned I have a lots to learn! Also did what you suggested about the router number for WEP, and it worked as well. I'm sure that's no surprise to you, but it was a very happy one for me ~ thank you!!! Time for bed and back to schedule tomorrow. Many sincere thanks, again!
  • benmin Level 1 Level 1 (0 points)
    Invalid argument/ no valid wifi ip address / can't connect to appstore or itunes

    Had the issue with new 32gb ipod touch. solved easily for me. was runniong WEP64 wireless encryption on the router. instead of using the passphrase for my router, i had to enter the first wireless key.

    go to your routers wireless security settings to find the wep key. once i entered wep key 1 everything came to life beautifully.
  • cacbird Level 1 Level 1 (0 points)
    You had the ultimate answer. Maybe Apple needs to use the language that most are familiar with. The "network password" is a different thing to me than the "WEP key". I have one of both - they are 2 different things as far as I know but the ipod asked for the network password. Thank you for your WEP idea - I spent about 4 hours trying to get mine to work and your answer solved the problem. SOOOOOO many people are having trouble with this.
  • jay CRANDALL Level 1 Level 1 (5 points)
    I am having this same problem. But I am not having the problem with my home router, I am having it at various hotspots I use. I have used them before but now they don't work. Obviously I can't access the router information or power it on or off at these locations. what do I do in this case. Ipod wifi has worked at these and other locations in the past.