Previous 1 2 3 4 Next 59 Replies Latest reply: Mar 7, 2010 3:28 PM by sck7788 Go to original post
  • Level 6 Level 6 (11,035 points)
    Let me add my voice to the growing chorus of puzzled "Magic" Mouse buyers.

    I've got 10.6.1 (the latest available update) installed on my late 2008 MacBook Pro. I followed the directions re pairing the mouse and installing the software, yet no "magic". Found the USB Overdrive thread, went so far as to trash the uninstaller for that program. I've searched for any and all other mouse software and deleted it. My Logitech Connection software has now been trashed and all preferences have been removed. I've removed preferences that in any way might be related to mousing, yet still no magic. It's just a standard mouse, no scrolling, swiping, etc.

    The Mouse system preferences option contains for Tracking Speed and Scrolling Speed (on the left half of the window) and Double-Click Speed and Primary Mouse Button (on the right). There's also an option for Zoom Scrolling below. No mention of Momentum Scrolling anywhere. I've trashed the System Preferences preference file too.

    I've trashed preference files, restarted, downloaded and installed the Magic Mouse software update (1.0) no less than 4 times. I'm at a complete loss about this and I can't seem to find any answers anywhere.

    What gives?

    Interesting, on my one month old iMac running 10.6.1, the software update won't even install. Instead, the error message referring to the need for 10.6.2 shows up.

    Again, what gives?

    This is ridiculous.
  • Rick Prather Level 3 Level 3 (720 points)
    "Found the USB Overdrive thread, went so far as to trash the uninstaller for that program. "

    I don't understand! What do you mean that you trashed the uninstaller?

    Did you run the uninstaller?

    After I located the USBOverdrive uninstaller in my Utility folder, ran it, then everything about the Magic Mouse worked brilliantly!
  • Level 6 Level 6 (11,035 points)
    No, I ran the Uninstaller first. I was just making a point about how far I've gone to right this problem.

    Actually, I'd had USB Overdrive for bit and then disabled it and uninstalled it long ago. When the Magic Mouse stuff started, I searched for and found the Uninstaller and ran it. It correctly told me the program was not on my system. I then trashed the Uninstaller too, out of an abundance of caution. My point was that the USB Overdrive fix apparently doesn't work for everyone.

    When that fix did not solve the problem, I trashed any Apple mouse and Bluetooth preferences, deleted the mouse from the Bluetooth list, ran Onyx to be on the safe side and then restarted. Then I paired the mouse, again downloaded and installed the Wireless Mouse Software Update 1.0 and restarted. When I was up again, I went to the Mouse option in System Preferences and the above-described window came up. This pattern was repeated at least three times before I finally wrote in.

    The mouse continues to be working only as a standard mouse. No scrolling no "magic" effects.

    Still frustrated . . .
  • Rick Prather Level 3 Level 3 (720 points)
    I wonder if there is still a USBOverdrive driver on your system that didn't get deleted because the uninstaller stopped when it saw that USBOverdrive wasn't installed.

    In desperation, I would install USBOverdrive and then uninstall it again.
  • Doug Huebner Level 2 Level 2 (200 points)
    I thought that my Magic Mouse was not working because the swipe did not work on iPhoto [and still does not] but I am discovering Magic Mouse effects in other programs. In Mail a swipe moves you up and down the mailbox contents list. In Google Maps, it drives the map crazy - zooming in and/or out without much fine control making it more than useless, its annoying.

    Any other effects that have been discovered?
  • Level 6 Level 6 (11,035 points)
    Mr. Prather, you have my undying gratitude. Taking your suggestion (and because I was in fact desperate), I downloaded USB Overdrive again, installed it and then uninstalled it.

    When I restarted after the uninstall . . . Magic! I can scroll and (much to the consternation of my equilibrium) I can zoom, etc.

    Additionally, the Mouse System Preferences window is now the proper one (with photos/demos) with (apparently) all the appropriate options. Tracking is a bit slow, but I'll fiddle with it.

    Thank you for your suggestion. It never occurred to me to try the reinstall/uninstall trick.

    Thanks again.
  • Rick Prather Level 3 Level 3 (720 points)
    Great!

    I've had to use that trick a few times over the years with other applications. One of my last ditch efforts when I am flailing around trying to solve a problem.

    Glad it's working for you. I'm enjoying mine and my slightly crippled R hand has never felt better.
  • Dirk Blink Level 1 Level 1 (0 points)
    Many thanks for the heads-up on USB Overdrive, SimonCharlie. Prior to installing the 1.0 software for Magic Mouse, I had disabled it that particular plug-in. However, I got the scroll function to work properly only after uninstalling USB Overdrive completely, as you suggested.

    Since the native tracking speed of the Magic Mouse is too low, I checked the USB Overdrive's author's site to see whether an update is in the works. He states that he is working on one. Good for him, and all of us who use his excellent little programme.
  • drbernd Level 1 Level 1 (0 points)
    Has anybody else this problem on a late 2008 MacBook pro with Snow Leopard?:
    When TimeMachine makes a Backup in background the arrow stutters and stops when using the Magic Mouse. This prob does't occur, when I use a common USB-Mouse.
  • photogFG Level 1 Level 1 (10 points)
    I am having that problem with the Magic Mouse on a Mac Pro. Every time Time Machine fires up, I move the mouse and it seems to be about a 1 second delay before I see any movement on the screen. The same problem with scrolling.

    One other issue I've noted is that when scrolling, the window seems to slide back up by its self sometimes. I have made sure that I am not inadvertently doing anything on the mouse that would make it think I am scrolling back up.
  • Dino1956 Level 1 Level 1 (40 points)
    I'm a bit confused. I thought the Magic Mouse was only offered in a Bluetooth Version ? Is there a USB Version ? Made me think when everyone is talking about USB Overdrive. Also, why would I need a 3rd Party Driver to Install an Apple Product ? Do the Apple Updates not fix these issues ? Thanks in advance. I Just Don't Know!
  • Rick Prather Level 3 Level 3 (720 points)
    You're right, there is only a Bluetooth version. And no third party software is needed.

    The confusion is the reference to USBOverdrive. It's drivers appear to interfere with the Magic Mouse drivers. So, it has to be uninstalled for the Magic Mouse to work properly.
  • Dino1956 Level 1 Level 1 (40 points)
    Great. But as far as I know I have nothing called USBOverdrive. So I should be good to go, correct? Thank you!!
  • tripgrip Level 1 Level 1 (0 points)
    I have a MBP 2yrs. old and I bought a magic mouse and installed it with OS X 10.6.1. The mouse only let you L & R click and scroll with the movement of the mouse and not being able to swipe on the top of the mouse. I then installed the new 10.6.2 update that came out today and everything work on the mouse except that the claimed 30 foot range is only about a foot away and then no response until I come back to within a foot of my MBP.
    Anyone have any ideas??? Thanks
  • Dino1956 Level 1 Level 1 (40 points)
    I was really excited about purchasing the Magic Mouse, but after what I have read in this Thread, I think I may wait & see Apple comes up with some fixes. One Ft Away max for a Bluetooth Mouse is just Unacceptable!