8 Replies Latest reply: Nov 17, 2009 10:46 PM by TuliTaivas
Gilo05 Level 1 (0 points)

I'm completely new with osx server. Installed it 5 min ago

I'm wondering how i manage to get a remote desktop connection from a windows machine to the osx server?
If i try on the windows the remote desktop with the IP of the server it can't connect.

By the way, how to i manage to get a remote connection from mac to mac server?


Imac / Powerbook G4, Mac OS X (10.6.1)
  • Antonio Rocco Level 6 (10,517 points)

    Mac to Mac regardless of whether it's server or Client. Apple Menu > System Preferences > Sharing > Enable the Remote Management option. Make sure you allow appropriate rights in the fields that follow.

    On the remote client go to the Go Menu and select Connect to Server, key in vnc://IPaddressofserverormac. Provide the admin name and password. Or for a fuller featured VNC Server use:


    To control any PC (not XP Home) from a Mac use:


    For PC to Mac make sure when enabling Remote Management you enable the 'VNC Clients may control screen with password' option. Don't use the same password that's been assigned to the local administrator. Next get hold of or download any or all of these:

    Ultra VNC

    Best to use the Enterprise versions as these tend to be more reliable. Not used it myself but AquaConnect is something else you could consider. There are a few more which you could Google for yourself.

  • Peter Scordamaglia Level 2 (380 points)

    The 'remote' desktop connection technology that the Mac uses is also know by its other name, VNC, Virtual Network Computing. Remote Desktop Connection (RDC), the standard Microsoft remote control connectivity tool, is not the same.

    Most versions of VNC that I have tried from a PC, so far CANNOT control a Mac. They connect, but most fail at authentication or say the server is an incompatible version, but you are welcome to look around and see if you can find one that works. If you do find one, remember us and let us know which one does work!

  • Antonio Rocco Level 6 (10,517 points)

    The three I've listed work well every time.

  • Peter Scordamaglia Level 2 (380 points)
    I would politely disagree. Yes, definitely, the Mac 'Screen Sharing' app works a treat, and Apple Remote Desktop.app works as well, but I am coming from a Window's PeeCee.

    For me, connecting to my 10.5(.8) Server via tightvnc gives 'Server did not offer supported security type!". Using RealVNC to this machine states "No matching security types Do you wish to reconnect to ... ?" a telnet to this AppleVNCServer service (port 5900), shows RFB 003.889 *, or Remote Frame Buffer Major 3, minor 889.

    Also, connecting to multiple 10.6(.1) Clients with Tightvnc correctly asks for a password but then hangs at "Status: Security type requested". Using RealVNC opens, connects, asks for authentication, and exits. Telneting to this AppleVNCServer service (port 5900), also shows RFB 003.889 *.

    The Current Version of the protocol is supposed to be 3.8, that is Major version 3, minor version 8. Not 80 or 800 but Eight). http://www.realvnc.com/docs/rfbproto.pdf and I believe that tightvnc only supports up to version 3.7.

    On each station I have installed the 'old' OSXVnc.app as a service (to a unique port). OSXVnc utilizes protocol 3.3 and I can control them successfully, but that is of my own doing because of this issue.

    Now JollysFastVNC works a treat to any machine I have EVER tried to connect to. I have not tried COTVNC or any of the others (too slow for me, when they wer e around)

    Also, I just noticed that RealVNC states that their free and personal version will not connect to Mac OSX (x86 and PPC) but the Enterprise one will. I just Dl'ed the Enterprise Viewer and it gave essentially the same thing ('protocol is not valid' message, even after it asks for a password). Anyway, I am not here to hijack this thread, just trying to keep the info flowing and open.

    Maybe I am the only one with these problems but the bottom line is I cannot use Real or Tight, or UltraVNC to administer my server or clients as long as AppleVNCServer gives out the 003.889 protocol version.


    * The ProtocolVersion message consists of 12 bytes interpreted as a string of ASCII characters in the format "RFB xxx.yyy\n" where xxx and yyy are the major and
    minor version numbers, padded with zeros.
  • Antonio Rocco Level 6 (10,517 points)
    Hi Peter

    I'm not denying there are or can be problems all I'm saying is they work well every time for me and others I know of. Nothing special has been done other than installing the application and configuring the Mac.

    I too am coming from a PC.

  • waldybaldi Level 1 (0 points)
    Connecting to mac from Windows XP PC using realvnc free version.

    Just wanted to add that it only worked for me when setting the colour level to FULL on the realvnc client (Options... button). Without it viewer crashed every time with 10053 error code.
  • lisfolks Level 1 (70 points)
    Worked for me using TightVNC on Ubuntu, just as described: enabled the 'VNC Clients may control screen with password' option in Preferences -> Sharing -> Remote Management "Computer settings" button. Put in a password. Then shared from TightVNC.

    Thanks very much for the instructions!
  • TuliTaivas Level 1 (0 points)
    Thanks, Peter, for the insight and the trick with telnet.

    May I add my own 2 cents?

    I have two servers, one with 10.5.4 and the other with 10.5.8.
    On both telnet shows "RFB 003.889" but to 10.5.4 I can connect with UltraVNCViewer 1.0.2 (internal version number is whereas with OS X 10.5.8 RealVNCViewer 1.0.2 tells me "incopatible version".
    VNC Viewer PE v4.4.3.16583 (from RealVNC) on the other hand warns in both cases "The server is non-standard, and may fail to work...". If continue on 10.5.4 it let's me enter the password but then quits and on 10.5.8 it says "Incompatible Version."

    I also remember havin had issues to connect with newer versions of UltraVNC to OS X 10.5.4, that's why I still use version 1.0.2.

    Occasionally, when I'm connected with UltraVNC 1.0.2 the VNC server on 10.5.4 freaks out. The screen freezes and I have to use putty to kill the service on the Mac server (it autostarts). After that I can connect again.

    It seems there's more to it than a non-standard Protocol Version Message.

    I'm somewhat annoyed of how Apple handles this. After all it should not be that complicated to be compatible to the standard.