Previous 1 26 27 28 29 30 Next 569 Replies Latest reply: Jan 29, 2015 6:56 AM by Spocket Go to original post Branched to a new discussion.
  • Almakos Level 1 Level 1 (0 points)

    You are welcome

    it is easy to find out whether mac is asleep

    try adjusting volume or start music playback with keyboard. if there is sound and screen still black, then obviously mac is awake =)

  • targus Level 1 Level 1 (5 points)

    But wouldn't the keyboard input wake the computer back up?

  • Almakos Level 1 Level 1 (0 points)

    well, ideally it would, but then screen should wake up as well =)

    Another way to check is listen to fans or HDD and try temperature on the back.

  • Plucker Level 1 Level 1 (10 points)

    +1 for the not waking from sleep problem here on a brand new 27" iMAC with Lion 10.7.2 and bluetooth keyboard and magic mouse.  Occasionally (about 3 times a week) after the machine has entered auto-sleep and has stayed asleep for some time (usually a couple of hours at least), the machine will not wake up and I have to power it down with a long press on the power button and then restart it.

     

    There doesn't seem to be anything in the logs on the machine around the time I tried to wake it, only the usual boot messages from the point it was re-started.

     

    Reading this thread I think there is a fundamental issue with the machines waking from sleep with bluetooth devices, though I haven't tried attaching a wired jeyboard to see if that improves matters.  Will have a go at that next.

  • Paul_31 Level 6 Level 6 (13,210 points)

    A 'fix' that works 100% of the time for me is to set Computer Sleep to 'Never' in Energy Saver preferences. I've tried various other suggestions I've seen suggested, but until Apple come out with a proper fix it does get rid of this annoying issue.

  • targus Level 1 Level 1 (5 points)

    Update: the issue has deteriorated for me. Is morning, the usual unresponsiveness was followed by full-on kernel panic upon reboot. Rebooting multiple times when prompted did nothing to alleviate the issue. A Disk Repair attempt was thwarted by an apparently unrepairable disk. I erased my hard disk, re-installed Lion (a much less painful process than I'd imagined - only took an hour for the whole rigmarole) and I'm restoring from a Time Machine backup as we speak. I realize this may not fix the wake issue, but it sure as **** will get rid of the kernel panic, which is my top priority right now.

     

    My big fear at the moment: what if the computer goes to sleep during the backup restoration (7 fraking hours) and cannot wake? What if a reboot in that state somehow fries my Time Machine backups? Too paranoid? I mean, I presume that the computer won't go entirely to proper "sleep" sleep with the backup restoration in process. Am I right?

     

    By the way, has anyone had any luck fixing the wake issue with a clean OS install and backup restoration?

  • targus Level 1 Level 1 (5 points)

    Paul, that's what I was going to try next had my computer properly rebooted instead the whole kernel panic incident and it's the solution I'll try if the OS reinstall doesn't help. Ive done the math, and even here in California where electricity isn't exactly cheap, an idling iMac with the monitor asleep only draws enough power to cost about $10/month. Not exactly free, but even presuming this computer lasts me another 3 years, that's $360, which is still way the **** cheaper than a new Mac, right?

  • targus Level 1 Level 1 (5 points)

    Bad news to report, I'm afraid. I can now say for certain that a complete erasure of the hard drive and a full clean reinstall of Lion did nothing to alleviate the issue. I don't know if that means it's a hardware issue or what.

  • targus Level 1 Level 1 (5 points)

    Bad news to report, I'm afraid. I can now say for certain that a complete erasure of the hard drive and a full clean reinstall of Lion did nothing to alleviate the issue. I don't know if that means it's a hardware issue or what.

  • Paul_31 Level 6 Level 6 (13,210 points)

    Going by the various threads on here discussing this issue I'm certain it's a glitch in the OS rather than hardware. Although this thread stared as a 10.6 issue it's continued into 10.7.

    This is how I have my Energy Saver settings and since doing this, no wake from sleep problems. I've even tried re-instating sleep and the problem comes back. Change back to never sleep and the problem is gone:

    Screen Shot 2012-01-16 at 08.55.45.jpg

  • targus Level 1 Level 1 (5 points)

    That's exactly what I did, Paul. I hate to waste all the electricity, both for environmental and personal economical reasons, but Apple hasn't left me much choice. Though, as I posted earlier, even here in expensive California, an idle Mac with the monitor asleep running 24/7 would cost a maximum of an extra US$10 a month, so I guess it's not that bad.

     

    I just wish I knew why I never had the problem at all until a few days ago. Absolutely mystifying...

     

    Thanks again!

  • Kingstonian Level 1 Level 1 (0 points)

    Just as mystifying is the same problem cleared up for me. I set the 'display sleep' at 10 minutes and moved the 'computer sleep' to 25 minutes. I still use the trackpad and wireless keyboard but have turned off bluetooth speakers when I'm not actually using them. I really don't know what has changed but I don't have the sleep/wake problems (I'll keep my fingers crossed).

  • targus Level 1 Level 1 (5 points)

    I wish things were going that well for me. I awoke today to find my Mac asleep EVEN THUGH I SET COMPUTER SLEEP TO "NEVER" and the usual reboot resulted in a kernel panic DESPITE THE BRAND NEW CLEAN LION INSTALL. I even got a kernel panic when trying to repair the disk by booting with "alt" held.

     

    After removing my Firewire drive, powering down my USB drive, and unplugging my Wacom tablet, however, I wa able to boot normally. Disk checks out as having no issue. I'm starting to suspect my Wacom in the panocs and perhaps even in the sleep issue. Uninstalled unneccessary tools and gadgets associatec with it (along with Adobe Air, which was reqired to run some of it), installed the newest driver, and unplugged the tablet. If the sleep problem - or, at the very least, the kernel problem - goes away, I'll cancel my Genius Bar appointment this evening and chalk one up in the win category...

  • Paul_31 Level 6 Level 6 (13,210 points)

    The Wacom issue rings a bell. Might be worth starting a new thread and post your panic log. Very likely someone will pitch in with some ideas, but I reckon the Wacom is a good starting point.

  • targus Level 1 Level 1 (5 points)

    I have a feeling that the Wacom tablet was the culprit all along. I haven't felt confident about solving this issue until now, but I feel really good about it all of a sudden. I'll let you know how this all turns out.

     

    Thanks again for your help, Paul! And Kingston!

Previous 1 26 27 28 29 30 Next