Previous 1 2 3 Next 71 Replies Latest reply: May 6, 2013 2:23 PM by Joey Wallach
jedicpa Level 1 Level 1
The backup for my mac that serves as the family media server has gotten so big that my original TC cannot back it up. I have bought a second TC dedicated to backing up this mac. Here is my problem... The sparsebundle for the media mac on the original TC takes up over 350 gb of its storage, so I want to delete it. But I can't. Every time I attempt, it tries for about 30 minutes and then errors out saying some of the data cannot be accessed. How can I get rid of this huge 350gb file so that I can free up the space for the other macs on my network?

MacBookPro, Mac OS X (10.6.1)
  • Jolly Giant Level 7 Level 7
    jedicpa wrote:
    How can I get rid of this huge 350gb file so that I can free up the space for the other macs on my network?

    did you try to erase the sparsebundle on the original TC via airport utility > manual setup > disks ?
  • Bob Timmons Level 10 Level 10
    If this is the only sparsebundle on the disk, (in other words, you only have backups from one computer on the TC, then erasing the disk would be the best way to delete the sparsebundle. Careful though, if you have any backups from other computers on this TC, then those backups will be erased as well.

    In AirPort Utility, Manual Setup
    Click the Disks icon at the top
    Click the Disks tab just below the icons
    Click Erase. The Quick Erase option will be fine here.

    If you have other backups (sparsebundles) on the TC, post back and we'll try to tackle that.
  • jedicpa Level 1 Level 1
    Thanks to Jolly and Bob.
  • Jolly Giant Level 7 Level 7
    jedicpa wrote:
    Thanks to Jolly and Bob.

    it's been a pleasure and ... good computing !
  • Ricardo Blach Level 1 Level 1

    I have the same problem, only that I do have more than one sparsebundle on the Time Capsule, owing to having changed the network name of my iMac. In my case I use the TC for file sharing amongst my network so erasing the drive is not an option.

    What I really need is to delete the old sparsebundle from the TC. How can I do that?

    Also, TimeMachine was having problems backing up to the TC and I made a backup to an external (Firewire) drive before upgrading to Snow Leopard. I managed to recover all my data and managed to get TM to back up to the TC again with no incidents, but now I find myself unable to delete the 'Backups.backupdb' Folder from the external drive and I need the space! Can you help with this too?

    Thanks for your help!
  • Bob Timmons Level 10 Level 10
    +What I really need is to delete the old sparsebundle from the TC. How can I do that?+

    Open your Hard Drive and look for the Time Capsule icon under the SHARED heading. Click the TC icon and a folder will appear to the right. Double click this folder.

    You should now see a xxxxx.sparsebundle file for each of the computers that have been backing up. The file contains the name of the computer and the MAC address so you should be able to easily identify the xxxxx.sparsebundle file that you want to delete.

    Click the xxxxx.sparsebundle file to highlight it and then click the gear shaped icon just above and select Move to Trash.

    Be very careful since you will not be able to retrieve the file if you make a mistake and delete the wrong file.
  • Bob Timmons Level 10 Level 10
    +...I find myself unable to delete the 'Backups.backupdb' Folder from the external drive and I need the space! Can you help with this too+

    I haven't had this problem so I can only guess at a solution.

    Hold down the "option" key when you delete the file to see if that will do the trick.
  • drv123 Level 1 Level 1
    I had this problem. Ultimately resolved by calling Apple and having tech march me through commands at the terminal level. Buena suerte
  • ee601 Level 1 Level 1
    Bob Timmons wrote:
    +What I really need is to delete the old sparsebundle from the TC. How can I do that?+

    Click the xxxxx.sparsebundle file to highlight it and then click the gear shaped icon just above and select Move to Trash.

    I have exactly the same problem. I've tried doing that, and I get a dialogue box that states "Deleting…" but stays forever with no blue in the progress bar at all, and it never actually gets deleted. Am I missing something? Sharing and permissions for that sparebundle shows that everyone can read and write, and it's not locked.

    Any help would be much appreciated as I'm driving myself nuts with this...
  • Charmian Gaud Level 1 Level 1
    I had a 24 iMac backed up on 2TB Time Capsule. Bought a 27 iMac to use as my main machine. I successfully ransferred the data from the 24in so the 27 was now my main computer - but just in case I kept the 24in iMac as it was with the backups to August.. On the Time Capsule 540GB + changes since August on 24iMac of course became 900GB, there was a Powerbook too & the new 27in had 540GB of Time Machine data. So there was only about 350GB left on the Time Capsule where it could age gracefully....

    Then disaster the New iMac less than 14 days old has errors and a bad disc drive hardware fault - not wanting a repaired new machine - I took up the Apple guarantee and got a new replacement machine. Time Capsule was used to brilliantly transfer the new Snow Leopard stuff I had on the broken 27iMac. So everything is working well but what to do with Time Capsule as only 350GB remained and I wanted to DELETE the broken machine which took up about 600GB data not the still functioning and useful data for the 24in iMac.

    I found this discussion forum and tried the delete sparsebundle for the broken Mac as described. Went through the instructions easily and set it up to delete overnight. In the morning it was still trying to delete this massive single "file". The Finder had spinning ball but everything else was working. So eventually after 12 hours I rang Applecare. They weren't keen to go to Terminal to fix it but said the size of the file meant it could take another 4 or 5 hours.. After 24 hours I decided to pull plugs. When I restarted there was still only 400GB free - not enough. So I control clicked on Sparsebundle and chose Inspector - this took a long time but a "Get info" box came up and then when I opened the defunct machine Sparsebundle>Bands> - a list of 65000 x 8mb documents were listed. So starting with a couple of these docs - I clicked Move to Trash - accepted instant delete and they were gone. Bravery eventually took over and a bit of waiting but I found I could happily delete 25GB of these documents at once. A couple of times it said a document couldn't be deleted but then if I found it individually, it would delete (So I am guessing that that was the issue in the big single file delete earlier where it went into spinning ball). In 3 hours of intensive deletion work - the whole of the dead machine Time Machine data was gone (I guess this was something the programming savy would use Automator for!!) and 900GB is now available for me to attach the Time Capsule to the NEW 27in and start again with backups without the risk of deletions occurring on the 24in iMac backups to August which I did want to have access to.

    So this is a long saga but for anyone having problems with deleting Sparsebundle - you might need to control click for Package Contents and then delete in reasonable sized bundles of documents. Its a bit like not overworking a shredder!! I guess 500 GB is about as large as anyone would need to delete!!

    25GB took about 10 minutes to delete so the 500GB sparsebundle single document should have deleted in about 3 hours.

    BTW the Guy at Applecare did say there might be a way of changing the machine ID but he thought the cleaner way was to try to delete the Sparsebundle.
  • nolamonte Level 1 Level 1
    Sorry, but same problem and have keen interest in your solution. You say "I chose Inspector"... apparently in 10.6.2, there is no Inspector, but there is Show Info. Is this the same version of the OS?
  • Charmian Gaud Level 1 Level 1
    You in fact have to wait for the bands to be listed..
    It does work on 10.6.2
    Open Network (not Time Machine hd)
    Then from Network choose Data
    Then Sparsebundle..
    Holding Control click sparsebundle and you get open Package contents
    Then double click BANDS folder
    It looks like it is empty - but if you wait the huge list of bands will show. Mine had 65000
    Get info shows the size of the group of deleted files.
    Hope this works for you. It is a slow process but more reliable than trying to delete the whole sparsebundle package as if one thing goes wrong you have a spinning ball whereas you can ignore any file that won't delete at first with Bands showing. ANd I found on the second attempt it would delete an "locked" file.. I found although it took a few minutes each batch delete it did work and up to 8000 items per delete was possible.
    Good luck
  • Richard Tench Level 1 Level 1
    Mac OS X
    Charmian, thank you so much! I've had problems with this for ages, and your solution works perfectly.
  • Marchman Level 1 Level 1
    Charmian - Thanks for the help. It has helped me get rid of my corrupted sparsebundle. After a week of trying with no success the only way was to go one by one through the bands folder. 72000 files later all is sorted. The nice thing is you are able to see the files being deleted in the progress bar.
    Thanks again.
Previous 1 2 3 Next