Previous 1 2 3 4 5 Next 71 Replies Latest reply: May 6, 2013 2:23 PM by Joey Wallach Go to original post
  • 1randomstring Level 1 Level 1
    10 Points for Charmian! This was a difficult problem for me to. Thanks for posting the question, and thanks for the answer Charmian.
  • ADG UK Level 1 Level 1
    Charmian - the good news is you seem to be the world's expert on this issue, the bad news is that it seems everyone else is able to follow your instructions to delete the sparsebundle file - except me. I have Mac OS 10.5.8 and therefore Inspector is not present. So I tried the Network option you suggested but this didn't give me a data file, it just navigated me to the time capsule and the sparsebundle file in the same way...

    Can you help because I now have a corrupted sparsefile and therefore no backup - I feel in the uncomfortable position of 'backup limbo'. Can you help? Thanks
  • Pondini Level 8 Level 8
    Do you have any other data on your Time Capsule?

    If not, you should be able to just erase the disk via +*Airport Utility.+* Select +*Base Station > Manual Set-Up+* from the Menubar, then Disks in the tool Bar, then Erase. That's very quick.

    If you do have other data there, you could copy that data elsewhere (such as your Mac's HD or and external HD connected to your Mac), erase the disk, then copy it back.
  • ScottandApple Level 1 Level 1
    This works for me. But you can greatly speed up the process by plugging your computer into the the Time Capsule via ethernet. At least that is what is happening for me.
  • marzer Level 1 Level 1
    UGH!! This is nuts. Why do file deletions take so long on a TC!

    My 2TB TC maxed out. I had TM (sparsebundle) and non-TM files (mirrored files) on the TC. So I first started by trying to delete a redundant sparsebundle. In 24 hours it deleted 84GB of a 874GB sparsebundle. Then I tried to delete the file mirrored file folder structure, pretty much the same rate of response.

    Drilled down to the bands and even that took a ridiculous amount of time; several minutes for 1 band, indeterminate for 8000 bands (after an hour I stopped monitoring). Not to mention that with over 100 thousand bands, this is no small effort by subset. And I'm connected via 1Gb ethernet.

    I can delete whole file structures in seconds to minutes (depending on size) from any other network shares; iMacs, Linux boxes. Why is this such an tedious task on the Time Capsule.

    I have other TM backups on the TC, but obviously it would be much quicker to erase the drive and just re-initiate the TM backups from the multiple machines! But that seems such a ludicrous solution.

  • marzer Level 1 Level 1
    UPDATE - So I used Chronosync to "mirror" an empty folder to the file folder structure on the TC, with the "delete immediately" option turned on. This still took much longer than with other (non-TC) network shares but was able to empty the TC destination folder, of 800GB, in 21 minutes. I'll try it with the "bands" folder in the sparsebundle I've been attempting to delete.

    Definitely an issue that warrants a fix patch in my opinion.
  • mikecorp Level 1 Level 1
    Is there a faster way to delete sparcebundle files? how do you do that?

    I'm now deleting a sparcebundle via ethernet cable pluged into a Mac PRO -> bundle is 645 GB in size. It is deleting now for 5 days and 11 hours. and I have 400 GB to go. This is crazy!! so before I delete it I will end up around 20 days? Who will pay the electricity bill?

    -Should they implement e-sata into TC?
  • rosskopp Level 1 Level 1
    here is possibly an easier solution to deleting the sparsebundle.

    follow the steps Chairman Gaud listed:
    "Open Network (not Time Machine hd)
    Then from Network choose Data
    Then Sparsebundle..
    Holding Control click sparsebundle and you get open Package contents"

    ... but instead of going into the BANDS folder, right click on the token and take the check mark out of the locked box and close. after this, select delete.

    this should work
  • John Christiansen Level 1 Level 1
    Thanks a lot to rosskopp. This makes sense.

    It should be included into the documentation, that this is a simple way to delete a sparsebundle backup. And it works. Without any terminal commands ect..
  • Robert Young4 Level 1 Level 1
    The problem I run into, is when I try to delete the files in the bands folder, it may delete 2000....and then freeze....or 5000...and freeze....or only 200...etc etc etc. However, if you can "restart" the finder (from Force Quit) before each deletion, and then select around 3-5000 & hit "trash", the freezing goes away in large part. Once and awhile it may still freeze up half way through, but generally, if you restart the finder before each deletion, it seems to go more predictably and reliably....just beware of taking "too big a bite" each time....
  • John Christiansen Level 1 Level 1
    Hi, This has been answered with a simpler and working solution. Please read the solution from rosskopp .

    Have great day.
  • vikg Level 1 Level 1
    Rosskopp, The Unlock box (in the Get info dialogue box?) was not checked for the "token" file file in my case. Are you suggesting simply deleting the "token" file will 'delete' the sparsebundle or allow for it to be deleted manually? Can you please clarify? Apologies if I'm missing an obvious point.

  • John Christiansen Level 1 Level 1
    Welcome here vikg,

    I think the solution with the "token" file came about, as some of us experienced that it was not possible to delete the sparsebundle, as the system reported "token is locked" or something like that. If token is locked, then you need to get it unlocked in some way.

    If you do not have the "locked token" issue then you should be able to go on to delete the sparseimage right away.

    Message was edited by: John Christiansen
  • vikg Level 1 Level 1
    John, If only it were that easy. I'm having the same issue as others where the delete progress bar doesn't seem to move. I suppose I can try the deleting bands method. I was hoping this token method may save me the pain.
  • John Christiansen Level 1 Level 1
    I'm sorry, but my knowledge on this - as on most other things in life - is limited. I would suggest to try to mail or call Apple directly. I guess that it is not an option to just erase and start over with the TC for you? Good luck.