Previous 1 2 3 4 5 Next 71 Replies Latest reply: May 6, 2013 2:23 PM by Joey Wallach Go to original post
  • neilfromsheffield Level 1 Level 1 (0 points)

    Had all the problems desribed above.

    Sorted it by using Windows via VM, worked a treat.

     

    56.8GB 158 mins

     

    ?why?

  • nero4life Level 1 Level 1 (0 points)

    This worked perfectly for me!

     

    Graveyard deleted the sparsebundle file.. it will take a few minutes

  • dommac1 Level 1 Level 1 (0 points)

    I have had a similar problem. The sparsebundle for the backup of my macbook pro was corrupted on account of me trying to reduce the size by deleting old backups.

     

    Apple care advised me to at least delete the sparsebundle or reformat the Time capsule.

     

    As I have a network share and one other mac backing up to this capsule. I couldn't do that.

     

    I tried several options suggested here - using parallels, using smb commands but all resulted in the same: finder tried to delete the file (800MB+) and often had no joy for upwards of 12 hours.

     

    Thanks to Tercla above I downloaded Pathfinder by Cocoatech. I deleted from within the menu of Pathfinder, left it for an hour and retunred to find the bundle gone.

     

    I fully recommend this solution and thanks to Tercla for the advice.

  • adjoas Level 1 Level 1 (0 points)

    this worked for me too -- or seems to be. i'm deleting a 700 gb sparsbundle from my 1 tb time capsule as i type. my macbook pro died, and when i got it refused to find & resume backing up to the pre-existing sparssebundle. the folks at the genius bar fidled with things but basically said, you have to delte the old file and start anew. no normal method of deleting the old file seemed to work. but i downloaded Pathfinder and it seems to be processing the delete as i type. it looks like a really handy file manager utility, as well. gonna try for the 30 day trial.  thanks for posting tercla.

  • Qvarnis Level 1 Level 1 (0 points)

    Well for me it turned out to be real simple (as a unix/linux (former) user).

    1. Turn of timemachine

    2. Open Terminal.app

    3. Type: sudo -s

    4. Enter your adminstrator password

    5. type: cd /Volumes/YOUR_TC

    6. Type: ls -la

    7. You should now see your sparsbundle file in the list

    8. Carefully type: rm -rf YOUR_SPARSBUNDLE_FILE

    9. Wait for a while, took me 10 mins for a 550 GB sparsfile

     

    Good luck

  • Brian Yamanaka Level 1 Level 1 (0 points)

    Qvarnis has the best answer.  No need to buy software or use Windows.  Just be careful if you haven't used the terminal before as 'rm -rf' is a pretty dangerous thing if you don't specifcy the correct file.

  • Mark Thacker Level 1 Level 1 (0 points)

    Agreed. I had the same problem with my Time Capsule and erasing the whole disk wasn't an option due to other backups on the disk.

     

    The machine in question had successfully done a new full backup and thus had a new sparsebundle file.

     

    Executing the 'rm -rf' on the suspect .sparsebundle file did the trick and reclaimed 500+ GB in just a few minutes. The Finder just wasn't cutting it here, but go ol root from a Unix command prompt saved the day!

  • Scott Aronian Level 1 Level 1 (30 points)

    The application "Graveyard" mentioned by Daniel Derome in conjunction with unlocking the token, provided an instant delete of the sparsebundle from TimeCalsule.

     

    Show Package of sparsebundle on TimeCapsule

     

    Get Info on the token, and unlock

     

    Drag onto Graveyard

     

    Thanks everyone, this was a big help.

  • shifty pieces Level 1 Level 1 (0 points)

    Also, for the unix noobs out there ( like my self ), if you've got a space in your time capsule name, you put a \ before it. ie

     

    My Time Capsule

     

    would be

     

    My\ Time\ Capsule

     

    thought I'd save you a google.

     

    oh and this truly is the best way. Took only a few minutes for me. Praise the command line.

  • zredbaron Level 1 Level 1 (0 points)

    I tried nearly all solutions listed on here that did NOT utilize a third party app. NONE of them worked for me (not even the Windows approach). I finally resorted to Graveyard, which blew me away at how simple and effective it was.

     

    Graveyard deleted the file fairly instantly (over 500GB in < 5 mins). If you browse to the folder where the sparsebundle is in Finder, you can see the space freeing up as the process is working (Graveyard has no progress bar). 

     

    Did I mention Graveyard is the best solution posted here? 

  • Qvarnis Level 1 Level 1 (0 points)

    Did I mention Graveyard is using 'rm -rf' ?

  • jnazario8181 Level 1 Level 1 (0 points)

    Thank you for your procedure! I was able to remove the files and now have been able to remove the sparsebundle that I wanted gone.

  • randisummer Level 1 Level 1 (0 points)

    Thank you SO much for the Graveyard suggestion.  I don't care HOW it worked but it did work.  Got rid of a sparsebundle from my son's computer without touching all my media files and my own sparsebundle.

    Thank you, thank you, thank you!

  • Ringale Level 1 Level 1 (0 points)

    Charmian, you're the one!!!

     

    Thnaks so much for your help!!

  • kryskat Level 1 Level 1 (0 points)

    Hello everyone,

     

    I have been trying to delete the sparsebundle files, and did what Charmiann suggested with deleting the data files individually, and have been at it now for over 24 hours! I like so many others, have over 65K files, and it is taking forever.

     

    Downloaded Path Finder, as I saw that as another suggestion, but the "reveal" does not show up when I right click on my sparsebundle, and I have searched everywhere to figure out if I missed something (which I probably did). Then I continued reading, and I see "Graveyard" as another option, but the icon sits on the dock for me to drag and drop the file and then disappears.

     

    I am sure it is probably something that I have missed in the blogs, and have read them backwards and forwards to find out what to no avail.

     

    PLEASE help!