5 Replies Latest reply: Mar 1, 2010 4:38 PM by David Mansaray
Robert Middleton2 Level 1 (0 points)
I am not sure if I am having a problem with my BLUE Snowball microphone or with my Mac's ability to plug-n-play a USB audio input. So I write in hopes that somebody smart will have encountered a similar problem before.

I have not used my Snowball in a year (when it worked just fine). In the meantime I have not changed computers but I have updated the system as recommended. I'm running 10.4.11 on my iMac Power PC G5. When I plug the Snowball's included USB cable into a port on the back of computer a red light shines on the microphone indicating it is drawing power from USB. It never shows up as a device available for sound input in the Sound system preferences panel. I've tried restarting a number of times with no luck.

Frustrated with my expensive paperweight Snowball...

iMac 2.1 GHz Power PC G5, Mac OS X (10.4.11)
  • Jeffrey Lee Level 4 (2,500 points)
    So I don't have one of these babies, but do you need to download and/or install some drivers for this device?

    I have an M-Audio device that does the same thing... plug it in, lights come on, but it doesn't exactly show up correctly as an audio device...

    i'd think there would be some settings that the software might control....
  • David Mansaray Level 1 (0 points)
    i just received this mic today myself and im having the same problem did you managed to get it fixed? im hoping that its not the mic itself. I really dont want to have to send it back
  • David Mansaray Level 1 (0 points)
    ok after about 40 mins of trouble shooting in my last attempts to get this sorted i found out that the usb micc that was supplied was faulty. when i changed the usb cable everything works perfectly
  • aldous1334 Level 1 (0 points)
    it doesnt look like hes checked this post in a while. it sounds like some standard tech troubleshooting thats needed. call customer service for the problem, try installing the drivers or reinstalling them. if you want to go this far, reinstall the os and see if it works.
    and when you say you tried restarting multiple times, did you mean restarting whatever programs you were using, or rebooting the system?...
  • David Mansaray Level 1 (0 points)
    the usb that was supplied was faulty***** sorry jsut realised the typo in my first post