3 Replies Latest reply: Jan 21, 2010 10:45 AM by weikeld
lovefever Level 1 (0 points)
Hi, I am new to MAC. I tried to copy some files to my external HD but the "sharing & permissions" says the device is read only.Hence I am not able to delete or copy any files to my External device. Please help me out.

macbook pro, Mac OS X (10.6.1)
  • V.K. Level 9 (56,110 points)
    how is the drive formatted? if it's a windows drive formatted NTFS it's not natively writable from OS X. select the drive in finder and enter command+i. read off the format in the popup. what is it? if it's NTFS then you should either reformat it for use with mac (mac os extended for mac only or FAT for bath mac and windows) or use some software like NTFS-3g that lets you write to NTFS drives from OS X.
  • K T Level 7 (23,700 points)
    Hello lovefever & welcome to discussions...

    Is this a new external drive?

    If so, look in the Applications/Utilities folder and run 'Disk Utility' - reformat the drive for OS X ...if you need details, speak up and good luck in any case.

    If not, are you the only user on the computer?
  • weikeld Level 1 (0 points)
    I am having a similar problem, but I cannot unlock the drive - as there is no lock icon .The drive is one I bought at Best Buy, and is formatted FAT32. I cannot see anywhere to unlock the drive since I moved to SL. It worked fine before I did the conversion. My other drives (I have 5 total) allow me to read and write, but the problem drive is set to read-only. Any suggestions? The specifics in info are: Kind: Volume, Modified: Yesterday..., Format: MS_DOS (FAT32), Capacity: 319.99 GB, Available: 106.48 GB, etc... Shared Folder is unchecked. Sharing and Permissions says "You can only read"

    Thanks for the help!