7 Replies Latest reply: Nov 28, 2009 6:46 AM by Robert Is Confused
shaknon Level 1 Level 1 (0 points)
Hi,

Whenever I disconnect the power cord of my MacBook, the OS shuts down within 2-5 seconds. The battery is installed and it has a 80% health and it has 185 charge cycles. I've been experiencing this strange behavior after two days of installing (Secrets Preference Pane). But I'm not sure if it was behind the problem. I even uninstalled Secrets preference pane but the problem still exist.

At first I though the battery is dead, but for some reason I tried running the laptop later on the battery power and it ran for whole 2+ hours until it was fully discharged. I then charged the battery fully and used it again and it was working like a charm. But later the problem returned and the MacBook shuts down whenever it is not connected to the power cord. If the battery was dead, then how come it runs without a problem sometimes? also the health indicator shows that the battery is 80% healthy and the charging cycles is not much and whenever the system shuts down, the indicator on the bottom of the battery shows that it is fully charged.

I don't know what is causing the problem, and why sometimes the problem arises and sometimes it goes away.

I am using a 2007 white MacBook with the original battery (provided with the laptop). I am running Mac OS 10.6.2.

I tried several solutions such as:
- Cleaning the battery and MacBook ports.
- Resetting the PRAM.
- Fully discharging the battery and then fully charging it.

But it seems that I am not able to resolve the problem. I would appreciate any provided help.

Thanks,
shaknon

Note: Here are two pictures that shows stats about the battery:
1- http://jump.fm/SAOBW
2- http://jump.fm/JBHYI

MacBook 13" White, Mac OS X (10.6.1)
  • 1. Re: MacBook Shuts Down After Unplugging Powercord Although Battery is Insta
    shaknon Level 1 Level 1 (0 points)
    Anybody can help?
  • 2. Re: MacBook Shuts Down After Unplugging Powercord Although Battery is Insta
    Simple_As Level 1 Level 1 (0 points)
    I had a similar problem where the battery was fully charged id unplug the AC and after a few minutes the Mac would completely shut off with no warning.

    After a heated discussion with Applecare i was passed a link for a battery update:

    http://www.apple.com/downloads/macosx/apple/firmware_hardware/batteryupdate14.ht ml

    After i installed this my Mac was back to normal,

    Hope this helps
  • 3. Re: MacBook Shuts Down After Unplugging Powercord Although Battery is Insta
    shaknon Level 1 Level 1 (0 points)
    Thanks for your reply, I downloaded the file but when I run it a pop-up appears on the screen with the following message (This update requires Mac OS X Tiger 10.4.11 or newer or Mac OS X Leopard version 10.5.6 or newer.). I am running Mac OS X Snow Leopard version 10.6.2 and it seems this update is not compatible with the latest version.

    Also, note that in my case, when I unplug the power cable, the OS shuts down within 2-5 seconds and that happens in both cases, when I am running Mac OS, or when I am using Windows 7 as a bootcamp. I think it is a hardware failure in which the battery is damaged somehow and that is why I ordered a new battery for my MacBook.
  • 4. Re: MacBook Shuts Down After Unplugging Powercord Although Battery is Insta
    Robert Is Confused Level 1 Level 1 (0 points)
    I am having identical issues as you described - although I haven't installed secrets preference pane (so I doubt that's involved).

    My problem went on for hours one night, I got sick of dealing with it and went to sleep with AC adapter unplugged and macbook off. The next day, it worked fine all day long. Now here I am in the evening - had a power cut, AC adapter went off obviously, and MacBook powered off. Again now I have this problem.

    I tried everything you've talked about (PRAM reset) as well as SMC reset, no change. My battery stats look great, says battery is healthy. This started happening to me a few days ago, I upgraded to 10.6 a few weeks ago.. not sure what caused this to start happening.

    I found one VERY interesting thing, maybe you can check this: when I have the problem, with AC adapter unhooked, when I try to power up my MacBook it comes up for 2-5 seconds (sometimes until the apple tone, sometimes not), and turns off. If I HOLD THE POWER BUTTON for 5+ seconds the MacBook remains on, the white light on the front flashes, and I get a long tone. This procedure is supposed to be used for firmware updates or something. Anyway, when I do this, the computer comes up perfectly and it uses the battery. When I hook an AC adapter up, that works, but as soon as I unplug it I am back to the same problem. You should try this and see if it works for you, it may be a clue. If nothing else, it's a good way to still use your laptop if you are on the go and can't be dead in the water

    My wife has a MacBook slightly newer than mine, I'm going to try her battery when possible to see if that solves the problem. I hesitate to go to the genius bar as they are terrible where I live and it's always been a waste of time

    (Also, the battery update fails for me as well).
  • 5. Re: MacBook Shuts Down After Unplugging Powercord Although Battery is Insta
    shaknon Level 1 Level 1 (0 points)
    Well, we seem to have the exact same problem. I remember holding the power button for 5+ seconds and the MacBook will work on the battery power just fine. Of course, later the problems occurs again and I am not sure why but it might be because of plugging the AC adapter and then removing it.

    What made take the decision of buying a new battery is that I tried my cousin's MacBook battery on my machine and it worked fine and when I installed my battery on his machine the problem happened with him although he is running Mac OS X Tiger and did not experience such a behavior before. That made me realize that it is a hardware failure problem since I ran the battery on two different machines with two different Mac OS X versions and the problem was still there in both cases. However, I am suspecting that installing Mac OS X Snow Leopard might damaged the battery in some way, but I am not sure about it.

    I am expecting the receive the new battery within few days. I will try it and inform you about the results.
  • 6. Re: MacBook Shuts Down After Unplugging Powercord Although Battery is Insta
    Chryse Level 1 Level 1 (0 points)
    I've got the exact same issue. I'm on a white Macbook (late 2006), it's literally just come back from the Apple store after having a new hard drive fitted after the old one failed. System profiler says the battery is healthy:

    Battery Information:

    Model Information:
    Manufacturer: DP
    Device name: ASMB013
    Pack Lot Code: 0001
    PCB Lot Code: 0000
    Firmware Version: 0102
    Hardware Revision: 0300
    Cell Revision: 0200
    Charge Information:
    Charge remaining (mAh): 4010
    Fully charged: Yes
    Charging: No
    Full charge capacity (mAh): 4075
    Health Information:
    Cycle count: 265
    Condition: Normal
    Battery Installed: Yes
    Amperage (mA): 0
    Voltage (mV): 12508

    it's at 98% charge at the moment with 5 lights on the back but if I unplug the power cable it shuts off within about a second, and I can't restart without plugging the power cable back in. I've reset the PRAM and the SMC, and reaseated the battery, but the problem's still there. I installed some additional RAM and Snow Leopard yesterday, but I don't think that's the issue as the problem predates this. I really don't want to go down to the Apple Store again, I'm well out of warranty and I've only just got it back after the last hardware problem!!! If someone could help that would be great
  • 7. Re: MacBook Shuts Down After Unplugging Powercord Although Battery is Insta
    Robert Is Confused Level 1 Level 1 (0 points)
    Shaknon -

    I'm sure that will solve your problem. Today I swapped with my wife's battery - it solved my problem and it caused the problem on her MacBook. So that confirms that this is a failure of the actual battery.

    Not sure why or what is actually failing... I'm going to roll the dice and get one of the $40 chinese batteries from ebay

    Best of luck and let me know how it goes