4 Replies Latest reply: Nov 12, 2009 5:04 AM by Carolyn Samit
Adam Rickets Level 1 Level 1 (10 points)
Since updating to 10.6.2 on my MBP 15" 2.4 Core 2 Duo I have the following problem..
When looking at any video clips on the BBC News website ( for example ) I get the error message "This content doesn't seem to be working. try again later" followed usually by Safari freezing, forcing a quit.

I have tried the following...

Resetting Safari
Emptying Caches
Repairing permissions
Uninstalling Flash Plugin
Installing Latest Flash Plugin
Removing all Plugins from /Library/Internet Plugins except the Flash Player Plugin
Creating new account

All of the above have made no difference.

I can however force Safari to start in 32 bit mode and then everything is OK

It would seem that the Flash player plugin will only work when Safari is in 32 bit mode - this is not how it is meant to be, and not how it is for other users.The plugin is the latest available- 10.0.32.18, as is Safari - Version 4.0.3 (6531.9) -but will not work with Safari in 64 bit mode.
I would like to run Safari in 64 bit mode so if anybody has any suggestions as to why the Plugin might be behaving this way on my set up then i would be very grateful
Thanks
Adam

15" MBP OS X 10.5.7 + 20" iMac 2.16 Core 2 Duo 2Gb RAM, Mac OS X (10.5.7)
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    HI,

    Try downloading and installing the 10.6.2 combo update available here.

    http://support.apple.com/kb/DL959

    One of the "fixes" .. "Safari plug-in reliability"

    Make sure and repair disk permissions after the installation.

    Quit any open applications/programs. Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and restart your Mac.







    Carolyn

    Message was edited by: Carolyn Samit
  • Adam Rickets Level 1 Level 1 (10 points)
    Thanks for your quick reply.
    I have tried your suggestion - even though I used the combo updater before - but unfortunately the problem still remains
    Thanks anyway...........

    Forgot to mention that everything is OK using Firefox and the same plugin.

    Message was edited by: Adam Rickets
  • Adam Rickets Level 1 Level 1 (10 points)
    All sorted for me now !!
    I thought that Safari Version 4.0.4 (6531.21.10) might do the trick but it didn't.
    On further investigation I found the problem to be an Application called Little Snitch that I run.
    Somehow in Little Snitch I had created a rule to stop the Flash plugin from making outgoing connections and this was stopping the content from playing.
    This is probably only a solution for me but if you are having problems and you use Little Snitch or something similar, then it could be an idea to temporarily disable it to see if it is causing a problem.
    Good luck !
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    Ah yes, 3rd party software. Most likely not compatible with 4.0.4 update.

    Always remember to repair disk permissions also after any software update or upgrade.

    Quit any open applications/programs. Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and restart your Mac.

    It can take awhile to repair permissions after the 4.0.4 update.. be aware and you will see a lot of, "messages" ... and make sure and not run any other appllications aside from Disk Utillity while it's running.









    Carolyn