Previous 1 3 4 5 6 7 Next 133 Replies Latest reply: Aug 28, 2014 9:54 AM by S.Fanara Go to original post
  • Jane Knox Level 3 Level 3 (690 points)
    join the Apple Developer Connection ...

    Excellent, Baltwo! Thank you for sharing that info. I'd give you Points if I was the OP.
  • moveson Level 1 Level 1 (0 points)
    I have discovered why this happens. In every case, the folder that generates this bug has items inside it that have identical names except for differences in capitalization. For example, the folder "Metallica" has one subfolder called "Master of Puppets" and another subfolder called "Master Of Puppets". Apparently iTunes is (or some former version was) case sensitive in creating folder names for albums. That case sensitivity seems to confuse the Finder, causing this confusing error. In the case described above, the error would be, "The operation can't be completed because an item with the name 'Metallica' already exists." As you can see, this makes no sense at all, since it is actually the subfolder that has the same name, but the parent folder that the finder references in the error.

    So the solution (for me) was simply to open the folder that is referenced in the error, make sure you are sorted alphabetically, scan through the list of subfolders (in my case it was always a subfolder) to find the duplicates, consolidate the items into one of the folders, and delete the errant folder.

    It would be cool if someone technically inclined could build a script that would do this.

    Thanks
  • jptan0 Level 1 Level 1 (0 points)
    Abstract: my problem was solved by renaming a file that had a tilde ('~') symbol. Presuming that this is a special or reservered character that cannot be handled by OSX.

    Hi everyone!

    This is my first post here, and I have to admit that I am fairly new to OSX having only recently migrated to a Mac.

    I was having similar issues as the OP described in trying to move some files onto my Kingston Data Traveller 16GB USB Stick. I even tried formatting it in FAT32 but it still came up with the same error which was puzzling.

    Finally, my issue was solved when I discovered that Windows had truncated the filename of one of my files with a tilde '~'. I'm assuming that this isn't exactly a standard character in file naming, or is a reserved character. When I renamed that file, the files transferred without an issue.
  • clavere Level 1 Level 1 (0 points)
    How did you find the ~? Just scan all the files? I am trying to move music from one drive to another and I am getting this error. So a lot of files to look thru if that is the case. Just want to confirm. Thanks.
  • baltwo Level 9 Level 9 (61,825 points)
    Click on the Desktop, CMD+F, enter ~ character into the search window, click File Name, and add Sytem Files included to the search criteria. I have 39 such files on my computer out of 75 GB of files and folders, numbering over 600,000 items.
  • clavere Level 1 Level 1 (0 points)
    Thanks! I will try this.
  • Jimmy Chang Level 1 Level 1 (0 points)
    I can report that the problem exists with NTFS as well. I have a 1 Tb Lacie drive and another 640 Gb Lacie as well. Both are NTFS for Windows compatibility. I was trying to copy files from the 1 Tb drive to the 640 Gb and I get this error. Strangely, I can copy my entire Music folder from one drive to the other, but I get the error when trying to copy my Videos folder.
  • Jimmy Chang Level 1 Level 1 (0 points)
    Forgot to mention that I use NTFS-3G and have no problems writing to either drive. The problem occurs when trying to copy files between them.
  • Chris Lingard Photographer Level 1 Level 1 (0 points)
    I'm having the same error message "operation can't be completed because an item of same name already exist" come up when trying to move data between one FAT drive to another FAT drive.

    happens on Drag and drop
    happens on copy and paste.
    there are no Tilde (~) symbols to be found.

    finder works for copying.

    trying to acquire forklift or chronosync now but this is rediculous.

    This plus many other bugs in Snow Leopard have made me REGRET UPGRADING.

    Thanks Apple. Way to go.
  • MattLTH Level 1 Level 1 (0 points)
    I'm just adding my voice to the chorus. I get the "operation can't be completed" error when copying files between 2 different FAT32 volumes. It only happens on my MacBookPro 5,2 on 10.6.2.

    When I move both drives (and the Sonnet Tempo SATA Pro ExpressCard 3/4) controller card) onto my MacBookPro 2,2 running 10.5.8, the file copy operations work without error.

    Grrrr....

    MattLTH
  • el.escapo Level 1 Level 1 (0 points)
    Yeah, it seems to be related to transfers in Snow Leopard between two Windows formats (either FAT32, NTFS, or a combination of the two.)

    I've just acquired Forklift, and it works great. Plus, with Forklift you can MERGE FOLDERS. Basic file system functionality, care of a third party. Thank you, Forklift!
  • Mike3456 Level 1 Level 1 (0 points)
    Boy am I really stuffed, I share files that matter between a pair of windows machines and a mac, many files saved after a wincrash years ago, so I have ended up with over 1500 files xyz~n.abc format. Any tips on programatically converting them?

    I cant do a blanket replace on the whole machine as some MAC osx files have a tilde at the front or end.

    Mike
  • Mike3456 Level 1 Level 1 (0 points)
    Further to my last post, Using USB memory sticks or an external HDD of several makes it is the same thing, Finder barfs on copying out of the filesystem the first file it finds of the 8.3 format, "123456~8.abc", giving the cryptic message that is the title of this thread. I seems to copy inwards OK, but the moment you want to export it goes pearshaped.
    Apple's finder is atrocious, crashing if you have more than 4 windows open, very limited views of the files etc, easier to do it through emacs. I actually prefer explorer.exe to finder.

    Mike
  • guillealv Level 1 Level 1 (0 points)
    it happens to me in the exact same situations... but my workaround has been a bit different. i've been using automator: actions - get files from finder - copy files, or either: action - sync folders

    painful, but it does work until apple comes with a fix in 10.6.3.
    PLEASE APPLE!, listen to us!!
  • fhall1 Level 1 Level 1 (0 points)
    Ditto for me with two NTFS network drives. I was trying to back up my NAS by copying files to a network hard disk via drag and drop. Last time I tried this was with 10.5.x and it worked fine. I'm now at 10.6.2 and got the errors. I'll try getting Forklift and see if that fixes it like everyone says it will. Hopefully Apple fixes this bug in 10.6.3
Previous 1 3 4 5 6 7 Next