Previous 1 5 6 7 8 9 Next 133 Replies Latest reply: Aug 28, 2014 9:54 AM by S.Fanara Go to original post
  • sa_admin Level 1 Level 1 (0 points)
    Installed 10.6.3. Halle-freaking-lujah. After 5 months I can finally copy folders with more subfolders to flash drives and Samba server partitions again... Good thing I caught this on my machine in time, but after this little disaster I will never roll out another Apple update in blind faith again.

    Almost forgot: The issues with zip-files is also resolved: I can compress folders with subfolders without the compression systematically hanging before completion.

    P.S.: One work-around I have recently been using is a shared folder to my Windows VM, and then from there to the drives, but what a kludge.

    Message was edited by: sa_admin (update)
  • Mitchell Smith Level 1 Level 1 (65 points)
    The error only seems to occur on our iMac running our months-old install of OS X 10.6. I think our problem is likely to be software, just not OS X 10.6:

    The error doesn't occur when the external volume is attached by USB2.
    The error doesn't occur when the external volume is attached by FireWire to a MacBook Pro running OS X 10.5.8.
    The error doesn't occur when the external volume is attached to a full, fresh install of OS X 10.6.3 running on an iMac or MacBook Pro.

    So, I think there is some conflict with what we're running on the iMac and 10.6.
  • Emtron Level 1 Level 1 (0 points)
    Hey there everyone,

    I have had this same problem but with using a NTFS drive. I recently re partitioned my 1TB external hard drive to NTFS using a friend's PC. When I try to transfer files from another NTFS external hard drive to this one I get this error message. I read in an earlier post that sometimes Mac OS has a hard time with files created on a PC. I've just recently switched to Mac from PC and don't know a whole lot about the OS system. I have a new Macbook pro running Snow Leopard and Mac Fuse NTFS 3G. I'm using firewire 800 for the 1TB drive and USB for the smaller drive. I tried using USB for both drives with no luck and I also tried copy and paste rather than drag and drop with no luck. Only some of the files do this but it's still like 70% of the time. I need to transfer about 500GB of photo, video, and documents and this file by file thing is driving me up the wall. Before I reformatted the drive I never had this problem.

    Does anyone know anything about this or if there's a way around it?
  • sa_admin Level 1 Level 1 (0 points)
    Well, that was too early and too good to be true: Now we are still having problems with some files copied to our samba-based shared fileserver: it will copy the entire file but then at the last moment say:
    "The operation can't be completed because you don't have permission to access some of the items." and then delete the already copied file ?!?!?

    As always, SAME files on the SAME drive to the SAME folder on our server in Leopard (10.5): NO PROBLEM! I really don't know what did they to screw up their file management in the rewritten Finder this badly, but it is months after the release of Snow Leopard and we still can't upgrade with this kind of failure at such a basic level... and software is being released that requires it.

    Update: Well, looks like a new bug introduced in 10.6.3 - yay... I hope they won't take another few months to fix that one. See this thread for more:
    http://discussions.apple.com/thread.jspa?threadID=2381606&tstart=25

    Message was edited by: sa_admin: Update
  • jaredddddd Level 1 Level 1 (0 points)
    wow, no solution to this....great. anyone know of any software that i can use to copy folders from one external to another without having this problem?

    <Edited by Host>
  • Mr. Fazookus Level 1 Level 1 (40 points)
    One way to overcome limitations of file systems is to zip the files instead of copy them... obviously that's only going to be useful for archival purposes or if you want to move the zip file to another system with different limitations.
  • Mr. Fazookus Level 1 Level 1 (40 points)
    Tried zipping the files, amazingly, the operation completed without errors... but the resulting zip file was corrupt.

    Wow.
  • Mr. Fazookus Level 1 Level 1 (40 points)
    think I found a Micky Mouse solution to this problem.

    Start a terminal session and do this:

    find source -exec cp -R '{}' destination \;

    Substitute your source and destination directories.

    What this does is basically find every visible file and directory in source and copy them one at a time to the destination, avoiding the bug that Apple should really really take seriously.

    Someone can probably improve on this, I'm not that good at this... maybe I missed something but it seems to be working.
  • robegian Level 1 Level 1 (10 points)
    Corlaix Vincent wrote:
    PS- Forklift license is less than $10 and it worths the money


    Not quite: actually it's $29.95, and in my case it didn't help at all — I still can't copy large amount of data to my external 500GB disk, even using Forklift.
  • rob@asg Level 1 Level 1 (0 points)
    Folks:
    Finder is (has been for a while) broken.

    Use rsync or cvcp in the terminal.
  • Jack Foster Mancilla Level 2 Level 2 (165 points)
    I have a Mac Mini with 10.6.4 that is working fine (except for this problem)
    The Mini is on my network, and has one factory internal drive, and two external drives that I use for storage of images, and software originals.

    After mounting the drives over the network, whenever I try to copy any file to any of those drives from my MacBook Pro 10.6.4, here is what happens.

    (Oh yes. … Both machines versions of 10.6.4 are fully up to date. After reading other suggestions, I updated both machines via the 10.6.4 combo update this morning, and the same problem still happens)

    First.) I log in over the network as the owner of the Mini machine, from the MBPro also as Owner.
    Second.) I can choose, any drive, or all drives, including the internal drive, on the Mini.
    Third.) The chosen drives seem to mount normally on the desktop of my accessing machine, MBPro.
    Fourth.) I can copy from any of the mounted drives to my local machine without problems.

    Now comes the problem.

    Fifth.) I try to drag any file or folder to any of the mounted drives.
    Sixth.) I am asked by (Details - com.apple.desktopservices) to, "Type your password to allow Finder to make changes."
    Seventh.) I answer the request with my name and password, and hit return.
    Eighth.) I get the error "The operation can’t be completed because an item with the name “” already exists." ()
    Ninth.) There has been created a 0k sized file on the target drive.
    Tenth.)
  • HaitiCanada Level 1 Level 1 (0 points)
    I got the same message when I try to copy files (or folders that contain such files) whose long names were shortened when they were transferred to a PC. (One clue that the names were shortened is that the revised names of such files contain a tilde such as INTEGR~1.DOC).

    _*Mickey Mouse solution:*_
    1) I rename the files in question; or, if there are too many of them
    2) I compress the folder that contain these files, before transferring them

    Both solutions worked for me.

    +*Additional Info, from Wikipedia regarding name shortening:*+
    +The tilde is part of Microsoft's filename mangling scheme for the VFAT file system. This upgrade introduced long filenames to Microsoft Windows, which were prohibited in previous versions. This was accomplished with a name-mangling scheme in which the first six characters of the filename are followed by a tilde. For example, "Program Files" might become "PROGRA~1".+
  • hoppah Level 1 Level 1 (0 points)
    I am having a similar problem, but the error message I get (after typing my password in to give me "permission" in Finder) is: "One or more items can't be copied to <foldername on NAS> because you don't have permission to read them."

    G.
  • gh37b89 Level 1 Level 1 (0 points)
    I was able to get my files copied on a 1 TB USB FAT32 drive buy using muCommander, a Finder replacement (www.mucommander.com - donationware). It has an option to overwrite existing files which took care of the problem.

    Message was edited by: gh37b89
  • 44gbs Level 1 Level 1 (0 points)
    In the past, I've been able to click and drag files from the home laptop to the one on my desk after connecting by VPN. Now the files want my home computer ID, then I'm asked if I want to replace the file that is on the distant computer (even though none exists) and then I'm told that I can't replace the file. The file name appears on the distant computer but it is empty - 0K. I have tried changing "Sharing" attributes as many ways as I can think of but nothing works. Also, the actual distant computer does not appear as a separate machine when I look in the home directory of my home laptop (it used to appear).
Previous 1 5 6 7 8 9 Next