4 Replies Latest reply: Nov 14, 2009 8:08 AM by coocooforcocoapuffs
coocooforcocoapuffs Level 3 Level 3 (845 points)
Hi all, I upgraded two machines to 10.6.2, an imac and an mbp, both newer but not the newest. All seemed well but for one problem with the imac: file sharing is really hosed. In the system preferences pane/Sharing I now get this behavior:
1) File Sharing: On, but there are no longer any shared folders or users. I can't add any either.

2) If I click Options, I see that Share files and and folders using AFP is checked, as is Share files and folders using SMB (Windows) with the proper Account ticked on.

3) If I try to share a new folder, then tick off Share files and and folders using AFP, it turns to "-" and file sharing is shut off immediately - and then ALL **** BREAKS LOOSE! I lose keyboard, can't open programs, can't use task bar, and icons clicked on the dock disappear.

Here are the events in a less emotional printout:

Warning 11/13/09 9:09:29 PM LSSharedFileListInsertItemFSRef returned NULL for path:/Volumes/StudioC/8.Downloads
Notice 11/13/09 9:09:29 PM TabletDriver[307]: CarbonCore.framework: coreservicesd process died; attempting to reconnect but future use may result in erroneous behavior.
Notice 11/13/09 9:09:29 PM coreaudiod: CarbonCore.framework: coreservicesd process died; attempting to reconnect but future use may result in erroneous behavior.
Warning 11/13/09 9:09:29 PM (com.apple.coreservicesd[188]) Job appears to have crashed: Segmentation fault
Notice 11/13/09 9:09:29 PM TabletDriver[307]: CarbonCore.framework: coreservicesd process died; attempting to reconnect but future use may result in erroneous behavior.
Notice 11/13/09 9:09:29 PM 2009-11-13 21:09:29.689 ReportCrash[1461:2a03] Saved crash report for coreservicesd[188] version ??? (???) to /Library/Logs/DiagnosticReports/coreservicesd2009-11-13-210929localhost.crash
Warning 11/13/09 9:09:34 PM ### Error:268435459 File:/SourceCache/SharingPref/SharingPref-193/Shared Classes/SambaUsersSheetManager.m Line:265
Notice 11/13/09 9:09:57 PM _RegisterApplication(), FAILED TO REGISTER PROCESS WITH CPS/CoreGraphics in WindowServer, err=-50
Notice 11/13/09 9:09:58 PM _RegisterApplication(), FAILED TO REGISTER PROCESS WITH CPS/CoreGraphics in WindowServer, err=-50
Warning 11/13/09 9:10:12 PM * WARNING: Method selectRow:byExtendingSelection: in class QSTableView is deprecated. It will be removed in a future release and should no longer be used.
Warning 11/13/09 9:10:29 PM ### Error:268435459 File:/SourceCache/SharingPref/SharingPref-193/Shared Classes/SambaUsersSheetManager.m Line:265
Warning 11/13/09 9:10:31 PM ### Error:268435459 File:/SourceCache/SharingPref/SharingPref-193/Shared Classes/SambaUsersSheetManager.m Line:278

This looks pretty bad and the behavior has to be the worst I've ever seen on a mac...it's like the entire system becomes unstable. I've tried all the usual things like Checking Permissions and running Disk Warrior. I even ran Applejack auto figuring I could not hose this up anymore. But nothing seems to fix it. The MBP however is just fine with filesharing and 10.6.2, so this seems to be imac specific. Both machines are configured with pretty much the same software.

Another worrying error message in console is this one, only because if I ever get the above resolved, this machine goes back to FCP editing:

Error 11/13/09 9:00:44 PM Error loading /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio: dlopen(/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHD Audio, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio: no matching architecture in universal wrapper

 Zombie MBP 2.2 4gig  Lotsa Aluminum iMacs  MB 2.4 2gig  iPhone 3g , Mac OS X (10.6.1),  No more PCs, finally!
  • Pancenter Level 6 Level 6 (8,750 points)
    Backup everything you need.

    At this point I would -download- the full 10.6.2 combo installer and
    re-install. When installing the compo updater unplug all USB/Firewire
    devices (except keyboard & mouse). Plug back in after OS install and reboot.

    I never use Apple's software update, especially lately. I've seen too many
    machines hosed after upgrading the OS.

    pancenter-
  • coocooforcocoapuffs Level 3 Level 3 (845 points)
    Hi there, thx for that. the 10.6.2 upgrade was made with the downloaded combo installer, as I too always do this. I ran it again, as a last ditch for this image, and it changed nothing. It's the strangest thing. I don't have any users under file sharing, and I can't add any directories, and when I try, the entire system goes haywire. Reminds me of the PC days when the MS OS was infected:)

    Not sure what to do now, as I really would like to fix this image. And if I can't, I am not sure if I should risk another iMac with the update. I've read about a Finder Error 10180 bug here on the forums, and this one has that too...after the machine goes nuts, finder seems to be corrupt with that same error. Perhaps related?
  • Dah•veed Level 7 Level 7 (32,245 points)
    Have you tried resetting the PRAM?

    (Re)start the Mac and immediately press & hold the Command + Option + P + R keys until you have heard the startup chime two times*, then release the keys and allow the Mac to startup.

    *Some certified techs here in the forums have said to hold until you have heard a chime that is louder than the first chime.

    Dah•veed
  • coocooforcocoapuffs Level 3 Level 3 (845 points)
    No, had not thought of that one. Also did the pull the plug and press on for 10 second, as that is supposed to reset things too. Both plans failed:)

    This one is really strange...everything else is working fine, and problem exists on a test user account as well.