11 Replies Latest reply: Nov 14, 2009 10:33 AM by David M Brewer
Alancito Level 6 Level 6 (10,855 points)
The video in this page and others in the series don't consistently play on my MBP 1,1 running 10.6.2:

http://www.apple.com/iphone/business/profiles/doer/

...I "Click to Play", it appears to start to download and the poster image is replaced by a grey viewing window with a spinner — which just spins and spins... Clicking the Play button doesn't help and there are no errors in the Console Messages log. Here's a screenshot of the stuck video:

Video on Apple\'s site doesn\'t play

I deleted the following from User > Library > Preferences:

com.apple.quicktime.plugin.preferences.plist
com.apple.quicktimeplayer.plist
com.apple.QuickTimePlayerX.plist

...and then rebooted — I was then able to view that particular video but then I tried viewing other videos in the series and they fail to play, e.g.

http://www.apple.com/iphone/business/profiles/airventures/

And then the original fails to play once again. ...Suggestions appreciated.

 ~ Alancito

 MacBook Pro 15" 1,1, Mac OS X (10.6.2), MobileMe iLife'08 iWork'08
  • 1. Re: Videos on Apple's site don't play
    Baby Boomer (USofA) Level 9 Level 9 (55,575 points)
    Make sure you have the latest version of Adobe Flash Player Software.

    Try running +repair permissions+ *from your HD* & then restart your computer.





  • 2. Re: Videos on Apple's site don't play
    Klaus1 Level 8 Level 8 (44,470 points)
    If you having problems watching WWDC Keynotes or Trailers on the Apple website, check your Quicktime 7 settings in System Preferences:

    Under Streaming, set for Automatic, enable Instant On and Play Immediately.

    Under Advanced, click Mime Settings and ensure that Streaming (both kinds) are enabled.

    They all play fine for me (but I am not on Snow Leopard).

    Message was edited by: Klaus1
  • 3. Re: Videos on Apple's site don't play
    Wyodor Level 6 Level 6 (19,375 points)
    I found that in a few hours I collected a bunch of Apple cookies that could fill a bakery shop.

    Problems appear in this forum, the support pages and the shopping cart in the Apple Store . Most with an error about too much data send by a cookie. Or simply not loading a page.

    Delete all cookies apple.com and the problems disappear. Until they appear again.
  • 4. Re: Videos on Apple's site don't play
    CMCSK Level 6 Level 6 (10,425 points)
    Running SL & no issues playing the video using Quicktime X. Using the latest version of Firefox and Flash Player.
  • 5. Re: Videos on Apple's site don't play
    QuickTimeKirk Level 8 Level 8 (48,110 points)
    Flash is not used on that page.
  • 6. Re: Videos on Apple's site don't play
    QuickTimeKirk Level 8 Level 8 (48,110 points)
    Snow Leopard does not include a QuickTime System preference pane.
    There is no streaming server files on that link.
  • 7. Re: Videos on Apple's site don't play
    QuickTimeKirk Level 8 Level 8 (48,110 points)
    Make sure you've installed QuickTime Player 7.6.3 from the Snow Leopard DVD.
    The pages work just fine for me.
  • 8. Re: Videos on Apple's site don't play
    Alancito Level 6 Level 6 (10,855 points)
    Thanks to all for the suggestions, but clearing apple.com cookies from Safari, repairing permissions and rebooting hasn't helped.
    QuickTimeKirk wrote:
    Make sure you've installed QuickTime Player 7.6.3 from the Snow Leopard DVD.

    QTK ~ I installed it during the upgrade from L to SL — so I have this version: 7.6.3 (1591.3). I don't know if the following is relevant, but if I go here:

    http://www.apple.com/quicktime/guide/appleevents/

    ...and click on "Launch QuickTime Guide in Player", QTX opens with a warning:
    You need QuickTime Player 7 to open “qtpix.mov”. Do you want to open the movie in QuickTime Player 7?

    ...I click on "Open in QuickTime Player 7" and the QuickTime Guide appears in QTP7 as expected. But I see this in the Console log:
    11/14/09 2:06:41 PM QuickTime Player[3879] .sdef warning for argument 'FileType' of command 'save' in suite 'Standard Suite': 'saveable file format' is not a valid type name.
    11/14/09 2:06:44 PM QuickTime Player 7[3881] .scriptSuite warning for argument 'UsingDescriptors' of command 'SaveReferenceMovie' in suite 'QTPSuite': 'list' is not a valid type name.

    I'm wondering whether, in a similar way, errors are occurring with the problematic video — and being reported in another part of the Console log that I'm not familiar with.

    BTW, QTP7 also plays local videos fine and other Apple videos run fine, such as the ones on these pages:

    http://images.apple.com/iphone/gallery/ads/

    http://www.apple.com/findouthow/movies/

    http://www.apple.com/ilife/iweb/

    http://events.apple.com.edgesuite.net/0906paowdnv/event/index.html?internal=ijal rmacu

     ~ Alancito
  • 9. Re: Videos on Apple's site don't play
    QuickTimeKirk Level 8 Level 8 (48,110 points)
    Your link to the Apple Events may never work with QuickTime X because it links to a feature (Content Guide) that only works with QuickTime Player (5, or higher).
    I wouldn't worry about the Console messages as Safari 4.0.4 shows over 7,500 permissions "repairs".
    Your original link does set some "cookies" (read the source code) and has a lot of javascript files but, as I said, works fine for me.
    If you have the time I would test the page with a different "User" account. This helps narrow down the troubleshooting steps.
  • 10. Re: Videos on Apple's site don't play
    Alancito Level 6 Level 6 (10,855 points)
    QuickTimeKirk wrote:
    ...test the page with a different "User" account. This helps narrow down the troubleshooting steps.

    Thanks for the suggestion. I rebooted and logged in to the Guest account and was able to view two of the videos in that series ...then the third one froze.

    I then logged out of Guest & into Guest again and was able to play the first video. Then the second one froze.

    ...It doesn't seem to be a particular video in the series that freezes, but rather the n'th video that I view in that series.

    Then if I copy & paste any of the .mov file's URLs from the source into Safari's address bar, they play fine — apparently via QTX.

    If I compare the amount of data being downloaded between the above two methods of viewing, "normal" viewing appears to download only half the video that the direct URL downloads. Perhaps the halfway download point is where it would actually start playing the movie — and that's where it gets stuck.

    ...So what's the next step? I could file a Bug Report via ADC, but it seems a weak case without diagnostics such as a crash report or console errors.

     ~ Alancito
  • 11. Re: Videos on Apple's site don't play
    David M Brewer Level 6 Level 6 (9,200 points)
    If you have DiskWarrior it running that and see if that helps. I ran DiskWarrior after installing the Safari 4.0.4 update that other day and had 3 errors. Safari/Quicktime was running sluggishly after the update. Now Safari/Quicktime runs perfectly.

    Message was edited by: David M Brewer