5 Replies Latest reply: Nov 15, 2009 5:28 PM by BDAqua
rynodino Level 1 Level 1 (0 points)
I am typing this message through safe boot on my imac g4 running Mac OS X 10.4.11

When i boot it regularly my keyboard does not work. I have tried this with 1 other mac keyboard and 2 PC USB keyboards. I believe this is os related.

If someone could help me as soon as possible that would be great...i have a project due in the morning and need my keyboard to do it

BTW: I have run a repair on my 'iMac HD' volume

Message was edited by: Dino P.

iMac G4, Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10 (119,850 points)
    Hi, as a quick workaround until we figure this out...

    While in Safe Mode, make a new User in System Preferences>Accounts, log into that one for a test.
  • rynodino Level 1 Level 1 (0 points)
    Hi. I tried adding a user but nothing....I have a second account on that comuter and it is not password protected. I logged in through that and activated the onscreen keyboard. from there i went to user acounts [the button by the clock] and switched users I was able to use the on screen keyboard to type my password.
    After i logged out of safemode and rebooted, nothing was successfull. I couldn't type anything.

    I have just pulled out of the closet and am now on my powerbook g3 pismo typing...my project is too big and my computer is too slow for this one. I may be able to try the firewire boot using my pismo but i don't know what good it will do until i know exactly what to do
  • BDAqua Level 10 Level 10 (119,850 points)
    Have you done a PRAM reset...

    http://docs.info.apple.com/article.html?artnum=2238

    Does the Keyboard show up in System Profiler?Hardware>USB?

    Could it be some broken 3rd party thing?

    If it works in Safe Mode but not a regular bootup, then Check System Preferences>Accounts>Login Items window to see if it or something relevant is listed. Check the Other row in System Preferences.

    Also look in these if they exist, some are invisible...

    /private/var/run/StartupItems
    /Library/StartupItems
    /System/Library/StartupItems
    /System/Library/LaunchDaemons
    /Library/LaunchDaemons
  • rynodino Level 1 Level 1 (0 points)
    i guess it may be a third part problem.

    i am trying to start it in safe boot as i type.

    i thought i would let you know that i have already tried to zap the pram but it will not even let me do that....im not sure it will even let my boot it through firewire...


    i am checking to see if those files are there....are they files in a directory or something i should look for through the terminal? if so, how?
  • BDAqua Level 10 Level 10 (119,850 points)
    You can type hose locations into...

    In finder, select Go menu>Go to Folder

    Or in Terminal...

    CD SPACE the the path.

    Don't know what it'd be, but lok for something you may have installed.