Previous 1 2 3 Next 33 Replies Latest reply: Apr 15, 2010 7:54 PM by Ryan Brousson
weavernoes Level 1 Level 1 (0 points)
I just bought a Magic Mouse for my MacPro. I downloaded and installed "WirelessMouseSoftware.dmg"
Got it BT connected, but the multitouch surface doesn't works. I can't scroll or swipe or anything as it should do.
Any tips for such problem?
Thanks

Mac Pro, Mac OS X (10.6.2)
  • fuzzydog Level 2 Level 2 (355 points)
    I shut down my machine after doing a superduper! clone every night and restart automatically in the morning. The swipe doesn't work unless I do a manual restart. I have found no solution as yet other than this one. So, you might want to try a reboot. I can't explain why a 2nd start gets the swipe working while it doesn't after the first one. Very weird!
  • weavernoes Level 1 Level 1 (0 points)
    Hi!
    Glad to see that we are - at least - two in the wide world with similar "magic mouse" problem!
    As it seems we have also same computer, may be there is something with such machine?
    Who knows?
  • GreyGuy Level 1 Level 1 (0 points)
    I had the same problem. I have a Macbook Pro purchased in Feb 09. I did a clean install of OSX on an external drive, and the multi-touch surface still didn't work. The mouse was paired via bluetooth, and I had the magic mouse preference pane in system preferences. But the Mac didn't see the mouse as a magic mouse, just a one-button wireless mouse. I returned mine. Good Luck.
  • Speedball2 Level 1 Level 1 (0 points)
    I've the same problem than weavenoes
  • weavernoes Level 1 Level 1 (0 points)
    Even more strange!!!
    I went to an iMac and tried the mouse
    Mouse was immediately recognized after installing "WirelessMouseSoftware.dmg" on it.
    I came back home and re-install Snow-Leopard, as I thouht it may be a software conflict with the SL version delivered with Mac Pro few days ago
    Still doesn't works!
    Amazing!
    Any tips or suggestions will be very welcomed!!!
  • weavernoes Level 1 Level 1 (0 points)
    I got it!
    After different tests regarding the mouse , then the Mac, I found out that it was some very old files within "System Preferences /Others) where problem lays.
    I trashed some quite old apps on mouse speeding. Then: "Eureka"!
    But don't forget to re-start the mac after each trash
    If it could help somebody else!!!
    Bye!
  • mkummer Level 2 Level 2 (285 points)
    Could you be a little more specific about the files? On which path had they been? Which files had them been? So other people could eventually benefit from your experience...

    Thx, Michael
  • weavernoes Level 1 Level 1 (0 points)
    As I said:
    within "System Preferences /Others) where problem lays.
    I trashed some quite old apps on mouse speeding (swiping speed)
    One of them was "Mouse Zoom"
    Can't remember other

    Message was edited by: weavernoes
  • weavernoes Level 1 Level 1 (0 points)
    I found it out!
    Within the several apps I threw out yesterday, that's USB Overdrive which brings "panic" within Magic Mouse controls.
    The problem seems well known by USB Overdrive developer: http://www.usboverdrive.com/USBOverdrive/News.html
    As I not quite convinced by the quality of the Mighty Mouse I've tried yesterday; I got back to my "old" Logitech MX revolution" and re-install USB Overdrive. The problems above mentioned came back immediately.
    A glance to developer'site indicates that problem is known and under "treatment"
    Wait and see!
  • Apple Helper Level 1 Level 1 (20 points)
    Alrighty, it looks like I have figured out the source of the problem. The program is called "USB Overdrive." What I did was went under System Preferences, and did a right-click on the USB Overdrive to remove the item from my computer. Turns out that that is not enough. The main problem is inside Extensions. Click on the Apple at the top of the screen, and go to About This Mac. Then, go to more options, and go under software, and then under Extensions. It should take about 10 seconds to load. Once that is done, scroll down to near the bottom of the list, and if you see one called USBOverdrive then open up a new window in Finder. Click on Macintosh HD, and then go to System, then Library, and then Extensions. Find the one called USBOverdrive.kext and drag it to the trash. You may have to enter the admin password to allow Finder to make changes. Empty the file from the trash and restart the computer, and get rid of the mouse from Bluetooth prefs, and then pair it again. That should solve the problem. By the way if you don't have Snow Leopard (10.6.2) run a system update, and if not, then buy a copy, it's well worth the cost.

    Message was edited by: Apple Helper
  • fuzzydog Level 2 Level 2 (355 points)
    Doesn't solve my problem as I don't have that extension. I still need to do a reboot in order to get swiping to work.
  • zolee1 Level 1 Level 1 (0 points)
    I had the same problem. I have a MBP and I didn't even install anything first, just paired it up with my MBP. Scrolling/Swiping didn't work.

    Then I restarted my MBP, clicked on the apple logo in the top left, and clicked 'Software Update'. I updated my mac by installing the required software and I restarted at as it prompted me to do so.

    After this restart everything is working.

    I hope it helps others...
  • Patrick Vittitow Level 1 Level 1 (30 points)
    My swiping has stopped as well with Magic Mouse,seems to be working with Wacom Trackpad but not MM. Just wanted to add my voice~
  • kloggai Level 1 Level 1 (0 points)
    I installed my Wacom Bamboo touch the other day and now my Magic Mouse swiping won't work. Scrolling works just fine though. Anyone else notice a connection between their mouse / wacom device?
Previous 1 2 3 Next