9 Replies Latest reply: Mar 23, 2010 9:32 AM by Timothy Smith4
M. Ryan Level 1 Level 1 (15 points)
I have restarted the computer and phone, and fully uninstalled and reinstalled iTunes. The phone and iTunes are updated to the latest update. When I plug in my iPhone, iPhoto opens but not iTunes. When I open iTunes, it freezes and the iPhone does not appear as a device. When I unplug the iPhone, iTunes un-freezes, and the iPhone appears briefly under devices before disappearing. iTunes is then fully functional until the phone is plugged in again.

Are there additional steps that would be helpful?

iPhone 3GS, iPhone OS 3.1.2
  • neuroanatomist Level 7 Level 7 (31,690 points)
    You might try removing and reinstalling AMDS:

    http://support.apple.com/kb/HT1747
  • psezratty Level 1 Level 1 (0 points)
    Me too! I have a MacBook Pro with OSX version 10.5.8 I just installed the new Itunes yesterday and I connected my Ipod to update it today and although Itunes launches it does not recognize my Ipod. I have now been waiting 20 minutes. If this is some kind of glitch with the new program than I kindly request it's figured out because I certainly didn't buy an Ipod three years ago just to have it not work with a program upgraded by Mac.
  • ShadyMac Level 4 Level 4 (1,250 points)
    Do you by any chance run Windows 7 64bit?

    There is a known bios issue with a few motherboards using the intel chipset and Win 7 64 bit with the latest iTunes. 9.0.2

    Updating the bios fixes most of those issues...

    Until the update...you can run in Vista SP2 mode instead and this will allow the sync to complete
  • cmelious Level 1 Level 1 (0 points)
    Mine was doing the same thing. I would plug it in and just get a pinwheel in iTunes. I tried rebooting both computer and iPhone. I was finally able to get it to recognize after running all of the software updates via the iPhone on my wifi network. Only after it was all updated did it finally work.For the record I had 11 outstanding updates when it wouldn't work, maybe there is something to that.

    -C
  • n8fig1 Level 1 Level 1 (0 points)
    Me too, i have an ibook g4, updated itunes and my iphone is doing the exact same thing. i did all the same things, uninstalled itunes, reinstalled, updated any updates on my iphone. nothing is working. it is especially frustrating to see the device appear just as i unplug it!
  • BrainDonor Level 1 Level 1 (0 points)
    I had the same issue this morning on my iMac. In my case, when I plugged in the iPhone, it wasn't recognized by iTunes. Also iPhoto did not start up. I tried restarting iTunes but it still did not recognize the iPhone. This used to work well the last time I synced a couple of days ago.

    I am also running VMware with Windows XP Pro. So I decided to close the VMware session and see if that does anything. Well, as soon as I plugged the iPhone back in, iPhoto started and iTunes now recognizes the phone.

    Are you running VMware or any other non-Apple software that may be causing conflicts with the USB ports?
  • antbar01 Level 1 Level 1 (0 points)
    I just got off the phone w/ tech support with precisely the same issue, and it turned out to a be a corrupted podcast (This American Life episode #399, in my case). Delete all recently downloaded podcasts on your iPhone and in iTunes and try again. If you do it one at a time, it takes longer, but then you'll know which one it was.

    Good luck.
  • slimjim900 Level 1 Level 1 (0 points)
    I had the same issue, too, buy my "fix" was a little different. I run VMWare Fusion full time on spaces 2 & 3 so when I was plugging in the phone one of the VMs was grabbing it.

    Never used to do this so I'm not sure what's caused it to go straight to the VM but I disconnected it from Fusion and all was right with the world again.
  • Timothy Smith4 Level 1 Level 1 (5 points)
    I had the same problem, iTunes got stuck, but no VM, and deleting recent podcasts did the trick. Thanks much.