12 Replies Latest reply: Jan 22, 2010 2:05 PM by toddlermac
Level 6 Level 6 (11,035 points)
I have trouble mounting nfs-exported disks on my ubuntu server.

I don't think it's the servers configuration:
(part of /etc/exports)
/dsk/mp3 10.42.42.*(rw,sync,insecure)

and my mount command on the apple should be ok as well:
sudo mount_nfs black:/dsk/mp3 /nfs_photo

The respons on the command are:
mount_nfs: /nfs_photo: Operation not permitted.

As far as I can see there are no ownership issues or such stuff.
My popcorn hour mounts the same just fine

Any one have any clue? I am new on mac but quite old on Linux systems so I do know my way around nfs usally.

MacBook Pro, Mac OS X (10.6.2)
  • 1. Re: NFS mount
    K T Level 7 Level 7 (23,700 points)
    Hello Kjell_Mesch & velcome to discussions...

    Some NFS server configurations only accept connections from reserved ports, <1024. OS X, AFAIK, by default does not use reserved ports for nfs.

    Know how to check/set/open/allow?

    Is your OS X firewall enabled?
  • 2. Re: NFS mount
    Level 6 Level 6 (11,035 points)
    Hi all. (and tanks for the reply K T)

    I realized that my problem has more to do with the finder than nfs, i think :-/

    The nfs-disk mounts just fine. I have been trying to access the mount with finder through the mount-point and that what fails. (If i do it with a terminal it works i realized)
    The msg is simple enough:
    The folder "nfs-photo" can't be opened because you don't have permission to see it's content.

    But why can I access it trough the terminal if it's a permission-problem?

    Have to rush of to work
    I will investigate more after work.
  • 3. Re: NFS mount
    Level 6 Level 6 (11,035 points)
    Been doing some tests.

    I can do:
    sudo mount -t nfs black:/dsk/lacie500 /dsk/lacie500

    Doing as I think the same in disk utillity it does not work.

    mount command list mounted disks as follows:
    my command line mount:
    black:/dsk/lacie500Gb on /dsk/lacie500Gb (nfs)
    disk utillity mount:
    map -static on /dsk/mp3 (autofs, automounted, nobrowse)

    What am I missing in disk utillity?
  • 4. Re: NFS mount
    allan.parsons Level 1 Level 1 (10 points)
    I am having this exact same problem. Everything worked fine in Leopard, but when I upgraded to Snow Leopard, my NFS mount broke.

    I'm running a Linux Ubuntu server with 500 GB of space, and I'm exporting /data/Music as read-only to my 192.168.1.255 subnet.

    I mount nfs://192.168.1.2:/data/Music to /Users/Shared/Music (read-only). I then link /Users/Shared/Music to all user's desktops (ln -s /Users/Shared/Music ~/Desktop/Music). That works fine. And, I can browse ~/Desktop/Music in a terminal window with no problems. But when I try to click the "Music" icon on my desktop, it fails with the same error message: "The Folder 'Music' cannot be opened because you don't have permission to see the contents."

    If you've figured this out, could you please post what you did to get it working?
  • 5. Re: NFS mount
    jv.imac Level 1 Level 1 (0 points)
    I do have the same problem. I tried to mount via Disk Utility but didn't work.
    From comman line I have the so known "Operation not permitted".

    This former discussion http://discussions.apple.com/thread.jspa?threadID=2151501&tstart=-1 said it might be related to insecure ports, but I have already checked this. What's more, I can connect wiht a CentOS OS based computer without problem.

    My "server" is a Synology DS190j.

    If someone has solved, please do post.
  • 6. Re: NFS mount
    jv.imac Level 1 Level 1 (0 points)
    nobody has new clues?
  • 7. Re: NFS mount
    allan.parsons Level 1 Level 1 (10 points)
    I know this doesn't help, but I think it might have been related to my computer going to sleep. A simple reboot resolved the issue, as I was seeing i/o and fsck errors in my log.

    Can you try a fresh boot? Are you mounting to /Users/Shared/xxx directory?

    -Allan
  • 8. Re: NFS mount
    jv.imac Level 1 Level 1 (0 points)
    Allan.
    I have tried what you said and it must be another issue.

    Thanks.
  • 9. Re: NFS mount
    jv.imac Level 1 Level 1 (0 points)
    Ok, this is my "walkaround":



    I have downloaded and installed the NFS Manager: http://www.versiontracker.com/dyn/moreinfo/macosx/9301
    This is some kind of fronted for the built in capabilities of NFS that OSX has (and any other unix-like OS) . Connecting my NFS server has been extremely easy. It is similar to the Disk Utility app., but unlike it, NFS Manager worked fine for me.



    When I find the problem why I couldn't connect without that manager I'll post.
  • 10. Re: NFS mount SOLVED
    jv.imac Level 1 Level 1 (0 points)
    Ok this is the key: the remote ports, I added this " nodev nosuid bg resvport " to
    the advanced parameters.

    Here's a link to the window: http://img260.imageshack.us/img260/1822/capturadepantalla201001y.png
  • 11. Re: NFS mount
    meshack Level 1 Level 1 (0 points)
    I was unable to see my NFS share on my openBSD server after upgrading my Mac Mini to 10.6. I fixed this by changing the mount parameters to use the server's IP address instead of the /etc/hosts file entry for it. Does anyone know why host name resolution would fail in 10.6 but not 10.5?
  • 12. Re: NFS mount (not) SOLVED
    toddlermac Level 1 Level 1 (0 points)
    I've been having the same problem with an NFS mount from a linux box not working in the finder when I mount the volume in v10.6.2. I can not copy files to the NFS mount in finder, but I can create/delete directories in the finder. Everything works correctly if I use the command line to get to the directory. I also frequently get errors that the NFS mount connection is interrupted or disconnected when I have it open in the Finder, but the volume is visible and working without error via the command line.

    I tried the options suggested (nodev nosuid bg resport, and also the -P option suggested by others) and that doesn't work with the Finder. Are there any other suggestions out there?

    I amazed apple could screw this up in this version of the OS. 10.5 worked fine.