14 Replies Latest reply: Nov 20, 2009 5:19 AM by Gretchen Scott
Leinie Level 1 (20 points)
I have searched high and low, and called everyone I can think of, but I cannot find anyone to give me the correct settings to get my Charter email to work with Apple Mail. Charter customer service is no good (I basically knew that going in). I've found a discussion topic regarding Charter and Apple Mail, but it pertains to the iPhone.

I have an iMac Intel Core Duo 2, 2.16 GHz. I am running 10.6.2. I'm able to use Gmail with Apple Mail, but nothing I do will help Charter mail to work. According to Charter, if I can access my email through their webmail site, then things are set up properly. But of course, they can't advise me on Apple Mail.

Does anyone at all have any advice? This has been so frustrating for me the last couple of days. Thank you!

20" iMac Intel Core Duo 2, 2.16 GHz, Mac OS X (10.6.2), Firefox Browser, Airport Express, iPod Touch
  • Kappy Level 10 (266,058 points)
    Whatever works for the iPhone should work for you if it's like other mail. All you need are:

    1. Type of mail - POP or IMAP.
    2. Your email username and password.
    3. The outgoing mail server's domain name.
    4. The incoming mail server's domain name.

    All of this should be available from Charter's tech support. The above is required for any email application and is used in the same way.
  • K T Level 7 (23,705 points)
    You may need to configure a specific port - try using #25.

    Also, seen this thread?

    The last two comments in the thread seem to have specifics, etc.

    Good luck in any case.
  • Leinie Level 1 (20 points)
    Thank you for your suggestions. This is probably going to sound very complicated, but I'm hoping someone can decipher it the way I'm intending!

    Since I'm resigned to the fact that, no matter what I try, I can't get the Charter server to work directly with my Apple Mail, here is my ultimate goal: to forward the Charter mail to Gmail, (where I'm able to change the settings so that it appears that the mail is being sent to (and replied from) my Charter email address) and then send that back to my Apple Mail (where Apple Mail can check every minute for new mail). I've accomplished those steps.

    However, I'm trying to figure out why, when I send email from Apple Mail using my Gmail account, it doesn't show the email as having been sent from my Charter address? I was thinking that, because I changed those settings in Gmail, that Apple Mail would retain them. It probably isn't that big a deal, but I've had people tell me they were confused because they were sending mail to my Charter address, but when I reply or send a new email, it shows up with the Gmail address.

    Main thing is, I'd like my Charter email address to show up, as both my outgoing address and my reply-to address, while using my Gmail account which I have added to Apple Mail.

    Any suggestions? Thank you very much!
  • Leinie Level 1 (20 points)
    Actually, I'm 99% of the way there now! To get my mail to display the Charter email address, I just went into my Account Information in Apple Mail and changed the email address to the Charter address. Now that part works. The only thing that doesn't work now is my notification of new email sound. The email shows up almost immediately, but the sound that I have set to notify me of new mail does not play, even though it is set in the preferences.

    Two steps forward, one step back...
  • K T Level 7 (23,705 points)
    Two steps forward, one step back...

    Try one more forward and restart, then see if the tone sounds next time you get mail.
  • Leinie Level 1 (20 points)
    I just tried it...no luck!
  • Leinie Level 1 (20 points)
    It's not that I mind using Gmail, but it doesn't check for new mail at 1 minute intervals like Apple Mail does.
  • Red Jacket Mike Level 4 (1,285 points)
    If you want Charter email to work directly with Apple Mail (mine does), there is one odd thing you could try; a Charter rep told me about this over a year ago, and it solved all my problems.

    In the account settings, in the User Name field, enter your entire email address instead of just your user name.

    Maybe this won't help with the newest versions of OSX and Mail, but I've kept this setting through lots of software updates and versions, and it still works fine.
  • Leinie Level 1 (20 points)
    Thanks for the suggestion about entering the entire email address in the user name field; I tried that, too. Unfortunately, no luck there, either!
  • Gretchen Scott Level 1 (85 points)
    I have the same kind of iMac as you, with the same OS. Also have Charter. I can receive mail with Apple mail, but cannot send it. I can send and receive with Entourage, Yahoo and Gmail.
  • Leinie Level 1 (20 points)
    Great news, thanks to the friendly, extremely helpful people at Apple Technical Support! We got it working (although emails seem to be somewhat slow to send, but they DO send!)

    At least for me, here are the settings:

    *Incoming Mail Server: mail.charter.net*
    Username: (complete email address)
    Password: (password)

    *Outgoing Mail Server (SMTP): smtp.charter.net* (I got conflicting answers from Charter on that one, someone said set both incoming and outgoing to mail.charter.net, but it should be smtp.charter.net).
    Under "Edit SMTP Server" and the Advanced tab, Use default ports; do not check Use SSL, and set Authentication to "None".

    A huge debt of gratitude to Neil, Ted, Brad and Jonathan at Apple Technical Support! Hopefully this will help you, Gretchen (and anyone else having problems with Charter).
  • Gretchen Scott Level 1 (85 points)
    WOW - it does work!!

    Thank you so very much for finding a solution.
  • Leinie Level 1 (20 points)
    EXCELLENT! Does it seem to you like the mail takes a little (or a lot) longer to actually send than usual?
  • Gretchen Scott Level 1 (85 points)
    It did seem to take awhile to send - but as I have not been able to send at all, anything is improvement.

    Longer than Entourage for sure.

    I'm just happy that it works!