11 Replies Latest reply: Dec 27, 2009 1:57 PM by Jason Ellis2
Poomoon Level 1 Level 1 (0 points)
Hi, just yesterday when i opened my safari and it loaded the apple.com page (my home page) it suddenly came out with an error window saying something like the script cannot be loaded or completed (forgot how it said exactly). So i clicked OK and just proceeded to yahoo.com. May safari refreshed shortly and nothing displayed, all white/blank page. on the top (not the website field, but the page title on top center), something funny it displays " www.yahoo.com 1x1 pixels " Now whatever website i input or tick from my bookmarks, same thing, blank page, and displays "1x1 pixels"right after the website name. I'm not really that good or an expert in these types of things, need anyone's help. Thanks.

iMAC, Mac OS X (10.5.8)
  • Golden Shoes Level 5 Level 5 (4,015 points)
    It's served by an advertiser. But you need to find out the URL for where it's being served from. Open the Activity and look through the list of connections until you find that one, and post the URL in your reply.
  • Poomoon Level 1 Level 1 (0 points)
    Hi, thanks, i did check it out, and it just says :

    livepage.apple.com 1x1 pixels
    http://livepage.apple.com/
  • Poomoon Level 1 Level 1 (0 points)
    i tried other sites, now i start to see this :

    http://www.youtube.com/
    www.youtube.com/
    www.youtube.com/favicon.ico

    i see this favicon.ico on the others also.
  • Golden Shoes Level 5 Level 5 (4,015 points)
    livepage.apple.com 1x1 pixels


    I tend to doubt that it's for that page, since I don't get any such thing, and there's no indication of any attempt to load a 1x1 pixel page. Did you check to see where the 1x1 pixel page is actually connecting to, because it's not Apple.

    favicon (.ico) files are the tiny images you see in the browser address bar and/or tab bar for each web site you load, so they aren't a problem.
  • Carolyn Samit Level 10 Level 10 (100,090 points)
    HI,

    Try maintenance.

    From the Safari Menu Bar, click Safari / Empty Cache. When you are done with that...

    from the Safari Menu Bar, click Safari / Reset Safari. Select the top 5 buttons and click Reset.

    Mac OS: Web Browser Quits Unexpectedly or Stops Responding

    Safari add-ons can cause performance issues or other situations

    Try uninstalling and reinstalling a new copy of the Flash Player plugin since it's required for streaming video on YouTube.

    Uninstall Flash

    Install Flash

    Repair disk permissions...

    Quit any open applications/programs. Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and restart your Mac.









    Carolyn
  • Poomoon Level 1 Level 1 (0 points)
    Caroline, Golden shoes, thanks for the help.

    I'm not sure what happened, as I already reset and removed my cache the night before and still the same. But in the morning it was still the same. This morning, I just 'forced quit' the safari app, then restarted again, suddenly it was running normal. Anyway i'll continue to check it out. Thanks again.
  • Ghaash Level 1 Level 1 (0 points)
    Hi,

    I'm facing the same situation here. I've tried everything Carolyn suggested and Safari still opens any page as a blank page with "1x1 pixels" title.

    It happened some times before, and Safari always came back alone soon. But now it's happening for about 1 week.

    And the most interesting fact: when I reset Safari and it reopens, he creates all the Top Sites thumbnails again. But if I try to click anything, it goes "1x1 pixels" again.

    I've also tried Firefox and Opera, and they're working ok. (I'm sending this on Firefox on the same Mac).
  • Ghaash Level 1 Level 1 (0 points)
    Ok, Safari's working again, all by itself...

    Nevermind.
  • David DeCristoforo Level 5 Level 5 (6,170 points)
    Carolyn's advice is solid. But after you have done everything she suggested, don't forget to quit and relaunch Safari. Much of what you are doing effects things that are already loaded into RAM and you may not see the result until you quit and relaunch the program. Sometimes, you might even want to reboot the computer, especially after a disk and/or permissions repair.

  • Jason Ellis2 Level 2 Level 2 (245 points)
    I began having this problem this week while I was visiting my parents' home for Christmas. Firefox browses perfectly, but Safari loads the title "<site> 1 x 1 pixel" for any site that I try to browse to, whether by typing in the address or using the bookmarks menu. I have reset Safari (v404) and I have shutdown/rebooted the MacBook several times since Safari first developed this problem two days ago. One thing that is notable about my experience is that I have been using Starbucks wifi and Safari prior to the problem occurring. I have trashed my Safari folder and I have removed AdBlock and ClicktoFlash software, but without any success restoring Safari to browsing functionality. Any other suggestions? Thanks, all.
  • Jason Ellis2 Level 2 Level 2 (245 points)
    Problem solved--I deleted everything related to Safari (folders, preferences, and the app), and then reinstalled Safari 4.0.4. I am using Safari to write this post.