4 Replies Latest reply: Dec 10, 2009 2:37 AM by Aidan Walker
willo_the_wisp Level 1 Level 1 (0 points)
Hi,

I just bought a brand-new iPhone, brought it home and plugged it into my iMac. As is usual for everything else for the Mac, I expected it to just work... disappointingly it didn't.

I plugged it in, iTunes loaded up (v 9.0) and gave me an error message:
'The iPhone "iPhone" cannot be used because it requires iTunes version 8.2. or later. Go to www.itunes.com to download the latest version of iTunes'.

This confused me - the version of iTunes that I had was 9.0. Just to be sure I went and downloaded the very latest version, 9.0.2 but unfortunately the same error message came up.

Luckily I have another Mac in the house - my husband's iMac (identical except that it's running Snow Leopard). I plugged the iPhone into his Mac, and it worked. However that's no good for me, as I need my iPhone to sync with my Mac, not his.

Does anyone have any idea what to do to solve this?

Thanks,

Willo

iMac 2.66GHz, Mac OS X (10.5.7)