Previous 1 2 Next 19 Replies Latest reply: Sep 21, 2010 4:50 PM by Bovinelife
alice_srq Level 1 Level 1 (15 points)
Since updating to iDVD 09 I have been having problems with changing fonts. Whenever I select text and try to change the font it defaults to Algerian Condensed and I cannot change it to anything else. I've deleted the plist thinking that might help but it did not. I also thought that the font I was attempting to use (veranda) might be "exotic" so I tried other, more standard fonts but always it changes to Algerian Condensed.

At present my project is stuck on Gils San which is better than Algerian Condensed but I would like to change it. Any hints?

Thanks.

Mac Pro 2x2.66 Dual-Core Intel Xeon, Mac OS X (10.6.1), iLife '09, Apeture, Photoshop, Nikon D80 and Canon HD-30
  • SDMacuser Level 6 Level 6 (13,585 points)
    Hi alice_srq




    Welcome to apple discussions.




    First, try using iDvd from a separate user account to see if the problem persists in the newly created account. You can add a new user account by going into system pref's > accounts. The +plus sign at the foot of the dialog box will help you add a new user after it's unlocked (if that's how you set up your mac). You will need to have access to your password / admin to do this. If the same problem persists and you have already tried disposing of the plist for iDvd




    com.apple.iDvd.plist

    (located in your preferences folder)



    then perhaps (and this is just a guess) you have to resolve a duplicate fonts issue. You can do this within Mac Fonts Book like this:



    click here




    Secondly read this link. It will help you manage, validate, and organize fonts.




    Hope this helps but if not just come on back.




    Message was edited by: SDMacuser
  • RMT07 Level 1 Level 1 (5 points)
    Mine is doing the SAME THING! Did you figure yours out? It keeps going back to that Algeria font... and won't change.
  • mc986 Level 1 Level 1 (5 points)
    Just am now having this same problem and it's so frustrating, the .plist file definitely did not help and Font Book shows no duplicates or issues to resolve (no yellow warning signs, etc.) I'm stumped.
  • mc986 Level 1 Level 1 (5 points)
    Hey, I just tried something and it seems to have worked. Click the new text object you created and go to Advanced > Reset Object to Theme Settings. This then puts the font back to the theme's font, but for some reason it now accepts any font you change, even in new text objects created. Just tried save/quit and reopening the project and the problem seems to be completely gone, even after restarting iDVD. I have no idea why this works, but it did for me. Cheers, though I hope someone fixes this bug for the future.
  • mc986 Level 1 Level 1 (5 points)
    Ah, now it's back to not working. So frustrating. Sorry for getting hopes up, but I'll keep working on it.
  • mc986 Level 1 Level 1 (5 points)
    Now it works again, sorry for the multiple posts. It looks like do what I said above, but if that doesn't work alternate between clicking random fonts and selecting/deselecting the object as well as maybe saving/closing/opening iDVD.
  • mc986 Level 1 Level 1 (5 points)
    Okay, well after running into numerous other iDVD issues (Anamorphic 16:9 DV from Final Cut Pro, crashes/errors while encoding) and wasting so much time, here's the workaround I've found that has worked consistently as I've tried different themes and everything.

    1. You make a new text object (Command+K), which is automatically the font the theme declares (and which you want to change).

    2. You try to change it to anything, it changes to Algerian Condensed.

    3. You go to Advanced > Reset Object to Theme Settings

    4. Font changes back to original theme font.

    5. You try to change it to anything, it changes AGAIN to Algerian Condensed.

    6. Repeat 3.

    7. Now, when you change it the third time after two Reset Object to Theme Settings, it should go to whatever font you want.

    Hope that works for you, it's been pretty consistent for me in iDVD 7.0.4 in OS X 10.6.2
  • alice_srq Level 1 Level 1 (15 points)
    Thanks for your posting. Sorry it has taken a while to get back. I finished the project I was working on last November with the default Helvetica and it worked well enough. But now I'm working on another and the problem is still there. I tried all of the recommendations you suggested but I'm still unable to change fonts. I've tried just clicking among the themes and trying to change fonts. When I do that I get one or two changes of font and then we're back to Algerian condensed. So, I figured I could use that trick to at least get the opening font I want but, wouldn't you know it, the trick didn't work on the theme I chose (one of the 6.0 themes). So, then I thought maybe it was related just to the older themes but no such luck.

    I can complete my current project using the font iDVD is forcing on my but I would really like iDVD to mirror the show I've put together in Keynote.

    Anyone else had luck fixing this problem?
  • alice_srq Level 1 Level 1 (15 points)
    mc986,

    Thanks for being so diligent in trying to resolve. I appreciate your response and did get some success but it was fleeting.

    I'm sending a problem form to Apple. Hope you will do the same.
  • jwegman Level 1 Level 1 (10 points)
    I'm running into the same problem. It's clearly a bug. The workaround I found is just to change it to the font you want, then when it jumps to AG, change it again to the font you want and also change the font size. Somehow that jolts the machine into using the correct font.

    My problem now is that I want to use upper and lower case letters, and so far the themes I've been experimenting with in iDVD '09 require you to use all caps, which is pretty ugly. Anyone know how to get around this?

    Thanks.
  • Bob Ginn Level 1 Level 1 (0 points)
    Interesting that I found my problem listed on the first page of the forum. In editing scene selection screens, the text for one movie chapter would not edit. On the other twelve chapters, I was able to change font and size using the Inspector, but only after letting it first change to Algerian Condensed LET; the next change, to Verdana, stayed. On the one scene, I did get it to Verdana, but could not resize the font (it was way too large). After reading the comments from mc986, I highlighted the chapter in the scene selection screen, did the Reset Object to Theme Settings thing, and went through the font change process, which worked (again only after tracking through Algeria). Many thanks for the fix. Now, I hope Apple will fix the bug. My machine is one year old, so don't know whether I have iDVD 08 or 09.
  • Beverly Maneatis Level 5 Level 5 (7,150 points)
    +so don't know whether I have iDVD 08 or 09.+
    These are the same version, just named differently to go with iLife 08 and iLife 09. iDVD in iL09 is not an upgrade from iDVD in iL08.
  • alice_srq Level 1 Level 1 (15 points)
    Jwegman,

    Thanks! Your workaround did the trick. I'm able to get the font I want, albeit in a round-about way. I agree with you that this is a bug and I did send a report to Apple because, as we know, they pay no attention to this Forum.

    As for your second problem I have no help. I noticed the same problem when I was trying different themes for my current project. I finally chose an older theme which does not have the UpperCaseOnly problem.

    Seems like another report to Apple is in order.

    Thanks again.

    Alice
  • Old One Level 1 Level 1 (0 points)
    Thank you so much for your post mc 986 - I have only just encountered the same problem myself, when trying to edit the file name font of the movie imported into iDVD, and I have been using iDVD 08 for the last 20 months and burned heaps of DVDs with no problems like this - since I purchased the iMac - sure hope that your work a round will do it for me
Previous 1 2 Next