12 Replies Latest reply: Dec 7, 2009 3:35 PM by dreaqmtheater61
dreaqmtheater61 Level 1 Level 1 (0 points)
I'm trying to download the latest version of itunes, actually I've tried downloading several different versions now to no avail. I'm using vista and have tried everything I have came across and nothing works. I have all the latest windows updates. I've tried unblocking after downloading the installer, I've tried downloading from both FF and IE8 and checked the "download even if signature is invalid" box in IE. I've been trying to download for months now and cannot figure out what is wrong or what is left to try. Ultimately I'm wanting to buy an iphone but looks like apple isn't gonna get my money if someone doesnt fix the **** file!

Toshiba
  • dreaqmtheater61 Level 1 Level 1 (0 points)
    Also, I've tried downloading older versions as far back as 7.6, hoping to get an install and possibly do an update to 9.0, but no dice. Each setup has an invalid signature which dates back to March 12th... has apple has this issue for that long? And has ANYONE heard anything from Apple regarding this issue? I'm finding it all over the boards and internet, so this is not a minuscule problem.
  • Pamela Gadsden Level 3 Level 3 (950 points)
    Are you getting this error : Windows reports that iTunesSetup.exe is not a "valid Win32 application

    If so check out this article : http://support.apple.com/kb/TS1406

    2, more detailed descriptions, of the fix here : http://www.zolved.com/synapse/viewcontent/28312/Itunes_Error__iTunesSetup_exe_is_not_a_valid_Win32applicat

    and here : http://hubpages.com/hub/itunes-setup-exe-not-a-valid-win32-application-error

    edit : If all else fails have a friend download the latest iTunes/Quicktime and burn it to disk for you.

    In addition you may want to use the Windows Uninstaller : http://support.microsoft.com/kb/290301
    That should give you the necessary basis for a clean install of iTunes software.

    Message was edited by: Pamela Gadsden
  • dreaqmtheater61 Level 1 Level 1 (0 points)
    doesn't say not a win32 application, always says invalid signature.
  • dreaqmtheater61 Level 1 Level 1 (0 points)
    And now I'm finding out that I have to pay to contact apple to speak with them directly? Is there anyone who can help?
  • polydorus Level 6 Level 6 (11,950 points)
    This invalid sig problem has been a real pain. We suspect that the router is often involved although there are other possibilities.

    A few simple things you can try to help isolate the cause of the problem:
    Restart your router and your PC.
    Try plugging in if you are on wireless.
    Check the settings in your router against your ISP's documentation.
    Try another browser e.g. firefox or chrome if you are using I.IE.

    If you have another PC at your location, can you download a good copy of the iTunes installer with that?

    If you are using a laptop, can you take it to another location and try downloading there.

    Otherwise can you get a know good copy of the iTunes installer from a friend?

    After thought: search for posts by bnoir who has been doing a lot of work on this.

    Message was edited by: polydorus
  • dreaqmtheater61 Level 1 Level 1 (0 points)
    After looking through some of bnoir's posts, I decided to try download chrome and safari to try the download there, and I was not able to download either chrome or safari as I was getting the same digital signature message. This leads me to believe that it might be my router after all? I need to install the driver for my usb cable to the modem and in the meantime I will try grabbing a copy from a friend who has a good copy of the installer.
  • polydorus Level 6 Level 6 (11,950 points)
    If you are having a wider problem with digital signing, it would be a good idea to do a scan for malware as that can sometime cause problems with cryptographic services.

    Also run through *Method 4* in this link:
    http://support.microsoft.com/kb/822798

    It ensures that all the relevant dlls are registered and also if there are error messages that can help. If you are using Vista you will get not found messages on 3 dlls as they are not present in Vista -initpki.dll gpkcsp.dll slbcsp.dll

    You should be able to use copy and paste on the individual lines so save typing and for accuracy.

    Problems with these dlls are much more common with XP than Vista.
  • dreaqmtheater61 Level 1 Level 1 (0 points)
    I've already ran windows defender and it said there was no malware or spyware on my system.
  • Pamela Gadsden Level 3 Level 3 (950 points)
    If the copy from your friend runs then you may want to get a different router.
    Was this one from your ISP when you got braodband?
    If not what did you buy ?
  • dreaqmtheater61 Level 1 Level 1 (0 points)
    It was from my isp.
  • polydorus Level 6 Level 6 (11,950 points)
    +I've already ran windows defender and it said there was no malware or spyware on my system.+

    I am afraid Windows Defender is not adequate, do you have any other security software?

    You could run an on line scan, several of the big names provide free scans e.g. Norton, Kaspersky, pandasoft. Stick to a big name, there are many scams out there.


    It would also be helpful to know more about your system.
    operating system, security software, router make & model.

    Posting the full results of the iTunes Network connectivity tests also provides a lot of information. You can copy&paste the results.

    (iTunes>>Help>>Run Diagnostics>>Network Connectivity tests)
  • dreaqmtheater61 Level 1 Level 1 (0 points)
    I DID IT! Gah I was beginning to think this was impossible.

    I bought a wii a few days ago, and after having trouble performing a system update on the wii, customer service narrowed it down to being a router issue (ironic). I logged into my router, went to wan settings, and disabled the spi firewall. The system update worked on the wii, so I tried downloading itunes and it WORKED!