3 Replies Latest reply: Nov 24, 2009 1:21 PM by nottmbantam
nottmbantam Level 1 Level 1 (0 points)
I'm trying to download Firefox, and currently running 10.6, with Safari 4.0.3.

Every time the file downloads, it finishes the download with the small print underneath the downloaded file saying "The operation could not be completed. Safari error Domain error , and of course, it won't mount, or run, so can't install Firefox.

I have had problem with downloaded files before, mainly giving a codec error. I have repaired hard disk, emptied cache on Safari and have also re-set Safari ( apart from first 5 items ) .

Any other suggestions, or what might be causing this?

Cheers.

Macbook Pro 13" 2.26ghz, Mac OS X (10.5.8)
  • 1. Re: Safari - Problems downloading files.
    ~Bee Level 7 Level 7 (30,770 points)
    nottmbantam --

    There could be a couple things that I can think of . . .
    Did you ever download an app to speed up the download process?
    Speed Download is one of them, and if you decide not to use/pay for it, it blocks downloads.

    Also any firewalls, AV apps, parental controls, etc.

    Anything like that on there?
    Or have you disable Cookies for all sites?
  • 2. Re: Safari - Problems downloading files.
    Carolyn Samit Level 10 Level 10 (89,590 points)
    HI,

    Safari add-ons can cause performance issues or other situations

    Also, if you are running Safari in 64 bit mode, try running in 32-bit mode instead. Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode. Quit Safari then relaunch.

    And in the Safari Get Info window make sure Safari is NOT running in Rosetta.

    If none of the above helps, Quit Safari.

    Then locate this file.

    com.apple.Safari.plist

    Move that file to the Desktop and launch Safari. If you a download files without a problem, then there's a corrupted file somewhere in your Safari preferences. Move that .plist file to the Trash.

    Another thing to try is logging in using another user account and see if you can download from Safari there. If you can, the the problem is isolated to just your user account and system wide.

    Could you please update your forum profile to 10.6 please... thanks! Click My Settings on the right side of this window.

    You could try downloading and installing the 10.6.2 combo update available here. One of the "fixes" includes: *-- an issue that prevented opening files downloaded from the Internet*

    http://support.apple.com/kb/DL959



















    Carolyn
  • 3. Re: Safari - Problems downloading files.
    nottmbantam Level 1 Level 1 (0 points)
    Thanks very much Carolyn and Bee. I knew I had not downloaded any plug-ins e.g. Speed Download, and was pretty sure it wasn't any firewall / parental controls.

    So, tried the first suggestion by Carolyn, and changed Safari to operate in 32bit. Quit and re-started, and tried the Forefox download again - worked perfectly . Thank you.

    Just using it for a short time in 32bit mode - I'm sure it works better! Will have to try a more prolonged period of surfing, but at the moment, am surfing on Firefox anyway.

    Cheers.