Skip navigation
This discussion is archived

MacBook Pro (Early 2008) Refuses to Power-On.  Working PSU, Charged Battery

3590 Views 10 Replies Latest reply: Nov 30, 2009 2:31 PM by S.U. RSS
Dash_Merc Calculating status...
Currently Being Moderated
Nov 23, 2009 9:42 AM
Let's start at the beginning. A few days ago, I burned a Gparted LiveCD from an .iso. I'm trying to use it to recover a microSD card that does not register as a device in the first place, and I'm out of simpler options.

This morning, before I left for work, I decided I would test my Gparted LiveCD in my MBP, since I had a few spare minutes. I popped the CD in, and turned on my computer, while holding down option/alt. I selected the LiveCD from the BootCamp menu, and it booted just fine. I told it to ignore all hardware profiles and stuff so it wouldn't have any chance of changing any settings and doing damage. It started up alright, showing the Debain desktop and the Gparted program window. I closed the program window, inserted my USB microSD reader, and reopened the window, so as to refresh the list of connected devices. Ten seconds later, my machine just suddenly powered off.

I look over to my power port, and like an idiot, I had left my computer unplugged (preparing to pack it up for work) while I was doing this. I know better than to run live CDs on my MBP without power plugged in, because most of them can't cope with the MBP power hardware out-of-the-box. I flip over my computer and hit the power test button on my battery. It blinks empty, as i suspected it would after an event such as this.

I plugged my computer back in, and prepared to boot it up into OS X, and to eject the live CD. Nothing happened. "Alright," I thought to myself, "I just have to let it sit plugged-in for a while and let the battery gain a slight charge, as usual, before I can turn it back on." So I do. I wait. I tried turning it back on, but nothing happened. At this point, I was bordering on the time I should leave for work, so I packed everything up, and took it with me to the office. I set everything up on my desk, and I started looking up solutions online. I tried all the troubleshooting steps I could find on any of the top-ten forum results in Google. I tried everything I could find related to my problem on the Apple Support pages. I tried to reset the PRAM, I tried to reset the SMC...and I think I'm out of options.

Finally, I come here, asking for help.

Symptoms:

+MagSafe cable light is green when plugged in.

+Battery appears to be at full charge again when pressing battery-test button.

-No noise, lights, or other signs of life emanate from my MBP when I plug it in or try to turn it on.

-None of the status light blinking or anything mentioned associated with PRAM resets or SMC resets occur.

-My sanity is wearing thin, as this computer is literally half of my life; and I will be depending on it soon for my venture into iPhone/Mac programming at work.

Please offer any helpful suggestions you can that don't involve paying Apple $200 for a one-time support call. I just got a job, and I am still recovering from the results of being jobless (building back up to being ahead-of-the-curve, monetarily). I cannot afford paid support or parts replacements, which is why I am here, asking the community, if there's anything that can be done.

Also, how can I get my CD out of my slot-drive? I don't know of any procedure to do this that doesn't involve the computer powering-on as a prerequisite.

Thank you for your time and support.

Best Regards,

Adrian
MB133LL/A, MacBook Pro (Early 2008), 2.4 GHz Intel Core 2 Duo (Penryn), 2GB RAM, 200GB HDD,, Mac OS X (10.5.8), Serial# W88092M61XR
  • S.U. Level 6 Level 6 (8,360 points)
    Welcome to Apple Discussions!

    Here's a place to start:

    http://support.apple.com/kb/TS1365

    Good luck!
    MBP, 17"hi res, 2.4GHz Intel Core Duo, 4GB RAM, 250GB HDD, Mac OS X (10.6.2), iBook G4, 800 MHz, 1.12 GB RAM, 120 GB WD HD, 10.4.11; 1999 CRT iMac Rev. C
  • S.U. Level 6 Level 6 (8,360 points)
    Just for future reference, here's a link to ifixit if you don't already have it:

    http://www.ifixit.com/

    I am assuming you are out of warranty and don't have access to an Apple Store? If you do have access to an Apple Store, it might be worth a try to make an appointment with a genius and see if you can get a diagnosis. There is no charge for looking.

    What it sounds like is that no power is getting to the logic board. That might point to a problem like a bad left I/O Board or a bad power button. However, I'm not sure how the sequence of events you described would lead to this type of failure. Especially since your power adaptor still seems to be charging your battery.

    Nothing else comes to mind immediately, but I will think about this for a while and post back if something does.

    Sorry not to be able to help more.

    Good luck!
    MBP, 17"hi res, 2.4GHz Intel Core Duo, 4GB RAM, 250GB HDD, Mac OS X (10.6.2), iBook G4, 800 MHz, 1.12 GB RAM, 120 GB WD HD, 10.4.11; 1999 CRT iMac Rev. C
  • S.U. Level 6 Level 6 (8,360 points)
    There should be a couple of pads on the logic board that you can bridge with a screwdriver to start the computer. On mine, they are located near the LVDS cable connector and are labeled PWR BTM and are separated by a white line.

    An 85 watt charger may help, if you have been using a 65 watt charger. Since you are going to the Apple Store, they can use one of their store power adaptors, and I believe that that they can also check out your battery and determine if it has any problems. Batteries do have their own little microprocessor that can get screwed up. The Apple Store may have one of their store batteries they can try.

    They might also be able to determine if the Left I/O Board is OK. It's possible that something has died on it, but I don't know if the board could be repaired or would need to be replaced. Last I checked, it was around $90 on ifixit.

    Post back with what they find. Here's hoping it will be something relatively simple.

    Good luck!
    MBP, 17"hi res, 2.4GHz Intel Core Duo, 4GB RAM, 250GB HDD, Mac OS X (10.6.2), iBook G4, 800 MHz, 1.12 GB RAM, 120 GB WD HD, 10.4.11; 1999 CRT iMac Rev. C
  • S.U. Level 6 Level 6 (8,360 points)
    AWESOME!! Thanks for posting back--this will be a big help to anyone else that has your issue. And a solid indicator of just how awesome an Apple Store can be!

    Happy computing, and thanks for the star!
    MBP, 17"hi res, 2.4GHz Intel Core Duo, 4GB RAM, 250GB HDD, Mac OS X (10.6.2), iBook G4, 800 MHz, 1.12 GB RAM, 120 GB WD HD, 10.4.11; 1999 CRT iMac Rev. C

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.