5 Replies Latest reply: Dec 4, 2009 2:14 AM by extremers
Deleting Songs Level 1 Level 1 (0 points)
So I have an Ipod touch 1st generation, its been working fine with the wireless connection, a couple days ago its just stopped working, it says I'm connected to my network but every time i try to open safari or i tunes or any app it says invalid argument. I've restarted it, restored it to factory settings, and restored network settings. I don't know what else to do. The IP address is 162. something and idk if it needs to be 192. or what? My laptop and computer work fine on the wireless network. Please help!

HP, Windows XP
  • 1. Re: Ipod touch says "invalid argument", I need help
    luvlabs Level 4 Level 4 (3,610 points)
    You need to start with resetting your network settings - tap Settings > General > Reset > Reset Network Settings.

    When your iPod restarts, tap Settings > WiFi > Other. Re-enter your SSID, security scheme, and password. It should log onto your network. If you get the check mark next to your network name, tap the blue arrow again and check your IP address.

    Note: if you are running WEP encryption, consider upgrading to WPA-psk or WPA2-psk. Much more secure and easier to implement.
  • 2. Re: Ipod touch says "invalid argument", I need help
    Deleting Songs Level 1 Level 1 (0 points)
    I tried all that, it still didnt work
  • 3. Re: Ipod touch says "invalid argument", I need help
    luvlabs Level 4 Level 4 (3,610 points)
    OK, time to delve into network issues. It really doesn't matter that your other devices connect and work with the network - the problem is what your network needs to do to connect to your touch. Here's the standard list of advice for you:

    1. Turn your router off. Wait a minute or so and turn it back on. On your touch, sign into your network by the Settings > WiFi > other route.
    - if it works, you're done -
    2. If you are running WEP, change it to WPA-psk or WPA2-psk. If you want to be stubborn and stick to WEP, you will need to use the hex address in Key 1 in place of your password.
    - if it works, you're done -
    3. Download and install the latest firmware for your router - especially important if you are running 3.x firmware on the touch. Log on to your network using Settings > WiFi > Other.

    Let us know if you are still having problems. You might also want to try a public hotspot to make sure there are no hardware issues with your touch's WiFi.
  • 4. Re: Ipod touch says "invalid argument", I need help
    extremers Level 1 Level 1 (0 points)
    Hello

    I have the exact same problem as described above, but mine started since version 2.1 for ipod. I left my ipod alone for about a month or so and just tried to go online yesterday, and I realized that I couldn't. After trying some of the things described above I decided to upgrade to the latest ipod firmware since I thought that would fix my problem, but it didn't. Before when trying to connect with version 2.1 I was getting an error saying safari cannot connect to the internet as well as Itunes Store. Now with 3.1.2 firmware it gives me an error saying Invalid Argument. I took my touch to the Apple store where I got it from but the ipod connects there with no problem and they told me they haven't heard of such issue as Invalid Argument.

    I will try to follow steps 2 and 3 on the post above even though my router is Japanese one. Would you please tell me why is this happening now? I mean my ipod was working fine about a month ago, but I just didn't use it for that time and now it doesn't work.

    Is this a problem of router only or is there anything else I can do to fix this?

    I have an ipod touch 1st Gen with 32Gb 3.1.2 firmware

    Looking forward to hear from you soon

    E

    Message was edited by: extremers
  • 5. Re: Ipod touch says "invalid argument", I need help
    extremers Level 1 Level 1 (0 points)
    E here again I forgot to mention my ipod touch is a 1st gen 32Gb with version 3.1.2 firmware now.