12 Replies Latest reply: Apr 3, 2010 12:48 PM by skibunnie
Dan08 Level 1 Level 1 (20 points)
Whenever I start iCal I get the message:

*The server responded with an error*
The server did not recognize your user name or password for account “xyz.exampledomain.com.” Make sure you enter them correctly.

(I edited the actual server address, of course)
I understand this message, as I had been trying to set up my iCal to talk to a server I had been running, but since I originally did that, I have re-installed Snow Leopard Server on the machine it was syncing with and the server has a new address as well. I was able to set up iCal to run fine with the new server, but for some reason, I simply can't find a way to delete the old account and it's settings from iCal.

Whenever I go into iCal's preferences and highlight the old account and press the minus button, it gives me a warning message saying:

"Deleting the account "xyz.exampledomain.com" will remove all references to the calendars in the account. This operation can't be undone."

I, of course, choose delete. The calendar and the account seem to disappear fine (disappears from iCal preferences and from the calendar sidebar) until I quit and re-open iCal. When I reopen iCal this whole cycle starts all over again and I get the pop-up saying it couldn't communicate with the old CalDAV account...

Any ideas? I've tried the usual stuff (deleted the ~/Library... preferences for iCal, restarted the computer, cleared p-ram, reset SMU, start in safe-boot)...

Details:
iCal - Version 4.0 (1362)
MacBook Pro 15" (late 2008)
OS 10.6.1

MacBook Pro, Mac OS X (10.6.1)
  • John Maisey Level 5 Level 5 (6,895 points)
    Hi Dan,

    It looks like your local iCal database is being overwritten.

    Are you syncing iCal, with MobileMe or another server? Even if not I suggest you re-set your SyncServices database.

    See:
    Mac OS X v10.5, v10.6: Resetting the SyncServices folder

    And:
    Sync Services: Advanced troubleshooting for contact and calendar syncing

    Best wishes

    John M
  • Dan08 Level 1 Level 1 (20 points)
    Thanks John,
    I looked over both these articles and both seemed very promising. Unfortunately, however, every time I start iCal I still see this error syncing with the old CalDAV account, and still seem to be unable to remove it. I tried all the options in these articles (clearing caches, disabling/resting sync services, etc) and nothing seems to work. I'm considering removing the SyncServices folder, but everything on the support website strongly discourages it. It seems like it might be my last option though...
  • Dan08 Level 1 Level 1 (20 points)
    Oh, and I forgot to respond to your question

    @ "Are you syncing iCal, with MobileMe or another server? Even if not I suggest you re-set your SyncServices database."

    I used to sync iCal with MobileMe, but stopped syncing with MobileMe before I ever created the CalDAV setting that is giving me this issue. Currently, I am syncing with a server I have set up that runs Snow Leopard Server's calendar server, but I have had this issue that does not allow me to delete the CalDAV account since before I started syncing with the server I am currently syncing with. Again, as mentioned in my post above, I tried resetting the sync services etc and have had no luck.

    What Apple's support website has to say about removing the SyncServices folder has caused me to shy away from that option. But as a last resort, would reinstalling Snow Leopard fix this if I were to then restore my computer from a Time Machine backup? Or would Time Machine have probably backed up whatever file or setting is giving me this problem, and restoring it from that backup would only leave me having wasted time re-installing and restoring my computer?

    Also, is there a practical way of deleting all files associated with iCal and then re-installing it? and would that help?
  • John Maisey Level 5 Level 5 (6,895 points)
    Hi,

    If you are not syncing to any external device or server and you tried the suggestions on the pages I linked to, next I would make a backup form iCal (from its File menu) and then restore from the backup file.

    John M
  • fred discussions Level 1 Level 1 (10 points)
    Look into System Preferences > Accounts > Options (below the user list) > Network account (or something like Directory service... my system is not in english so I can't give you the right translation) : you could probably see that you have joined a network account or service, which would automatically add the CalDAV account into your iCal everytime you open it. Simply deactivate the network account. That solved my problem ! (Mac OS X 10.6.2)
  • Dan08 Level 1 Level 1 (20 points)
    @fred

    That did it! Thanks so much!
  • Dan08 Level 1 Level 1 (20 points)
    @fred

    That did it! Thanks so much!
  • danpoarch Level 1 Level 1 (0 points)
    The directions above didn't apply to my 10.5 System Prefs. However, I used the same logic and went to:

    Applications/Utilties/Directory Utility and deleted the offending directory service. Next launch of iCal the server account did not re-appear.

    I had rebuilt my server and iCal continually tried to reconnect to the previous build of the server which had a different directory name/service. I too had to delete the server each time I launched iCal on my machine. Which would then sync with all of my MobileMe connected computers and replicate the problem everywhere. It was nothing more than an annoyance. However, more annoying is that I've only just now found the solution after searching for the past year. Search terms are everything i guess.
  • mathis Burkart Level 1 Level 1 (0 points)
    Configuration:
    Server on OSX Server 10.6.2 latest Updates (5.2.2010)
    Clients on 10.5.8 latest Updates (5.2.2010)

    Event:
    - Old Server was on OSX Server 10.5.8
    and was called the same as the new one
    - Server System HD Failiure - previous supportteam made no backup of the server configuration (how stupid is that)
    - New Setup with 10.6.2

    Problem:
    - iCal Server Accounts (CalDAV) are reappearing after reboot of client machine

    Configuration:
    - the server is named the same
    - iCal Accounts are running fine

    Assumption:
    - it has something todo with Kerberos
    - it has something to do with the User Creating Process (managed Users from Old Server, no longer existing)


    Question:
    - How can i change or delete the dependence of a managed user ?
    - How can i change a managed user in to a unmanaged (if the old server is gone) ?
    - Where can i find the managed default-settings

    any suggestions ?
    help ?
  • mathis Burkart Level 1 Level 1 (0 points)
    Tried:
    User:
    - cache cleaning
    - prefs (ical managed)
    - reset syncservice
    - export local calendars, delete all ical files, reimport all local calendars, rekonfiguration of iCalserver account
    System:
    - Reset DirectoryService manualy
  • davidav Level 1 Level 1 (0 points)
    I had what sounds like the same/very similar problem with OS X 10.6.2 Server and 10.6 clients. John Maisey's solution above worked: see Mac OS X v10.5, v10.6: Resetting the SyncServices folder.
    I had to do this repeatedly to get rid of duplicate accounts that kept popping up. From Terminal run /System/Library/Frameworks/SyncServices.framework/Versions/A/Resources/resetsyn c.pl reset, then remove unwanted iCal account from Preferences/Accounts in iCal, then repeat entire process to remove each unwanted account.
  • skibunnie Level 1 Level 1 (0 points)
    Yeah, i've been having a very similar problem too, quite maddening. Here's a solution i just came up with that is the only one that seems to work. Apparently Apple's iSync program has a bug, so to fix it, try this: Go into iSync (its in Macintosh HD / applications), then choose iSync. Then do command-comma or Preferences. Then uncheck enable syncing on this computer. Then choose Reset Sync History (you'll have to do it on second screen too). Then reset computer. Then go back to ical and you can delete events and/or calendars as needed. If you have any trouble go back to isync and turn back on syncing -- seems like the issue does not return.