8 Replies Latest reply: Jan 23, 2010 2:44 PM by Gary Wright4
Karbon Level 2 (285 points)

Is there a "Restart" button for the Mirrored Door Models? Like on the little button below the Power Button on the Quicksilver and the Digital Audio. How do you "restart" it when it's frozen and you can't access the Apple Menu?

I'm working out some "issues" on a sometimes recalcitrant G4 MDD Dual 1.25ghz and I can't find anything in the manual, and while searching for it here has led me into reading many really useful and interesting topics surrounding the mirrored door models, but alasno answer to what I really need to know right now. Having to hold down the power button to (hopefullY) shut it down - or desperately pulling out the power cord is getting really old, lol.

Not sure if it's pertinent, but it has 10.5.8 on one drive and 10.4.11 on the other.

Thanks a lot.


PM G4 867 QS-2002 * G4 533 DP/800 DA * G4 667/1ghz DVI PB, Mac OS X (10.4.11), PM9600/XLR8 G3 384 * Beige MT G3 338 * Indigo G3 366 FW * All run OS 10.3.9
  • Allan Jones Level 7 (33,700 points)
    The single button above the drive doors is all you get on the MDD.

    Like most latter Macs, you can press and hold the button (about 5 seconds) to get a forced shutdown. A single short press only sends it to sleep mode if "Allow Power Button to sleep computer" is checked in System Preferences > Energy Saver.

    If there are power issues and the button is not responding. it can be a bad front panel board (FPB) of which the button is a part. I've been told that this can be diagnosed if you can turn up one of the very early USB iMac keyboards that had a power button (model M2452). It will override the button on the FPB and start the computer.

    In the last few days, someone posted they were able to start a PowerMac using the power button on a older monitor, probably an ADC-type. Same deal--overrides the FPB.

    Fortunately FPBs are much cheaper than power supplies if that proves to be the problem.
  • Karbon Level 2 (285 points)
    Hi Alan. Thanks for replying.

    The power button for this one is working okay for the most part, per se. The problem is that I'm troubleshooting some upgrades which are causing it to sometimes freeze - I was trying to find the least stressful way of forcing it to restart - as with the little restart button on the Quicksilvers and DAs. I've had to pull the power cord out more than once which has led into some other problems, lol - and even forcing a shut down with the power button seems a bit extreme. So there is no way to restart it when there's a problem - a keystroke even?

    The M2452 keyboard is actually what I am using with the MDD right now and I actually was trying to use the old "control + command + power button" to force a restart and I think it might have responded maybe once (could have been a coincidence though) - but not since - I was pretty stressed, so I tried it a lot.

    And... just double checked and hummhhhh... the power button on the M2452 keyboard won't start the MDD up from a cold start nor do a forced restart when the computer is frozen - but it WILL restart it from the desktop when everything is fine - go figure. When I first used the key combination from the desktop, it acted kinda strange - blanked out the screen first, then about 10 or more seconds later finally restarted it (holding it down will bring up the "shutdown - restart - sleep" menu also) - it definitely did not work though when the machine kept getting hung up with kernel panic freezes during start-up.

    Thanks again.
  • Allan Jones Level 7 (33,700 points)
    I think the other button you're using is the "programmers' button." It was standard on Macs for a long time, but it disappeared somewhere between my Beige G3 minitower and my current G4 MDD 1.25G. I understand its vanishing is a function of some broad underlying architecture change.

    I still use the old "Nimitz" keyboard (M3501) on my MDD via an ADB-to-USB adaptor. It has a power button that will not start the computer (the penalty of the USB connector) but does work to bring up the "restart/sleep/shutdown" window. It's the same screen you get when you do "control-eject" on a newer board.

    My KB power button, like yours, will not restart my MDD if it's hung up. I think that's SOP for newer Macs.

    Have you seen Dr. Smoke's tutorial on resolving kernel panics? If you go up one level from the one I linked, there are huge number of very well-presented troubleshooting and maintenance articles.
  • Grant Bennet-Alder Level 9 (55,305 points)
    One thing I like to do to get more info about goofy Macs running Mac OS X is to always start up with the V option (Verbose mode). This gives you the screens of scrolling startup scripts and stuff, and sometimes shows them when the machine is shutting down as well. Holding the key gets old in a hurry.

    You can set the nvram parameter
    to contain
    and it will start up in verbose mode every time thereafter, until the pram/nvram is reset.

    In terminal:
    sudo nvram boot-args= -v

    Another hint is that the light for the caps lock key is under software control. if it is not responding, the software is stuck somewhere, not just slow to respond. Also, setting the menubar clock for flashing separators acts like a "heartbeat".
  • Karbon Level 2 (285 points)
    Hi again Allan, and Grant also. Thanks for your assistance and suggestions .

    Yes, on the G4's, Quicksilver and earlier, there was a programmer's button (used mainly for firmware updates - by me anyway since I don't "program", lol), but there was also a little button either below the power button, or beside the reset button, depending upon the model, that would let you restart the computer from the front panel of the G4 in case you weren't able to access the proper Restart function under the Apple Menu. I am getting more comfortable with just holding the power button to shut it down or using the power button key-combo restart on the old keyboard when needed - which seems to be less and less.

    And thanks for the link on resolving kernel panics and starting up in Verbose Mode - I will indeed use and keep them for reference. In this case though I think I know what's causing the panic attacks - I'm upgrading and setting it up for someone else (so it must be kernel panic-free before I pass it back or they'll having panicked kernels too, hehe), and I had added two items this MDD seems not sure about - a 512mb RAM module that I got locally and which while not having been used in a Mac, is made by a reputable manufacturer (Hynix) and meets all the MDD requirements - and a USB/Firewire combo card that had been listed as mac-compatible, but which I could not get to work in my Quicksilver neither - both machines see it but won't mount anything plugged into it. It has the VIA chip (which I've read is faster than the Nec chip), and I've actually had good luck with VIA-chipped usb/fw combo cards, especially in my pre G4 machines (I've had two Adpatec combo cards poop out on me in the past year - FW side - yet one of the VIA combo cards, I've been using trouble free for seven years now) - this one has a newer chip version though and I guess it's not compatible after all - and when in the MDD, is causing problems. I'd read that the MDD is picky about what goes into which PCI, so I have tried them all, but... no go, so I just left it out.

    The 512mb pc2700 module I added though is a weird one - I've run memtest, rember, tech tool deluxe and diskwarrior and all of them say the ram is all good - and everything is fine for a bit then... it won't completely boot (kernel panic time), does boot and is okay for a bit, then kernel panic time, runs slow and other weirdness - but much better after I removed the usb-fw card. When I go back to the original memory only (only 4x 128mb = 512mb), it appears problem-free, but much slower to work from - and I hate to waste a perfectly piece of seemingly good ram though, so have continued experimentation - trying different slots and in different order with the other ram (I'm going to try and order more RAM from one of the places in the USA I think Allan suggested - sometimes problematic over the border when you don't use credit cards though). The first problem I had was with the original installation of Leopard on the drive which turned out was badly damaged and caused panic just by itself - I zeroed the drive and re-installed Leopard and the mdd was much happier after that. Then from reading more and more posts here from you and others about other aspects of the MDD (this is my first one), such as using cable select on the hard drives - I'd read before that the mdd uses it, but had hooked the drives up the way I'm more familiar with (old school) - so I re-opened it and changed the hard drive setup to CS, removed all the ram, etc, did another pmu reset - started up an hour later and it appears happier now - it's been 24 hours and so far, so good - with the 512mb ram in the second slot with the other ram pieces. I've zeroed out a 320gb hard drive after copying almost 200gb's of data from one backup drive to another (using on-board FW), installed some software, and such - no panic attacks yet. I'd noticed before that the machine was pretty clean inside and I don't find it to warrant the nickname "wind tunnel" at all - half the noise of my Quicksilver, so perhaps the fans have already been upgraded.

    One other weird thing is that it completely gets hung up if I try to boot it from either of my back up drives (one installed internally, the other firewire) that have Tiger installed and were formatted for/from my own Quicksilver. I know it's not good to run a particular machine from an operating system that was configured for another model, but I knew both these drives had stable working operating systems installed and initially wanted to just boot from them to try and troubleshoot the MDD. I've done that with various macs without an issue (a friend of mine even booted his G5 from my FW backup drive when his drive crashed so he could retrieve his data.), but not with this one. The MDD seemed to freeze in terror - created a complete state of confusion that not even trying to go back to boot from the original drive, or from the leopard installation disc would cure. Had to completely zap the pram, unplug it for a while, then re-zap pram again, before I could restore order (and no matter what ram was installed). The only thing I can think of is that they both have had OS 9 installed (bootable installations) and reading about the MDD needing OS 9 installed from it's restore discs (which I don't have), makes me wonder if that's the problem? It has no problem with booting from the clean install of Leopard I installed on it's original drive - and, I can open programs installed on my drives - just can't boot from them.

    Oh well. Thanks again for your help (and listening, lol).

  • Gary Wright4 Level 1 (95 points)

    I just found your comment in this old thread:
    ".. the light for the caps lock key is under software control. if it is not responding, the software is stuck somewhere..."

    I have been experiencing screen freezes - fixed cursor, no keyboard control, and NO CAPS LOCK LIGHT, and no mouse LED light. Also, if I plug my mouse into the USB 2 port of my Belkin PCI card, no LED light, there either.

    I've been assuming that no light means no USB power, and therefore, it is more likely to be a HARDWARE problem - but your comment makes me think I should be troubleshooting as if software.

    Where can I find out more about how USB power is controlled by software?

  • Grant Bennet-Alder Level 9 (55,305 points)
    Gary Wright wrote:

    I've been assuming that no light means no USB power, and therefore, it is more likely to be a HARDWARE problem - but your comment makes me think I should be troubleshooting as if software.

    I believe you are correct, that yours is likely a software problem -- at least when it comes to the power that turns on the light in a mouse. When the software is crashed, plugging in a new mouse has No Effect, but the USB card may be working just fine.

    When the software is running, but perhaps only one Application is "stuck", the light in the mouse typically will come on, even though things may be sluggish.

    Message was edited by: Grant Bennet-Alder
  • Gary Wright4 Level 1 (95 points)

    Thanks for your reply.

    Rather than trying to hijack this older thread, perhaps you could look at my problem as posted here:

    japamac has given me a lot to chew on, but another perspective is always welcome.

    As it now stands, I've tried reducing heat buildup at the CPU; too soon to tell if the problem is solved.

    If the problem returns, I'll have to decide if to pursue hardware (I have a known-working logic board I could try) - or software, such as Disk Warrior (which I will have to buy), or perhaps an Archive-and-Install. These are all major steps, so if someone with more troubleshooting experience than me can see the better path, I'd welcome the input.