Previous 1 2 3 Next 34 Replies Latest reply: Mar 17, 2010 9:02 PM by ballzo Go to original post
  • Tom Nash Level 1 Level 1 (15 points)
    Tried that again. Didn't work for me. I'm running 10.6 Server so possibly this works for those on 10.6 but not OS X Server.
  • PBICS Level 1 Level 1 (0 points)
    Same here - 10.6 Server.

    Where is the com.apple.preview.plist file found?
  • fmwhelp Level 1 Level 1 (0 points)
    Hello,
    the file is located in:
    user/library/preferences

    PS: I have not yet tried this fix. Keeping my fingers crossed.
    Thanks,
    FMW
  • fmwhelp Level 1 Level 1 (0 points)
    iGary,
    Tried the trick. Sorry to report it did not do the trick for me.

    BTW, what are plist files? I have over 4 thousand of these.
    Thanks and have a good day.
  • wayne mitzner Level 2 Level 2 (400 points)
    It's a major bug in Snow Leopard. I've discouraged many from installing it, until they get the bug fixed. Preview can't be used like it used to be. In fact it now has almost no use at all. One step back to the old acrobat and photoshop. Tsk tsk, Apple.
  • Tom Nash Level 1 Level 1 (15 points)
    Has anyone else here checked iphoto? Not only can I not view jpg's in Preview but iphoto won't display any photos but only the small preview/thumbnail. As soon as you click edit or double click the photo, I receive a blank window just like in Preview.
  • fmwhelp Level 1 Level 1 (0 points)
    Hello,
    I never did receive an answer that would render my question "solved" so what I found:

    I had ~78 pictures in a file that I had taken with my camera phone. Most pix would not show in the quick view...only a black background with a thin line down the center (x-ref my original post).
    Other pix did appear in quick view. So, I looked at the files, sorted them and discovered that the ones that would not appear in quick view had no "date created"; that column had "---" for all the photos that were not showing up in quick view.

    I copied those pix and imported to iPhoto. Copied from iPhoto back to my original folder. Guess what? With the exception of 2 photos that refuse to appear with quick view, the others--~ 75 pix--do show up in quick view. They now all have the same "date created", which happens to be yesterday, but that doesn't matter.

    Check to make sure your photos have "date created" since that apparently was my problem. Why? I don't know what difference it makes to quick view, but somehow it must.

    Thank you,
    FMW
  • fmwhelp Level 1 Level 1 (0 points)
    See my post dated today, January 23, 2010 (fmwhelp).
    Hope that helps.
  • amendment13 Level 1 Level 1 (0 points)
    I'm having the same problem, on a brand new Mac Book Pro running 10.6.2. Jpegs won't show in preview. For now I'm opening in Firefox.
  • Tom Nash Level 1 Level 1 (15 points)
    Hey Amendment13

    Could you check to see if any imported pics into iphoto (in jpg format) are also having the same problem. My entire iphoto library of jpegs aren't viewable. So no Preview and iPhoto viewing of jpgs.
  • wayne mitzner Level 2 Level 2 (400 points)
    When i had this problem, i ended up calling Apple, and they had me delete several preference files. That fixed it. I don't recall all of them, but they must have a number of people with this problem, since they knew exactly what to do.
  • Judy Level 4 Level 4 (2,235 points)
    Move ~/Library/Application Support/Preview/PDFIndex4.sk to the desktop

    It worked for me. Also, I put it back, and Preview is still working so far.

    I deleted com.apple.preview.plist, but that did not fix anything.
  • gmasch Level 1 Level 1 (0 points)
    Symptom: jpegs opened in Preview 5.0.1 result in blank window, but Sidebar thumbnails are fine.

    Neither of the previous suggestions is possible for me, since I cannot find "/Library/Application Support/Preview/PDFIndex4.sk" (or com.apple.preview.plist, for that matter) anywhere on my iMac. My Application Support folder does not contain a Preview folder at all. This seems a bit odd, but who knows? I just did the upgrade to Snow Leopard last week, and have had to upgrad a few other things that broke (Canon scanner driver, etc.)

    So the question really is this "does Apple intend to fix this with a new version of Preview, and if so when? I have ver. 5.0.1 - Is there a newer one that I missed?
  • wayne mitzner Level 2 Level 2 (400 points)
    there are 2 Library files, one in the main hard drive directory, and the other in your user library --
    users/"your name"/library/application support/preview/PDFindex4.sk.
    Also, delete the com.apple.Preview.plist, located at - users/"your name"/library/preferences/com.apple.Preview.plist.

    then restart the computer.
  • Tom Nash Level 1 Level 1 (15 points)
    I also don't have a application support/preview in my user or root librarys. No PDFindex4 on my system. Maybe Mac Server 10.6 doesn't have this? Maybe this is the problem. Who knows but still doesn't work for me either.