8 Replies Latest reply: Feb 20, 2010 4:59 AM by timlondon
sysx Level 1 Level 1
I just purchased a Mac Mini Snow Leopard Server to use in my home office. I wanted to use the second drive in the Mac Mini for Mirrored Raid, but was advised not to go that route by an Apple Support person. My next approach was to partition the second disk with three partitions (system, user, backup) for Time Machine Backups and user space. Prior to the partitioning, I was using Time Machine from my 2 Mac clients and when Time Machine did not recognize the new partitions I went back to one partition on the second disk. Now neither of the Time Machine clients can see the new (old) partition on the server.

I can only get "Time Machine can't access the Backup Disk 'Backups' (OSStatus Error 2)from both of my clients when I attempt to select the second disk from Time Machine Preferences. The old backup folder was called 'Backups'.

The Server System Disk's permissions are: System RW, Admin RW, Everyone R.
The other disk's (to be used by Time Machine) permissions are: Me RW, Staff RW, Everyone R. I suspect the permissions changed during the partitioning.

Any thoughts on how to pair the client Time Machines to the second disk, and make the second disk's permissions to look like the first disk's permission?

Mac Pro, MacBook Pro, Mac Mini Server, Mac OS X (10.6.2), iPhone
  • sysx Level 1 Level 1
    Posted on wrong forum.
  • NOTICE Level 1 Level 1
    Was having the same issue, used my free 30 days phone support, now it works - here's what did the trick for me:

    If you can see the "WD_Backup" disk icon, then login as a registered user with the default UN and PW (these are not in the documentation - bad WD, bad...)

    UN: wd_backup
    PW: admin

    Apparently they have other defaults you can try if the combo above doesn't work:

    UN: wd_backup
    PW: backup


    PW: admin
    UN: admin
  • tempotempo Level 1 Level 1
    Hi, thanks very much for posting this - the WD setup had me pulling my hair out, and I was minutes away from ditching the setup - but your:

    UN: wd_backup
    PW: backup

    combination worked for me, and it is happily backing up using Time Machine over the network now - is about 1100029X faster than the crappy WD Anywhere software that came with it (buckled under 700GB+ disk backup over wireless network - took 3 days to "scan + process files" alone.
  • Kevin Guenther1 Level 1 Level 1
    I'm having the same problem and tried the same solution but whenever I select the WD_backup icon, I get a "Connection Failed" notification in the Finder. Doesn't matter how many times I click on "Connect As" The connection dialogue box never comes up and "Connection Failed" remains as the status in the Finder.
  • Kevin Guenther1 Level 1 Level 1
    NVM, I got it... Just misunderstood. You log into the drive the same way just using the WD_Backup UN and PW. Doy!

    Message was edited by: Kevin Guenther1
  • KenChicago Level 1 Level 1
    This is a copy of my post elsewhere on this discussion board:

    I have just successfully set up Time Machine on my MyBook World Edition II NAS. It's not so straightforward, and the information on the Western Digital support site is either unhelpful or flat-out wrong, so here's a post that will hopefully save people in a similar position a lot of time and frustration.

    Here are the key facts:

    1. The MyBook World Edition II NAS does support Time Machine -- if you upgrade to at least firmware Release 1.01.14 (9/29/09). See http://www.wdc.com/wdproducts/updates/?family=mbworld. Amazingly, the Level I support people at Western Digital told me that Time Machine is not supported! I had to point him to this link.

    2. MyBook World Edition II comes with a built-in user, WD_Backup, which appears to be the only user that can be used for the backup.

    3. Follow the instructions here: http://www.wdc.com/wdproducts/updates/docs/en/appletimemachine.pdf. BUT, what the instructions don't tell you is the password for that user, which Mac OS will ask you for during the Time Machine setup. On my device, it was "admin" but other posts say the password can be "backup" or "wd_backup."

    4. Ignore some of the misleading statements in the Western Digital "knowledge base." For example, it says Time Machine is not supported. That used to be true but with the firmware update, is no longer true. Also, some instructions direct you to make a partition on your drive for Time Machine using Disk Utility. This is not possible, as far as I can tell, because the MyBook World Edition II shows up as a "share," not a "device" in the system, and therefore Disk Utility does not see it.

    5. The reason I wanted to set up a partition, where I could limit the disk space, is that I read that Time Machine creates daily backups, with incremental versions of documents. Thus, the Time Machine backup will eventually fill up whatever space is given to it. Since I could not partition the MyBook World Edition II, what I did instead was to enable the "Quota" functionality and then put a disk quota on the WD_Backup user. I hope this will do the trick. (I have the further issue of having two Time Machine backups, one for me, one for my wife. How our Time Machines will battle it out for the disk space, I have no idea.)

    I hope that the Western Digital people will create greater flexibility for Time Machine users in future firmware updates.

    Anyway, hope this helped.
  • timlondon Level 1 Level 1
    Thanks for that solved my problem straight away, bad wd very bad.