6 Replies Latest reply: Mar 27, 2010 4:42 PM by beziermedia
Neyüm Level 1 Level 1 (80 points)
Hi everyone,

I'm not sure when this problem started, but my Bluetooth keyboard has always worked quite well, and I remember using it with my laptop a couple of weeks ago without any issues.

At any rate, I'm using an Apple BT keyboard with Snow Leopard. It pairs and connects fine. I can use it to switch between apps (using command-tab) and the extra buttons (brightness, volume, iTunes controls) work fine. However, I can't type!

I've tried deleting the plist, resetting PRAM and NVRAM and re-pairing. Strangely enough I can enter the pairing code (though the number keys don't work once it is paired).

Has anyone come across this problem before? Unfortunately I don't have another Mac to test this on, but I suspect it may be a software issue, as I can enter the pairing code.

Message was edited by: Neyüm

Macbook 2.16GHz Intel Core 2 Duo, Mac OS X (10.6.2), 4GB RAM
  • gooodkarma Level 1 Level 1 (0 points)
    Same problem for me and I'm using 10.5.8. I have no problems with Magic mouse but The B/tooth keyboard pairs up then fails to allow me to type. the F keys however activate odd combinations i.e. the volume key will open widgets! I have also found that these keyboard issues also are common to the wired Aluminum keyboard. From the many posts I've read i will not solve the problem by upgrading to Snow Leopard. Hopefully someone out there has a solution.
  • Neyüm Level 1 Level 1 (80 points)
    This problem appears to have just stopped for me. I suspect it was something to do with MouseKeys, in the Universal Access Preferences. If this is a problem for you, try turning this off.

    It's still strange behaviour - my in-built keyboard was working while the Bluetooth one did not - but at least it's not doing it anymore.
  • trailwalker1 Level 1 Level 1 (0 points)
    Had exactly same problem as Goodkarma so I did as you said and it all works perfectly now.

    Thanks for your help, this is a problem Apple should be on top of.
  • Toby Neal Level 1 Level 1 (5 points)
    Was having exactly the same problem (modifier keys working, odd F keys and no typing) and turning off the mouse keys in Universal Access worked for me.

    Thanks for the suggestion.
  • hailstorm32 Level 1 Level 1 (0 points)
    This has happened to me twice in the past four months. Once after installing some printer software, and once after a power failure. But in my case, the keyboard works fine until one particular user logs in, after which the keyboard does not allow anyone to type (but other keys like volume and option-command-esc work fine) until the system is rebooted, at which point things are fine until the affected user logs in again.

    I've tried all of the tips in this discussion (deleting the plist, resetting PRAM and NVRAM, and Universal Access) but nothing has worked. The only thing that solves the problem is going back into Time Machine and replacing the entire affected user directory with a backup from before the time when the problem began. Last time this required over 400GB and 4 hours to complete, so it is not the most elegant of solutions...
  • beziermedia Level 1 Level 1 (5 points)
    I just had the same problem. I had to open up bluetooth prefs on the last computer I had paired the keyboard with and clicked on the minus to remove the keyboard. Then when I came back to the computer that wouldn't pair it asked for a passcode. Works now.