Previous 1 2 Next 15 Replies Latest reply: Dec 31, 2009 11:37 AM by b noir
tyler.paquette Level 1 Level 1 (0 points)
Hello there,
I have an issue, on my home computer java runs seamlessly in safari for windows, but here at my office, it just wont run, i downloaded the Sun JRE and installed with Admin priveleges, althought Safari 4 Win includes Apple JRE anyways, it is enabled in my preferences, but whenever i try to use the file manager in Webmin, or any other java applet on the web it just says "Java is Unavailable (SITE) tried to load java content but java is not installed or unavailable, would you like go to a page where you can download java?" and I did it again thinking maybe it required an earlier version, but still nothing. any help anyone can offer me i would be greatly appreciated
Cheers,
P.S. Im running WXP Pro, and JREs 6u1, 6u17

Message was edited by: tyler.paquette

iPhone 3GS 16 GB Blk, iPhone OS 3.1.2, Dell XPS M1730 Laptop/Win7
  • b noir Level 9 Level 9 (72,020 points)
    Experimental advice/troubleshooting here I'm afraid, tyler.

    Try heading into your Internet Options control panel. Click the Advanced tab. Scroll through the list of advanced options. What Java-related options can you see? Are they checked or unchecked?

    (Thinking here I can try to cross match what you're seeing with what I'm seeing on my XP Pro SP3 box.)
  • tyler.paquette Level 1 Level 1 (0 points)
    Control Panel>Internet Properties>Advanced
    under "Java (Sun)" : Use JRE 1.6.0_01 for <applet> (Requires Restart)
    and it is checked, that is the only java option
    Cheers,
  • b noir Level 9 Level 9 (72,020 points)
    under "Java (Sun)" : Use JRE 1.6.0_01 for <applet> (Requires Restart)


    Interesting. Mine says:

    +Use *JRE 1.6.0_15* for <applet> (Requires Restart)+

    In my Java control panel, when I click the "About" button in the general tab, I'm seeing "Version 6 Update 15 (build 1.6.0_15-b03)". What are you getting there, tyler?
  • tyler.paquette Level 1 Level 1 (0 points)
    Version 6 Update 17 (build 1.6.0_17-b04) i also have version 6 update 1, but i installed that a few minutes ago, i saw someone had gotten an earlier version to work. oh, and heres something weird
    Apple Java Plug-In
    Apple Java Plug-In — from file “npJavaPlugin.dll”.
    MIME Type Description
    application/x-java-applet Java Applet
    thats the only listing in my Safari plugins listing for java, though i hear that Safari isn't technically supported by sun Java, thus it uses Apple JRE
  • b noir Level 9 Level 9 (72,020 points)
    Apple Java Plug-In — from file “npJavaPlugin.dll”.


    Hmmm. More experimentation ... but maybe there's an issue with your Safari Java plug-in?

    Let's try swapping it out.

    First, quit Safari.

    Now navigate to C:\Program Files\Safari\Plugins\ (or to whichever drive your Safari is installed on).

    Drag the npJavaPlugin.dll out of that folder onto your Desktop.

    Now launch Safari again, using either the Start Menu or the Desktop shortcut. That should provoke a *repair install* of Safari (you'll see a "configuring" message before Safari launches). That repair install will replace the plugin dll.

    Does the performance with Java on webpages improve with the fresh dll in place?
  • b noir Level 9 Level 9 (72,020 points)
    Another possibility ... I just got my little desktop notification for the Java 6 build 17 update.

    Can you give me a link to a page which is causing you Java trouble, tyler? If so, I could try having a look at it with *build 15* in place, and then try the Java update to see if build 17 breaks my Safari Java capabilities.
  • Louis8ball Level 1 Level 1 (0 points)
    Hi,
    I wasn't sure if this thread had already been closed or not, but if its still open, I'd like to chime in with some comments of my own, as well.

    I too have been experiencing very similar issues with my edition of Safari for Windows. I am running Windows Vista Basic, and my version of Safari is 4.0.4.

    I followed the instructions you gave to the person who started this thread, and after restarting Safari, I am still receiving the same error I was receiving before. Here is what the error says:

    _+*"Pogo.com games use the Java plug-in. You either do not have Java installed or you have a version that is incompatible with our games. It does not cost you anything to install Java.*+_
    _+*Do you want to install the Java plug-in now?"*+_

    Well, I know for a fact that I have Java installed on this machine, and it has been enabled for use with Safari.

    Here is the version of Java which I have presently installed on my machine. Aside from v. 17, I also have versions 1-7, which all show enabled as well.

    Name Java Plug-in 1.6.0_17
    Publisher Sun Microsystems, Inc.
    Status Enabled
    File date Sunday, October 11, 2009, 4:17 AM
    Version 1.6.0.17

    I have attempted (more times than I can remember) uninstalling and then re-installing Java on this machine, and I am still receiving this same error.

    Can you please help?

    Thanks!
  • b noir Level 9 Level 9 (72,020 points)
    "Pogo.com games use the Java plug-in. You either do not have Java installed or you have a version that is incompatible with our games. It does not cost you anything to install Java. Do you want to install the Java plug-in now?"


    Interesting, Louis. Haven't seen that one reported before. (Still, systematic Safari 4.0.4 for Windows troubleshooting is pretty much a work-in-progress, so the fact that I haven't seen it before doesn't necessarily amount to much.)

    This is the first thing that occurs to me after doing a bit of research. By any chance, does your ISP use Slipstream SP web acceleration? If so, it might be worth trying the following "Image Setting" workaround:

    [Why do some Java-applets (such as certain games on www.pogo.com) not work?|http://www.slipstream.com/oursolutions/troubleshooting.html#use_Web8]

    Any luck with pogo after that?
  • Louis8ball Level 1 Level 1 (0 points)
    Well, to be honest it does not appear to be the case that my ISP uses that software/service application. My ISP is bellsouth.net, which is an offshoot of AT&T.

    I do appreciate your input though. Thank you.

    Message was edited by: Louis8ball.
  • b noir Level 9 Level 9 (72,020 points)
    Okay ... head into your Safari settings ("Edit > Preferences") and click "Security". Are Java and Javascript enabled for your Safari?
  • Louis8ball Level 1 Level 1 (0 points)
    Yes, they are enabled, and have been for much (if not all) of the time I have been experiencing this issue.

    I also just uninstalled and re-installed Safari for Windows, and did the same with Java (did it twice with Java) just now. And lo and behold, I am still experiencing the exact same error message at Pogo.

    Does anyone know if, when we download (or update) the newest Java version, does it need to be installed in a specific folder within Safari? If so, where? Can someone give me the file path, please?

    Thanks!

    Message was edited by: Louis8ball
  • Louis8ball Level 1 Level 1 (0 points)
    Well, I'm happy to say, I just found a workaround to my issue, and it seems to work just fine. For anyone who might be interested, here is one way to get there:

    Edit>Preferences>Advanced>Make sure that the "Show Develop Menu in Menu Bar" option is CHECKED.

    Then, whenever you find yourself at a site where you are receiving a message which tells you that you do not have Java installed on your machine (even though you know that you do), then do the following:

    Click on "Develop" (at top of screen, between "Bookmarks" and "Window" (minus quotations)), then select "User Agent", and then click on your version of Safari, but make sure you select the one which says "MAC" after it (yes, even though we are all using Safari for Windows here).

    For example, I have Safari 4.0.4 installed on my machine. So under "User Agent", I click on "Safari 4.0.4 --- Mac", and now I am able to play the games @ Pogo.

    Granted, this procedure might need to be repeated each and every time I change locations within the Pogo game site, but at least I am now able to participate at that website using Safari for Windows.

    Cheers!
  • b noir Level 9 Level 9 (72,020 points)
    Great idea Louis! Many thanks for letting us know about your resolution.
  • Louis8ball Level 1 Level 1 (0 points)
    Oh, that's no problem. I actually found this information posted by someone over in the Pogo community discussion forum, who had been experiencing the same or similar problems. I hope that this info might end up being useful to others here, as well! ; )

    Message was edited by: Louis8ball
Previous 1 2 Next