8 Replies Latest reply: Dec 21, 2009 11:43 AM by V.K.
fieldsnyc Level 1 Level 1
I'm seeing this in my mail.log every minute:

Dec 1 12:27:46 Executor postfix/master[6394]: master exit time has arrived
Dec 1 12:27:46 Executor postfix/master[6399]: daemon started -- version 2.5.5, configuration /etc/postfix
Dec 1 12:28:46 Executor postfix/master[6399]: master exit time has arrived
Dec 1 12:28:46 Executor postfix/master[6406]: daemon started -- version 2.5.5, configuration /etc/postfix
Dec 1 12:29:46 Executor postfix/master[6406]: master exit time has arrived
Dec 1 12:29:46 Executor postfix/master[6409]: daemon started -- version 2.5.5, configuration /etc/postfix

This does not seem to be normal behavior. Is something misconfigured here? How can I fix this?

Mac Pro, Mac OS X (10.6.2)
  • V.K. Level 9 Level 9
    I don't know what this message means but are you actually using postfix mail? if not you can turn it off. those messages should then go away.
  • K T Level 7 Level 7
    expertise.publishing
    Publishing
    Apparently a bug that goes back as far as 2005 - you can file a report, but I'd just ignore it if all else is ok.

    http://lists.apple.com/archives/Darwin-userlevel/2005/Jul/msg00001.html
  • fieldsnyc Level 1 Level 1
    Is postfix used by the system for anything? What's the right way to turn it off? Why might it be running in the first place?
  • V.K. Level 9 Level 9
    the system doesn't really need it. you can turn it off without any ill effects unless you are using command-line mail and it doesn't sound like you do. run the following terminal commands

    sudo postfix stop
    sudo launchctl unload -w /system/library/launchdaemons/org.postfix.master.plist

    you'll have to enter your admin password (which you won't see) after the first command. that's normal.
  • neuralstatic Level 1 Level 1
    just experienced this and found your thread while looking for an answer.

    do you have any thing in /var/spool/postfix/maildrop ? if there is something there, then launchd will keep launching postfix.
    (ls /var/spool/postfix/maildrop)

    i had a file there, and the permissions were wrong for it to process. so it kept launching, but never was able to clear the folder.

    i did a chmod 775 on that document ( something like: sudo chmod 755 /var/spool/postfix/maildrop/* ), and that has fixed it after years of issues.

    i'm not sure it's the best answer, but worked for me.

    Message was edited by: neuralstatic
    btw, i had tried to disable the launchd entry for it, but that was no help.
  • V.K. Level 9 Level 9
    do you mean that postfix was generating this message even after you unloaded the postfix launch daemon?
  • neuralstatic Level 1 Level 1
    correct... well, i disabled that entry from launchd via lingon gui. should do the same thing though. i guessed there was another trigger somewhere must have been monitoring the folder and launching postfix
  • V.K. Level 9 Level 9
    if you disable the daemon via lingon you need to restart the computer afterward for the command to take effect.