5 Replies Latest reply: Dec 3, 2009 7:51 AM by beatrizbeckford
austin m Level 1 Level 1 (125 points)
so i tried installing ubuntu netbook remix onto an external drive, and upon restarting my MBP won't boot to my internal HDD, once it displayed "GRUB_" with a blinking cursor, but is otherwise unresponsive.

now i just get the folder with the ? on it.

I've run disk util, repair permission, repair disk and still no luck.

i can boot the MBP into target disk mode and see the HDD on my other system and all appears to be good, and if i boot to the install dvd, the HDD shows up under the "startup disk" menu, but it just doesn't boot.

any thoughts on how to fix this?

2.8 dual quad macPro, Mac OS X (10.6), 7GB ram x1900 FCS 3 2TB RAID 0
  • Kappy Level 10 Level 10 (260,700 points)
    You've trashed the OS X boot block. The only way to restore it is to repartition and reformat the hard drive.

    Since you can boot into TDM you can backup your files from the drive before doing the above. I suggest using a good backup utility such as Carbon Copy Cloner - VersionTracker or MacUpdate.
  • K T Level 7 Level 7 (23,700 points)
    Run your snow Leopard DVD and use Disk Utility and Disk First Aid from there to check your main HD.

    Disconnect the external HD and reboot if Disk Utility says no issues.

    Or, boot and hold down the V key to see a selection of bootable volumes to choose from....if you get back to your main HD, go to System Preferences/Startup and confirm that selection.
  • Kappy Level 10 Level 10 (260,700 points)
    I'm having a senior moment here. What does the V key do during startup? From your description I thought you may have meant the OPTION key. I know COMMAND-V is verbose mode and the "X" key is supposed to force booting into OS X, but I can't recall the "V" key.
  • austin m Level 1 Level 1 (125 points)
    ok, so i went back to the source, i booted into the the Live cd of UNR and then opened up gparted and was able to modify the EFI partition on the mac's boot drive, then after doing a restart it was able to see the mac as a bootable system and boot to it.

    of note, running the SL installer had no effect on whether the drive could boot or not. i've played with hackintoshes before and figured i'd probably killed the EFI/boot loader. luckily hitting the "required/firmware" box in gparted reset the EFI partition enough to get the mac to recognize it again... now if i could just get UNR installed/bootable on a flash drive.
  • beatrizbeckford Level 1 Level 1 (0 points)
    So I have an imac that I have had for about 3yrs. About several months ago, it started acting a little strange, it wouldnt pick up the mouse or the keyboard at times even thought they were plugged in properly to the usb port, sometimes both would work sometimes one or the other would work and other times they worked fine. About a month or 2 ago, I went to turn my imac on and it got to the screen where the little circular icon pops up implying it is loading, stayed that way for 2-3min then turned of and turned itself back on and did the same thing, made the apple sound got to the load screen turned of after 2-3min then turned back on, it has been doing that for the past month. What do I do?