8 Replies Latest reply: Oct 1, 2005 3:11 AM by Martin Neuss
Martin Neuss Level 2 Level 2 (370 points)
hi all,

i´ve a draxtek vigor 2500 we (wireless)router/switch/modem. with my new ibook i tried to get wireless access to the vigor.

there is no problem to connect to the wireless network with my ibook but i cannot get a dhcp lease, the ibook always generates it´s own ip-address and ignores the vigor completely. when i try to ping the router or other computers on the lan the operation times out.

so when i use the normal 100mb ethernet connection all works, when i use wireless access i cann connect to the network but nothing else works.

any suggestions ?

martin

ps: using tiger, newest firmware etc.
  • Matthias Rempe Level 4 Level 4 (1,560 points)
    Hallo Martin,

    what are your settings for Airport? Check "Systemeinstellungen/Netzwerk/Airport". Switch to the tab "TCP/IP" and check whether "DHCP" is selected ("IPv4 konfigurieren").

    Check on your vigor "Grundeinstellungen für das Funknetz": until you get a connection, uncheck "SSID verdecken". At "WEP Einstellungen" check "Verschlüsselung". For a first try, set "Verschlüsselung" to "aus".

    Then try again to connect and watch at the "TCP/IP" tab for the ip address.

    HTH

    Matthias
  • Martin Neuss Level 2 Level 2 (370 points)
    thanks for your prompt reply.

    all settings are as they should be - as i tink they should be.

    of course dhcp is enabled, of course the ssid is shown etc.

    as i said: i can connect to the network - even with wep authentification - but after the connection is established nothing works as it should.

    - pinging the router and other computers on the lan results only in "host is down"
    - no dhcp lease is granted.

    it seems as if os 10.4 doesn´t recognise the dhcp server at all or as if the wlan is separated from the lan. are there any settings on the router which "connect" the wlan to the lan/dhcp-server, ...?

    when i connect my ibook via ethernet all works as it should.

    martin
  • Matthias Rempe Level 4 Level 4 (1,560 points)
    Martin,

    do you have enabled your iBook's MAC address at the "Zugriffskontrolle" settings (vigor)?

    At "Systemeinstellung/Netzwerk/Airport" check the setting on tab "Airport" for "Standardmäßig verbinden mit".

    Gruß

    Matthias
  • Martin Neuss Level 2 Level 2 (370 points)
    do you have enabled your iBook's MAC address at the >"Zugriffskontrolle" settings (vigor)?


    of course. as i said the ibook gets connected to the wireless network but it gets no ip address from the router and pinging shows only "hosts down".

    At "Systemeinstellung/Netzwerk/Airport" check the setting >on tab "Airport" for "Standardmäßig verbinden mit".

    got connected automatically and manually. no problem there. problem comes up after connecting to the network.

    the ibook doesn´t get connected to the dhcp server. this must be a software or settings problem as the hardware is o.k.
    when connected directly by ethernet all is functioning.

    martin
  • Matthias Rempe Level 4 Level 4 (1,560 points)
    Martin,

    connecting wired and connecting wireless use two different interfaces. When the wired method works it does not necessarily mean that the wireless works too.

    Launch the terminal.app and run ifconfig. Among others, you will see an entry named en0 with an associated MAC address (ether 00:xx:xx:xx:xx:xx) and an entry named en1 (Airport) with a different MAC address.

    Because of the two MAC addresses, I asked if you've enabled the correct one in the vigor.

    Also, how can you tell that your Airport gets connected to the network when it gets assigned an internal IP address? I think this indicates that Airport cannot connect correctly to your vigor (network). Additionally, "hosts down" means that you're not connected to the desired network.
  • Martin Neuss Level 2 Level 2 (370 points)
    hi,

    of course i entered the airport-mac into the routers settings.

    I only said that i got "connected", not that the connection is really working.
    I know (?) that i´m connected because the network status display says it so ("sie sind mit dem netzwerk xxxxxx verbunden") and there was no error message at all.
    but the ibook generates its own ip address, doesn´t see the dhcp server and pinging other computers won´t work.
    so i think the physical layer and the first software layers are working and somewhere above is either an error in the settings or a real bug (or feature :))

    I also enabled the routers syslog feature; the logs are coming to my emac. unfortunately the vigor doesn´t send any log-info about the wireless lan - or does it? also until now i haven´t found the airport log file, if there is any.

    so some more experiments this evening.

    I also made contact to draytek: they asked me to assign a manual ip and try again. but yesterday evening after restarting my ibook i didn´t get a connection at all. have to recheck this and test drayteks solution once more.

    martin

    ps: if you want i can send you some screen-shots of my vigor and ibook configuration by email
  • Matthias Rempe Level 4 Level 4 (1,560 points)
    I agree that it's probably the best to try to resolv the problem by private mail and maybe post the result here.

    You can find my e-mail address in my profile. I have my PowerBook and an iMac G5 connected wireless with a vigor 2500we, so I guess we'll find a solution.
  • Martin Neuss Level 2 Level 2 (370 points)
    hi,

    the problem vanished when i had my ibook shut off for approximately 2 hours and not just for 2 minutes.

    when i booted again all worked from the start. dhcp, wep, internet. not only in the dedicated airport-only environment but also in the normal full featured environment.

    so i believe it really was an ibook- or mac os-problem.

    i´ll report if there are more problems in the next few days. i´m curious what will happen when the 10.4.3 update arrives.

    greetings martin