9 Replies Latest reply: Dec 4, 2009 10:14 PM by Katrina S.
bcc42 Level 1 Level 1 (0 points)
I am trying to upgrade my iTunes to the latest version, which I believe is 9.0.2. Whenever I try to upgrade through the Apple Software Installer, it gets about half way through the status bar and then stops and gives me this message:

"iTunes + QuickTime" has an invalid signature. It will not be installed.

I have had this problem ever since iTunes moved up to version 9. I get the same error if I only try to upgrade QuickTime (minus the "iTunes +).

When I download the actual file and run it from my computer, it tells me the file has an invalid signature, asks if I want to run it and when I click Yes, it does nothing. If I run as administrator, after I click yes, the computer asks me if I want to allow it to run, I click yes and then nothing happens.

In the past, I have tried deleting the Users/me/AppData/Temp folder as outlined in the troubleshooting. I have even uninstalled and reinstalled the program in the past and I'd really rather not do it again. I recently downloaded the Windows Install Clean Up and removed all references to iTunes and Apple Software Updater (or whatever it is called). I have tried all of these steps and yet I continue to get the same error.

What needs to be done so that I can get my iTunes updated? I am missing out on being able to do some things, like view movies, simply because I am unable to update my software.

Thanks,

Brad

PC, Windows Vista
  • Katrina S. Level 7 Level 7 (24,090 points)
    There have been more & more posts about this and folks are finding it might be the router they are downloading the files through. Try getting the iTunesSetup.exe while connected to another router network.
    Yep, sounds weird, but at least 4 folks that I've read here on apple discussions had success downloading it from a different wireless network. It's like the routers are messing up the file's signature info.



    Here is a similar post to yours from "gadget44":
    http://discussions.apple.com/thread.jspa?messageID=10652940



    So far, nobody has posted back that they have physical access to the routers causing this. One guy was going to ask his landlord about it...

    Message was edited by: Katrina S.
  • phoenixsuns9351 Level 1 Level 1 (0 points)
    I am currently accessing the internet with physical access to the router and i still get the same message. It will not continue no matter what i do i have tried the same steps including reinstalling the program and still refuses to complete the download
  • Katrina S. Level 7 Level 7 (24,090 points)
    phoenixsuns9351, did you try downloading and installing QuickTime standalone like bcc42?
    And you got the same invalid signature error with the QT standalone install?



    Are you able to download and install anything else, such as the latest version of Acrobat like gadget44 tried? gadget44 was able to DL other stuff, just nothing from Apple.



    We're trying to rule out problems with digital signatures in general ... sometimes other folks have had luck downloading via Firefox browser instead of IE.



    As for your router perhaps causing the problems, what brand & model is it? What's the firmware release running on it?
  • Katrina S. Level 7 Level 7 (24,090 points)
    phoenixsuns9351, do post back with details of your router if you can, please. Here is what I am talking about...the person who got errors using his landlord's router wireless connections, but got things OK from a different wireless router.

    http://discussions.apple.com/message.jspa?messageID=10625410#10625410
  • bcc42 Level 1 Level 1 (0 points)
    Never occurred to me that the router could be the problem and decided to test the theory. I plugged my laptop directly into the modem (you may have to restart your computer to get it to communicate with the modem if you try this) and all the Apple stuff downloaded and installed just fine.

    I have been having trouble with certain downloads from other sites, this may also be the cause of those problems. All I know for sure is the router was the problem when it came to the iTunes/QT downloads.

    For the record, I tried this at both my place and my parent's house. Same problem in both places as we both use Netgear routers. My mother has had problems with downloads onto her computer as well. It may be time to look into a different brand of router.

    Thanks!
  • Katrina S. Level 7 Level 7 (24,090 points)
    Oh, cool that you got it going, bcc42.
    What model Netgear router? Is yours a fairly new model?
    Are there any firmware updates available for it?





    What band are you using - b,g,n?
    Does changing the channel make a difference?
    What kind of security - WEP, WPA?




    Netgear routers may be fine - it could just be some obscure setting causing it.
    Or interference from a neighbor:
    http://kb.netgear.com/app/answers/detail/a_id/1027/session/L2F2LzEvc2lkL29QeVE2R E9q




    +I have been having trouble with certain downloads from other sites, this may also be the cause of those problems.+
    Yeah, I'm not convinced this is an Apple problem....

    Message was edited by: Katrina S.
  • bcc42 Level 1 Level 1 (0 points)
    At my apartment, it could have very well been interference from another nearby router as there were usually 3-6 networks visible (including mine) to my computer at any given time. At my parents' house, their network is the only one showing up. Mom has had some problems in the past with signal strength from the router not being strong at times, but that was not the issue here.

    My router is approximately a year old, parents' is older by a few months but I'm not sure how much exactly. Both are dual band (G & N). Mine is a WNDR3300. Parents have a WNR834B. I got behind on any updates for my router and I would pretty much guarantee that my parents haven't downloaded any updates for theirs unless it makes automatic checks, which I doubt.

    I will look into firmware updates for the routers.

    Thanks
  • b noir Level 9 Level 9 (72,015 points)
    Ooooh oooh!

    I'd definitely check on the firmware for the WNDR3300, bcc ... The documentation from netgear on the latest firmware for the model suggests that it fixes problems with downloading with certain ISPs:

    http://kb.netgear.com/app/answers/detail/a_id/12689

    (No precise details on what sort of downloads or which ISPs, unfortunately.)
  • Katrina S. Level 7 Level 7 (24,090 points)
    +I will look into firmware updates for the routers.+



    Sounds like a good plan. I wonder if the latest firmware will solve your various download problems?



    Did you see the notice on the page b noir linked to?
    +Note: Do not upgrade the firmware using a wireless connection. Please perform firmware upgrade with “wired” or Ethernet connection only.+
    I would definitely follow that advice. Imagine getting one of these corrupted downloads on the router firmware....it might render the router completely useless.