6 Replies Latest reply: Jan 22, 2010 5:17 AM by shabalstaff
OlafMeding Level 1 (10 points)
How can I remove the word "fuer" from my spell checker? I meant to add the word "für".

I added the word "fuer" to the personal dictionary by mistake. Now I can not undo this mistake because the Ignore button for this word is grayed out.

*Here is what I did*: If you don’t want the word to be treated as an error, click Learn to add it to your personal dictionary. (In some applications, you can Control-click the word and choose Learn Spelling from the shortcut menu.)

*Here is what does not work*: If you accidentally add a misspelled word to the dictionary, type the misspelling in the Spelling and Grammar window and click Ignore, or Control-click the misspelling and choose Unlearn Spelling from the shortcut menu.

Thanks for your help.
Olaf

Mac Pro Early 2008, Mac OS X (10.6.2)
  • Golden Shoes Level 5 (4,015 points)
    How to remove a word from the spell checker?.


    That's easy.

    Quit all applications that use the Spell Checker.
    Go to Home/Library/Spelling and open the file named "en" (for English).
    Delete the word(s) you don't want from the file, save the changes and quit.
    Restart the application you were using with the Spell Checker.
  • OlafMeding Level 1 (10 points)
    Thank you that worked (except I also to to log out and back in).

    Olaf
  • shabalstaff Level 1 (0 points)
    I went into Macintosh HD\Library\Spelling but there was no file called 'en' there. Is it somewhere else?
  • varjak paw Level 10 (169,827 points)
    Wrong folder. It's in your user's Home -> Library -> Spelling, as GS said.
  • shabalstaff Level 1 (0 points)
    I found the file -thank you - but it did not solve my difficulty. Let me explain. I could not think how to spell ridiculous and spelt it phonetically, (i.e. 'rediculus') depending on the checker to correct it but pushed the Learn key in error. I had also told it to 'learn' two words in my address that showed up as spelling errors. When I look in the en spellings file the two words in my address are there but not 'rediculus' although Mail still does not show it as a spelling error and it still appears listed in the Spell Checker options.
  • shabalstaff Level 1 (0 points)
    Sorry. Disregard my last message; I am new to Apple as you may have guessed. I found 'rediculus' listed in the "LocalDictionary" file in the same directory. I deleted it and the problem was solved.