3 Replies Latest reply: Dec 12, 2009 7:45 AM by MrsM
MrsM Level 1 (0 points)

I have an early 2008 model MacBook Pro running Snow Leopard and Windows XP through Boot Camp. From searching, I can see that people have had issues booting but their computers had at least turned on - mine doesn't even get that far.

I went to use the computer yesterday and was unable to turn it on. I looked up the Apple support website on another computer and tried the two fixes there (I believe it is called resetting the PRAM and SRAM?) but still no luck.

The battery light indicates that the battery is fully charged and there is no indication on the computer that it is turned on, no light on the opening clip button thing and no light on the Apple symbol.

I am thinking this could be the Logicboard issue but I have never had a problem with video before.

Any help/advice?

MacBook Pro, Mac OS X (10.6.2)
  • S.U. Level 6 (8,360 points)
    Welcome to Apple Discussions!

    You could also try resetting the SMC:


    Do you get a startup chime or is it just completely dead?

    One possibility is that you have the NVIDIA problem:


    If you have access to an Apple Store, it will probably be worth making an appointment at the genius bar and having your Mac evaluated. If it won't boot at all, it will be difficult to diagnose on this forum. I believe Apple does have a way to test and see if you have the NVIDIA problem.

    Good luck!
  • Alling-by Level 1 (0 points)
    Simular issue here.

    Last night, I closed the lid, putting the machine to sleep, as always.
    This morning, I opened the lid again, it started with a Black Srceen, so I though "Let's turn the backlight up" No function there "Reset display?" I closed and re-opened lid, nothing "Restart!" pushed power-button, followed by enter, still nothing, so I held down the power-button to completely kill the machine, then to boot it up. I pushed the power-button again... It started up the fan and disc-drive for 1.5 seconds, then shuts down again.

    I've tried it all, reset SMC, PRAM, checked power-cord, check the battery, boot without battery, re-insert ram, but nothing!
    It seems the power-supply goes on, asks the logic-board for activity, get's no answer, and commits suicied again.

    I'm out of Apple-care, I live in Denmark, so no genius bar for me.

    Thanks in advance!
  • MrsM Level 1 (0 points)
    Hi Alling-by,

    Not sure if you've been able to fix your problem, but it turns out my issue was indeed a battery issue. As soon as it was hooked up to an Apple charger it turned on. We had been naughty and bought a charger off eBay when ours was ruined.

    Possibly you may need a new battery - ours was tested at Apple and had been through over 250 cycles so we will buy a new one soon, but for the moment we are just using the new Apple charger we purchased.

    Hope this helps.