10 Replies Latest reply: Jan 12, 2010 3:16 PM by Stevo1986in
guyphenix Level 1 Level 1 (15 points)
I have come to my wits end with this. I have been trying to sort out this stupid itouch, i have updated it to 3.1.2 and done about 50 restores now. Ive deleted all the apps off the itouch put them back on via itunes then put them on via app store.
Everything else works fine but not downloaded apps.
Anyone have any ideas other than do a restore?
Does it matter what generation it is or if its registered to a computer?

Powerbook G4 12-inch MacAsarus, Mac OS X (10.4)
  • 1. Re: Apps keep closing
    iNexxFear Level 2 Level 2 (380 points)
    Have you cycled the power on your touch after installing an app?

    this can be done by holding the power button and then sliding the red slider at the top across... Then wait a few seconds, hold the power back in until you see the apple logo.

    It sounds like the touch's internal memory for system usage is overflowing and a power cycle could help you.
  • 2. Re: Apps keep closing
    guyphenix Level 1 Level 1 (15 points)
    Yea i tried that a few times at the start before restoring etc and afterward aswell, nout changed
  • 3. Re: Apps keep closing
    iNexxFear Level 2 Level 2 (380 points)
    Now are you putting apps in by the store in the Touch?

    If so have you tried this process with your PC? Someone else here earlier was having issues with Monkey Island and the only way they got it to work is to have the PC install it onto thier touch.

    So erase it out of iTunes' app section... Go to the store, search and download it again and try to install it...

    See if that helps.
  • 4. Re: Apps keep closing
    Boves Level 1 Level 1 (0 points)
    I'm having the same problem, I get into an app and the title screen comes up then it instantly gets out of it again.
  • 5. Re: Apps keep closing
    guyphenix Level 1 Level 1 (15 points)
    Ive put them on via itunes on mac...didnt work
    Put them on via the app store on itouch...didnt work

    Safari,mail etc all grand but downloaded ones as above mentioned by boves open for a second then close.

    Boves
    Have you paid for any apps?
    I havent risked buying as they havent worked for me yet.
  • 6. Re: Apps keep closing
    tjell Level 1 Level 1 (0 points)
    I've also gone thru all the recommended Apple steps. After I reinstall my apps (both free and bought) they work for awhile. Then one or two stop opening and the next day none will open.

    Time to call tech support I guess.

    Tim
  • 7. Re: Apps keep closing
    bs2007 Level 1 Level 1 (0 points)
    I have the same issues. I restored my ipod touch multiple times, I called apple customer service and they were no help at all. All they told me to do is delete my apps on itones and redownload them and that did nothing. Has anyone figured this issue out yet?
  • 8. Re: Apps keep closing
    bs2007 Level 1 Level 1 (0 points)
    i got my apps to work.go to the website below and follow the instuctions. http://www.apple.com/support/country/
  • 9. Re: Apps keep closing
    Richpal Level 1 Level 1 (0 points)
    All of my apps were working fine. Then I added Skiball from the app store.
    Now all of my purchased applications immediately quit after choosing them.
    I have tried:
    Unselecting the apps in itunes and syncing.
    Restarting the ipod touch
    Resetting the ipod touch from the General menu.
    Then another reset with the power and home buttons pressed.
    Retyping my wifi password
    Resyncing just one app.
    (no luck)

    Then I tried the whole procedure again adding a full Restore.
    Then another reset. Again, retyping my wifi password (Grrrrrr)
    That process took nearly 45 minutes
    Then I checked just one purchased app again and synced..

    NO LUCK

    This is a real problem.
    That $.99 Skiball app blew away my astronomy programs and my HP-41c Emulator.

    Apple....What is going on???
    It shouldn't be this difficult.
  • 10. Re: Apps keep closing
    Stevo1986in Level 1 Level 1 (0 points)
    aarrggghhhh i got an itouch 64g and its doing the same. as soon as i sync it to the pc i cant open any of my apps! i took it to an apple store and was given a new 1 but its just done the same thing! what's going on apple?!