Previous 1 2 Next 22 Replies Latest reply: Jan 3, 2011 7:52 AM by w2m3
Vonnie Level 1 Level 1 (0 points)
Hi Everyone,

Recently I was looking through a couple of photo folders using the space bar option (you know how it makes it big and easier to look thought folders without opening everything?) and I get to certain photos and the spinning beachball appears and won't go away. I relaunch finder (as it is not responding) and then it won't open again and I have to shut down and restart. Sometimes shutting down doesn't work and I have to do a hard shut down.

Has anyone else experienced this and does anyone know if there is a solution to this?

Many thanks in advance.

Vonnie

MacBook Pro, Mac OS X (10.6.1), iBook G4
  • CMCSK Level 6 Level 6 (10,600 points)
    How much hard drive space do you have?
  • Vonnie Level 1 Level 1 (0 points)
    I have around 95gb available..
  • augustguy Level 1 Level 1 (0 points)
    I too, have just started getting this same issue where the Finder stops responding. I am also running Snow Leopard and have installed all of the latest software updates, (prior to this issue). I have just reinstalled the OS and it did not the resolve the issue. Any ideas?
  • robcfx Level 1 Level 1 (0 points)
    Same thing here. It started when I used space bar to scroll through things and now it showing up in lots of places. The Installer, USB hard drives... Finder Not Responding is the only error and hard restart is the only cure. The Finder will completely disappear.
  • robcfx Level 1 Level 1 (0 points)
    Same thing here, and getting worse...
  • anastasiyaosh Level 1 Level 1 (0 points)
    The same problem:

    Finder stops responding and most of the time the drop down menu on top of the screen disappears at the same time. If the keyboard is also not responding following the Finder freeze, hard restart is the only option. Had to do two restarts in the last two weeks.
  • jrennell Level 1 Level 1 (0 points)
    This has been happening to me recently as well. It seems related to this issue:
    http://discussions.apple.com/thread.jspa?threadID=2135129&start=0&tstart=0

    I get the same message
    *The application Finder.app can't be opened.*
    -10810
    When I try to reopen the finder after force-quitting it. I have a couple of NTFS-3G volumes as well as SMB shares set up which I think may be related. I do not have anything like MacFUSE installed, it's just straight Snow Leopard finder.

    When the finder crashes, a lot of other applications come crashing down after it. What's strange is some applications can be started, while others cannot. For instance the last time it happened (just before hard-restarting and posting this) I could launch Address Book, but not System Preferences; the program would start in the dock (stops bouncing and illuminated light), but the window never comes up and the menu bar doesn't change when clicking it. Applications that lock up after the Finder stops responding start using 80%+ cpu according to System Monitor.

    I have a feeling this is something related to non-HFS+ drives and disk access. I'm testing out adding the NTFS drives to the Spotlight privacy setting to see if that helps. Other things I will try include removing afp/smb shares from the NTFS drives. I'll report back on the success/failure if I can figure something out. Sometimes the problem happens twice in the same day, sometimes it doesn't happen for 3 days. I've lost work due to this so I'm very interested in a solution.

    *More Details*:
    Snow Leopard 10.6.2
    Drives:
    * 640GB "Macintosh HD" - HFS+ Journaled (Snow Leopard drive)
    * 750GB "Media 2" - HFS+ Journaled (formatted from Snow Leopard)
    * 1000GB "Media" - NTFS (Formatted from Windows 7)
    * 640GB
    - 105MB "System Reserved" - NTFS (Formatted from Windows 7 Install)
    - 640GB "Windows 7" - NTFS (Windows 7 Drive, formatted from Windows 7 Install)
    File Sharing: On - (AFP and SMB)
    Shares:
    * 4 folders from "Media" (/Volumes/Media/)
    * 1 Folder from "Media 2" (/Volumes/Media 2/)
    * My Public folder on "Macintosh HD" (/Users/jrennell/Public/)

    Message was edited by: jrennell
  • Phil Brayshaw Level 3 Level 3 (775 points)
    jrennel - some people (myself included) have had issues with spotlight indexing causing issues with external drives (and network drives in my case).

    you might want to try the suggestions about clearing spotlight indexes on external drives (or disabling spotlight on those drives) in the thread you linked to - if you've not already done so of course.

    also check your logs (Applications -> Utilities -> Console) and see if there's any mention of "mdworker" in there. Also, check if there's any diagnostic dump files being created in /Library/Logs/Diagnostics. The names of the files will indicate which program is crashing and might give you a clue as to what the root cause is.
  • jrennell Level 1 Level 1 (0 points)
    I didn't see any errors or logs related to spotlight, mdworker, or finder. Adding the drives to spotlight privacy, turning off network sharing of those drives, as well as updating to 10.6.3 seems to have cleared the issue up. I have not seen that problem since. Thanks for the tips to check out.
  • ymmark0 Level 1 Level 1 (0 points)
    I'm not sure this is the same as the other discussion mentioned above (probably related though). I'm having the same problem, my finder is crashing as soon as I access a network drive. There is no error message displayed i.e. I don't get
    "The application Finder.app can't be opened. -10810". I don't get anything.

    Rebooting does not help - it fails within minutes of a reboot.

    I've also tried the suggestions - changing the spotlight config and rebuilding LaunchService - none of which helped.

    I notice in /var/log/system.log there are a constant stream of messages to this effect:

    fseventsd[53]: SLOWDOWN: client 0x100828800 (pid 177) sleeping due to too many errors (num usleeps 191)
    May 20 20:17:50 marks-imac-8 fseventsd[53]: SLOWDOWN: client 0x100828800 (pid 177) sleeping due to too many errors (num usleeps 203)
    May 20 20:19:53 marks-imac-8 fseventsd[53]: SLOWDOWN: client 0x100828800 (pid 177) sleeping due to too many errors (num usleeps 215)
    May 20 20:22:01 marks-imac-8 fseventsd[53]: SLOWDOWN: client 0x100828800 (pid 177) sleeping due to too many errors (num usleeps 227)

    fseventsd seems to be related to drives and so this could be related?
    Is anyone else seeing this in system.log?
  • ymmark0 Level 1 Level 1 (0 points)
    further to last, pid 177 is indeed
    mark 177 2.7 1.1 2787732 23000 ?? R 7:06pm 2:14.66 /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder
    so I guess this error this is definitely related in some way.
  • theRCDproject Level 1 Level 1 (0 points)
    Hi,
    I've got exactly the same problem - no error message, Finder unresponsive, and in my logs:
    Jun 6 11:22:13 hostname fseventsd[47]: SLOWDOWN: client 0x100862200 (pid 139) sleeping due to too many errors (num usleeps 1333)
    Jun 6 11:24:16 hostname fseventsd[47]: SLOWDOWN: client 0x100862200 (pid 139) sleeping due to too many errors (num usleeps 1345)

    I believe this is related to the access to the network file system used by Time Capsule, which is also unresponsive.... all other file systems are OK when I browse them (e.g. ls -alR) via the terminal...

    ymmark0 did you find any solution in the meantime?

    Thanks.
  • kevin! Level 1 Level 1 (0 points)
    i'd just like everybody who's having these freezing/lockup type issues to *open /Applications/Utilities/Disk Utility, click on your hard drive on the left side, (it's named Macintosh HD by default, but you may have renamed it) and run Verify Disk, located at the bottom right of Disk Utility's window*
    i'm assuming some of you might be having hard drive issues and not Finder.app issues, HD errors would have a much different troubleshooting process.
  • ymmark0 Level 1 Level 1 (0 points)
    I've not had any luck fixing this. I'm just working with apple to try and find a solution. I've tried creating a new user and testing in that. i found the same behavior, so it's a system wide problem.
    I've repaired the disk permissions - that doesn't help.
    I've verified, repaired the disk - that doesn't help.
    I'm going to try to archive and reinstall - then keep my fingers crossed.
    I was using pathfinder, which was bearable until I discovered that iTunes and few other apps don't like working with it (i've not put much effort into resolving that however and it may be easy to fix).
    more soon.
Previous 1 2 Next