Previous 1 19 20 21 22 23 Next 390 Replies Latest reply: Apr 16, 2014 1:23 PM by tlovecchio Go to original post
  • guy53 Level 1 (0 points)

    Having this problem also. Just bought my first 27" iMac this week and this problem has occured right out of the box. Frustrating.

  • brightangel Level 1 (0 points)

    I just received 2 updates from Apple one which was the WiFi update !! After the install I put the iMac to sleep waited and came back to check it and the WiFi connection was there very quickly.

    Hopefully this will correct the issues everyone has been having.

  • ssazy Level 1 (0 points)

    Same Here!  A few days ago I got the update notice and voila!  Didn't take Apple as long as I thought it might.  They must have been getting a lot of heat even though the guys in the Apple store in Scottsdale acted like they only "just" heard of a couple of incidents!  Nice to not have to manually reconnect anymore everytime you come out of sleep mode.

  • craigfromwinter springs Level 1 (0 points)

    I just checked my computer and it is all up to date and I just had the problem last night.  Computer was locked up and had to shut it down to reestablish internet connection.  It has been about a month since I had the problem and I thought it might be associated with my Magic Mouse (which frequently lost connnection) problem.  I changed to a wired mouse, thought the problem was resolved but no such luck. 

  • goofatyerservice Level 1 (0 points)

    I have it to. I just started using wireless (until Monday I was plugged in) -- and it happens every time the computer is idle. My mom has the same computer and has had the same problem. My computer is up to date

  • Couchcowboy Level 1 (20 points)

    Would everyone please specify if they're talking about a wired or wireless connection. This forum is supposed to be "lost ethernet connection" forum, but has somehow morphed into a "lost WiFi" forum. I think they're two different problems.

  • brightangel Level 1 (0 points)

    My problem was as stated above (WiFi). I did a search and was brought to this forum, and while scrolling through various posts I noticed I was not alone with WiFi issues as is the case with ethernet. Apparently Apple has not found the fix for ethernet yet !! Sorry the site has morphed into WiFi lost after sleep, but in the end it has caused everyone a pain in the rear-end with connection problems whether wired or wireless !!!

  • MBPnewbie1 Level 1 (0 points)

    yup, same here. i installed an update last night, and i've been having an issue with my ethernet losing connection upon waking my 3-month-old mbp from sleep every single time now, and it's extremely annoying.  in 3 months, i had never had this problem before.


    when i run the system diagnostic check, all the lights are green. it takes a few diagnostic tests before my connection is restored.


    seems obvious it was the latest update. now what should i do?


    EDIT: this might be the culprit (see screenshot below) - this EFI firmware update. do i need to reinstall lion?


    Screen Shot 2012-03-09 at 1.47.06 AM.png

  • Apple Smarty Pants Level 1 (5 points)

    After Lion I began having the issue with my 21" iMac.  I'm using ethernet and wifi is turned off completely.  After waking from sleep, it takes 30 seconds minimum for any internet page to load, or any network connectivity.

    Other 27 Mac on the same network" has no issue.

  • Couchcowboy Level 1 (20 points)

    OK, here's my solution after over a year of trying everything under the sun (see previous posts) to allow my iMac to connect to the internet via ethernet after sleep:


    Yep, that's my aswer. Mind you, it's not by choice, but has been forced upon me. I have decided that the Apple Gods have determined that I should be among the "never sleep their computers" camp and I have seen the light and realized that burning a little extra electriciy is worth the convenience of never having to wait for the computer to awaken and the beauty of instant internet access. It's not a's a feature!

  • kyle wagner1 Level 1 (15 points)

    For me, it's both wired and wireless.  I don't think it's directly to do with wifi, may be more to do with what hardware you've got on your machine. See below.


    I was using wireless (Time Capsule, 1st gen) and getting this problem. But directly plugging ethernet into my router (bypassing the time capsule altogether) also failed to resolve. I have a macbook pro (unibody) from 2008 (10.6.8/latest updates), no other known issues. And the same router works fine for my 2007 (white body intel core2duo) imac (10.6.8/latest updates) right next to the laptop - I can sleep/wakeup the imac as much as I like, internet (specifically, DNS) returns within seconds. I was hoping Lion might fix this for my MBP, but it doesn't sound like that's a surefire solution and don't want to spring for the $$ if it'll still be broken.


    This issue appeared for me sometime after Jan 9, 2012. I had no problems waking from sleep before this date.


    The issue typicaly appears after a long sleep, but sometimes even a short sleep is a problem. Restarting is the only option that always works.


    It's definitely a DNS issue for me, since I can still ping,  The posted workarounds (e.g., various "mDNSresponder" calls from Terminal) have usually not worked, though a few times I think the "sudo launchctl load /System.../" followed by an unload did seem to work. But not in the past few weeks.


    Hope this helps someone else figure out what's going on. I've tried everything else I've found in the forums - recreating my network, passwords, fixing permissions, trashing the time capsule plist, etc. This issue has been around so long (years from the dates of some posts), I wonder why apple hasn't fixed it by now.

  • Joseph Sobry Level 1 (0 points)

    Interesting. I had a different problem. My iMAC I7 with 27" screen never goes to sleep as it runs flat out 24/7 running WCG code on all 8 cores.

    Nevertheless the Ethernet adapter went out to lunch and I could not reactivate it.

    I tried everything from recycling the router swapping ports, swapping cables on the router etc. and most of what has been suggested here on these pages.

    I finally powered down and back up and sat there staring at this problem for 10 minutes when suddenly the ethernet started to work and it is still working now about 1 hour after power up.

    Very strange indeed.

    Is there not a message log somewhere that reports hardware problems with peripheral devices?

  • Arkhlight Level 1 (75 points)

    Take a gander at this.



    It's an update for the issue most of you are experiencing.

  • kyle wagner1 Level 1 (15 points)

    Thanks for adding that link, alas I cannot use it since my problem is with a macbook pro 2008, and I'm using the 10.6.8 OS.

  • Stephen Dawson1 Level 1 (5 points)

    Thought I'd post my experiences with this problem, and what fixed it for me. My symptoms:


    After every wake from sleep the network was unavailable to Safari, Mail etc, even though it looked like the network was up according to iStat Menus, Network Prefs etc. Wired LAN.


    After a couple of minutes, according to Hardware Growler, my IP address was released and re-acquired. After that, everything worked.


    Killing mDNSResponder during the initial period got things working, although the IP address was still re-acquired after 2 or 3 minutes.


    This problem started happening suddenly for me. Then I realised that I had been testing my Epson flatbed scanner with Lion and it was still turned on. It's connected via Firewire through a Firewire hub. Believe it or not, turning off the scanner cured the problem! This is 100% repeatable. Scanner on, no network after sleep. Scanner off, everything's fine.


    Go figure!

Previous 1 19 20 21 22 23 Next