Previous 1 23 24 25 26 27 Next 390 Replies Latest reply: Apr 16, 2014 1:23 PM by tlovecchio Go to original post
  • curtisinoc Level 1 Level 1



    Where on my mac (mountain lion 10.8.2) do I find the setting to do this?:

    "disable the ethernet adapter in system settings and enable it again will work every time"



  • Ric91 Level 1 Level 1


    - choose Apple menu > System Preferences

    - select Network preferences

    - select your ethernet connection on the left ("Ethernet")

    - now use the small gear-wheel at the bottom of the panel to deactivate this service

    - click the Apply-Button on the right

    - now use the gear-wheel again to activate this service

    - click Apply once more


    Regards Ric

  • Stephen Dawson1 Level 1 Level 1

    Hi speedandfinality. I think you're suffering a problem that has raised its head since Snow Leopard days. Basically, DNS stops working. Specifically, the mDNSresponder process stops working. Firefox doesn't seem to use this layer in MAC OSX, Safari and Chrome do. Killing mDNSresponder results in it restarting and normal network operation resumes (or you can sometimes just wait a while and it starts working by itself).


    I dug around and found, which mentions this problem for Snow Leopard, and provides a program you can download that kills the process if you don't like delving into Terminal. You can put this in your dock for quick access.


    Actually, for me, I always got this problem when a firewire scanner was connected during sleep. Disconnecting it solved the problem. But there are many, many people with different symptoms.


    Hope this helps.

  • curtisinoc Level 1 Level 1

    Thank you Ric !!

    I was getting annoyed by having to "restart" my iMac every so often when I encountered this problem.  I will use this method next time.

  • speedandfinality Level 1 Level 1

    Thanks for your help.  I tried the ethernet deactivation/activation sequence suggested by Ric91, but that didn't work either.  I don't mind trying the program you suggested or even fooling with the Terminal, but since Firefox works, I will stick with it for now.  It's hard to believe that this has been going on since Snow Leopard and Apple hasn't fixed it.

  • Stephen Dawson1 Level 1 Level 1

    You'll find that most other programs won't be able to access the Internet either. But if web browsing is all that you're doing during the "outage", stick with Firefox by all means.

  • Ronald Hasler Level 1 Level 1

    I had pretty much the exact situation with my new iMac. Intermittent Ethernet disconnection after sleep, followed soon after with total disconnection. Nothing I tried worked. At first, restarting it while it was in the intermittent stage seemed to work but that sure was a tiring scenario. I was almost glad when it stopped working altogether. I have Apple Care so I eventually called and, after determining my modem and cable hardware were not at fault, they recommended a visit to the Genius Bar. GB took no time in assessing the problem and quickly pulled the computer in for a new logic board. I get it back I a couple of days, hallelujah!

  • Ric91 Level 1 Level 1

    Your problem ist complete different than the one described here. If Firefox works you do not have lost internet connetion. So it is pretty normal that this solution will not fix any other problems.

  • curtisinoc Level 1 Level 1

    This thread started in 2009 and its obvious that this is a REAL problem/issue for many people . . .  Apple has to be listening and aware . . . right???  sheesh!

  • danielfinegan Level 1 Level 1

    I was having the same problem - very delayed connection to the internet after waking up from sleep - on my brand new iMac. In my case, disabling the firewall (system preferences-security and privacy-firewall)

    solved the problem.


    A firewall is provided by my FIOS provider, so I have no concerns with shutting off the OS X firewall.


    Regards -



  • curtisinoc Level 1 Level 1

    Thanks again Ric . .  problem occured tonight for the first time in a while.  Just tried your suggestion which worked like a charm.  Sure beats restarting my Mac.

  • KJezza Level 1 Level 1

    I found this problem resolved by switching Airport off and on again. Is my Airport card dodgy?

  • Stokestack Level 1 Level 1

    I suddenly started getting this under 10.8.3, but it's not application-specific.  On waking, the OS will present a dialog saying none of my known networks is available.  But of course it is, and I have to reconnect to it.  Every time.

  • Ric91 Level 1 Level 1

    If I understand your post you connect your network by Airport. This thread is about Ethernet-connections so I'm afraid you won't find answers here.

    Try to delete all of your known networks and reconnect to your network by entering your WiFi password.

  • Ric91 Level 1 Level 1

    Finally I got it working. I visited our local Apple Store several times as my iMac was still in warranty. First they have done a "software reset", whatever this means. I got my iMac back at the Genius Bar completely wiped out and with a new OS X installation - good to have several backups.

    After that my iMac runs well a few days, then all came back to me. One day I had broken ethernet connections nearly on every wakeup.

    I put my iMac back to the Genius Bar. This time they gave me a new logic board. This happened three weeks ago and I had no more problems.

    So it looks like a faulty logic board to me, which some other iMac users confirmed before.