1 2 Previous Next 15 Replies Latest reply: Mar 24, 2010 6:30 PM by Jordan klein
Jay Imerman Level 1 Level 1 (0 points)
This is similar to another thread under OS X 10.4, but I followed it to its conclusion to adding my DNS domain in the search, and it was already there (supplied by my server). I still can't resolve from my Mac.

I have a Windows network (the Macbook is my first of many Macs). When I ping either host name, or host name with fully-qualified domain name (FQDN), I get:

Jay-Imermans-MacBook-Pro:~ jimerman$ ping Wkstn8
ping: cannot resolve Wkstn8: Unknown host
Jay-Imermans-MacBook-Pro:~ jimerman$


If I go to System Prefs > Network > Advanced > DNS, my Windows server appears by IP address, and the search domain is correct.

All of my PCs can resolve host names no problem. The Windows server is the only DHCP server on the network (the wi fi router has DHCP disabled).

Hopefully someone will have an idea?

Macbook Pro, Mac OS X (10.6.2)
  • 1. Re: Can't resolve host name
    Jay Imerman Level 1 Level 1 (0 points)
    I should add that queries using dig and nslookup fail with no results.
  • 2. Re: Can't resolve host name
    cgiacomi Level 1 Level 1 (0 points)
    I'm actually having the same problem on my unibody MacBook running 10.6.2. If I go into nslookup, it will properly resolve the hostname, so it appears that there is an issue where system calls are not properly working with DNS to resolve hostnames.
  • 3. Re: Can't resolve host name
    direwolf8 Level 4 Level 4 (1,280 points)
    If dig and nslookup fail, and you don't have a static entry in your hosts table, then you need to fix your DNS servers. That doesn't point to a Mac OS problem. If the addresses are outside public addresses, try an open DNS server like google's and see if that solves the problem.
  • 4. Re: Can't resolve host name
    Sideways Level 1 Level 1 (70 points)
    I frequently have this problem but have a solution, at least to how it manifests on my MBP. The problem occurs for me when I work on a client site who uses DHCP for client laptops. When I go home and plug into my home LAN, the DNS servers and domain list from home router cannot override the settings from the work site which remain. The way to check this is to open network preferences, click on your network connection type (LAN or Airport) then use the advanced button. Now select the DNS tab. If the entries for dns servers and domain name appear in bold font they are probably wrongly persisted ones.
    Either use a DHCP renew to clear (and/or) if that doesnt work, manually select the entries and press the minus key to remove them. Once the entries are gone try a dhcp renew and the correct values should appear in read only colour.
    Also be aware that there is another issue where you may have set DNS entries in another network location, which then override your current location. Only solution there is to cycle through the Advanced / DNS tab for each location and delete incorrect entries manually before recycling DNS.

    Hope that helps,

    Paul
  • 5. Re: Can't resolve host name
    cgiacomi Level 1 Level 1 (0 points)
    Thanks Paul. I actually resolve it by renewing DHCP too, but the problem never occurred before Snow Leopard, which makes me think that the system calls got screwed up somewhere along the way. I don't have multiple network locations, so it doesn't apply, although it's helpful to know about that being a potential problem.

    Thanks for the response!

    Regards,

    Chris
  • 6. Re: Can't resolve host name
    Alex Motrenko Level 1 Level 1 (0 points)
    Have the same problem. 10.6.2

    nslookup is able to resolve host names
    ping is NOT able to resolve host names
    non of the browsers are able to resolve host names
    Skype will work just fine, including voice calls

    Tried DHCP renew, tried putting in public DNS servers (Google), deleting them - nothing helps.

    The only solution is to restart my computer, than everything works just fine.

    May happen even when I close my computer for a while, open it up again, and need to restart it to connect to Internet correctly. Happens both at home (D-Link Wifi router), and at work (variety of LinkSys routers).

    Never happened to me before, even on Snow Leopard, but started showing up regularly now.
  • 7. Re: Can't resolve host name
    William Kucharski Level 6 Level 6 (14,705 points)
    As mentioned above, if dig and/or nslookup can't resolve names, either you've specified a DNS server you can't reach, or something is wrong where you have no connectivity to your servers at all.
  • 8. Re: Can't resolve host name
    cgiacomi Level 1 Level 1 (0 points)
    Thanks William. As both Alex and I mentioned above, neither of us have nslookup issues.
  • 9. Re: Can't resolve host name
    William Kucharski Level 6 Level 6 (14,705 points)
    Argh - sorry about that.

    If nslookup can resolve addresses but Mac OS X routines cannot, the problem most likely lies in the list of DNS servers being provided either manually or via DHCP.

    Whether due to a bug or design, Snow Leopard occasionally alters the order in which it will consult DNS servers if more than one is listed. This is non-intuitive and different from how BIND-based programs like nslookup work.

    For example, say you specified DNS servers in this order:

    1.2.3.4
    5.6.7.8

    BIND-based utilities like nslookup would always use 1.2.3.4 for lookups, using 5.6.7.8 only if queries to 1.2.3.4 failed.

    However for whatever reason, Snow Leopard's mDNS resolver, which is responsible for all non-BIND DNS lookups, will occasionally direct all queries to 5.6.7.8. If 5.6.7.8 is configured such that it gives a NXDOMAIN response to a query 1.2.3.4 could resolve, DNS resolution will fail in the manner you've described.
  • 10. Re: Can't resolve host name
    cgiacomi Level 1 Level 1 (0 points)
    This is interesting information... I will definitely take a hard look at this and make sure that my DNS servers are both working properly. Thanks!
  • 11. Re: Can't resolve host name
    GPayne Level 1 Level 1 (0 points)
    Had a similar problem, and this solved it. Thanks!
    . Registered domain with one registry service A, which assigned an IP address #1
    . Created hosting account with another company B, which gave me a different IP address #2 (It was a big PIA to hook up the domain with the IP address; next time will get domain registration and hosting from one place)
    . Transferred the domain from A to B
    . Uploaded content to web site at B (from DreamWeaver, via ftp, to ftp.mydomain)
    . Tried to browse new site at B; but got to old site at A
    . After some hours (I understand that these DNS changes take time), browser went to site at company B, but got standard page "this domain is parked here at B" instead of my uploaded home page
    . Clearing browser caches (Firefox and Safari) and restarting browsers made no difference
    . Reboot made no difference
    . I tried our 2 other computers, both Windows: they correctly accessed my home page at address #2
    . "nslookup" resolved to correct IP address #2, but "ping" and "traceroute" pinged the old address #1!
    . System Preferences > Network > Advanced > TCP/IP > "Renew DHCP Lease" fixed it: now ping and browsers go to my site on address #2.
  • 12. Re: Can't resolve host name
    Alex Motrenko Level 1 Level 1 (0 points)
    William -

    Your analysis is interesting, thank you. I am not sure this solves the problem though. I wonder if anyone at Apple is tracking these posts to track down the problem.

    Thanks again for your help
    Alex
  • 13. Re: Can't resolve host name
    William Kucharski Level 6 Level 6 (14,705 points)
    Depends on the problem, Alex.

    Many with this problem have tracked it down to having multiple DNS servers specified, one of which could resolve the address and one that could not.
  • 14. Re: Can't resolve host name
    Jay Imerman Level 1 Level 1 (0 points)
    So, the problem turned out to stem from an old backup. I lost my hard drive on the Windows server and had to revert to an old backup. For some reason, when I restored the backup, the DNS server was not configured correctly. I had to delete and recreate the domain, and everything was happy.
1 2 Previous Next